summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-05-29 12:46:46 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-05-29 12:46:46 +0000
commitc390f5920edf5a65c3980e5b665975794c8ecc43 (patch)
treebf44f7711042a4fe03b17458ead4dbfb8fe3729f /net-mail
parentNew ebuild for dev-python/pyacoustid module for Chromaprint acoustic fingerpr... (diff)
downloadgentoo-2-c390f5920edf5a65c3980e5b665975794c8ecc43.tar.gz
gentoo-2-c390f5920edf5a65c3980e5b665975794c8ecc43.tar.bz2
gentoo-2-c390f5920edf5a65c3980e5b665975794c8ecc43.zip
Version bump.
NEWS ~~~~ (Extracted headlines from NEWS file. See it for details.) - Fix inserting of UTF-8 characters from *text/plain* parts in reply - `notmuch_database_get_directory` and `notmuch_database_find_message_by_filename` now work on read-only databases (Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog16
-rw-r--r--net-mail/notmuch/notmuch-0.13.1.ebuild166
2 files changed, 181 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index 0b75906495d9..f91287009283 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.56 2012/05/19 07:50:41 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.57 2012/05/29 12:46:46 aidecoe Exp $
+
+*notmuch-0.13.1 (29 May 2012)
+
+ 29 May 2012; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +notmuch-0.13.1.ebuild:
+ Version bump.
+
+ NEWS
+ ~~~~
+ (Extracted headlines from NEWS file. See it for details.)
+
+ - Fix inserting of UTF-8 characters from *text/plain* parts in reply
+ - `notmuch_database_get_directory` and
+ `notmuch_database_find_message_by_filename` now work on read-only databases
19 May 2012; Amadeusz Żołnowski <aidecoe@gentoo.org>
notmuch-0.10.2-r3.ebuild, notmuch-0.11.1-r3.ebuild, notmuch-0.12.ebuild,
diff --git a/net-mail/notmuch/notmuch-0.13.1.ebuild b/net-mail/notmuch/notmuch-0.13.1.ebuild
new file mode 100644
index 000000000000..bb04011ae8e2
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.13.1.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.13.1.ebuild,v 1.1 2012/05/29 12:46:46 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.1"
+
+inherit elisp-common pax-utils distutils
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="test? ( crypt emacs python )"
+IUSE="bash-completion crypt debug doc emacs nmbug mutt python test vim
+ zsh-completion"
+
+CDEPEND="
+ >=dev-libs/glib-2.22
+ >=dev-libs/gmime-2.6.7
+ dev-libs/xapian
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ vim? ( || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 ) )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( python? ( dev-python/sphinx ) )
+ test? ( app-misc/dtach sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git virtual/perl-File-Temp virtual/perl-PodParser )
+ mutt? ( dev-perl/Mail-Box dev-perl/MailTools dev-perl/String-ShellQuote
+ dev-perl/Term-ReadLine-Gnu virtual/perl-File-Path
+ virtual/perl-Getopt-Long virtual/perl-PodParser
+ )
+ zsh-completion? ( app-shells/zsh )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+
+bindings() {
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ $@
+ popd || die
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ default
+ bindings python distutils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${ROOT}/usr/share/bash-completion"
+ --emacslispdir="${ROOT}/${SITELISP}/${PN}"
+ --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
+ --with-gmime-version=2.6
+ --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
+ $(use_with bash-completion)
+ $(use_with emacs)
+ $(use_with zsh-completion)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ bindings python distutils_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ mv README README-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ mv README README-python || die
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin contrib/nmbug
+ fi
+
+ if use mutt; then
+ [[ -e /etc/mutt/notmuch-mutt.rc ]] && NOTMUCH_MUTT_RC_EXISTS=1
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/plugin vim/syntax
+ fi
+
+ DOCS="" bindings python distutils_src_install
+
+ if use doc; then
+ bindings python dohtml -r python
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postinst
+
+ if use mutt && [[ ! ${NOTMUCH_MUTT_RC_EXISTS} ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postrm
+}