summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-02-14 19:55:55 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-02-14 19:55:55 +0000
commitc2c82ce5bac2c6c8109c58bd3285fc1fbfafbd48 (patch)
treef25bea0ea4529b944935b8444a8d8282b4f5e8d5 /net-mail
parentFix README installation for bug #258990. (diff)
downloadgentoo-2-c2c82ce5bac2c6c8109c58bd3285fc1fbfafbd48.tar.gz
gentoo-2-c2c82ce5bac2c6c8109c58bd3285fc1fbfafbd48.tar.bz2
gentoo-2-c2c82ce5bac2c6c8109c58bd3285fc1fbfafbd48.zip
initial ebuild
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/vchkuser/ChangeLog10
-rw-r--r--net-mail/vchkuser/metadata.xml12
-rw-r--r--net-mail/vchkuser/vchkuser-0.3.1.ebuild37
3 files changed, 59 insertions, 0 deletions
diff --git a/net-mail/vchkuser/ChangeLog b/net-mail/vchkuser/ChangeLog
new file mode 100644
index 000000000000..990443c9ed22
--- /dev/null
+++ b/net-mail/vchkuser/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-mail/vchkuser
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vchkuser/ChangeLog,v 1.1 2009/02/14 19:55:55 hollow Exp $
+
+*vchkuser-0.3.1 (14 Feb 2009)
+
+ 14 Feb 2009; Benedikt Böhm <hollow@gentoo.org> +metadata.xml,
+ +vchkuser-0.3.1.ebuild:
+ initial ebuild
+
diff --git a/net-mail/vchkuser/metadata.xml b/net-mail/vchkuser/metadata.xml
new file mode 100644
index 000000000000..f0c241515b61
--- /dev/null
+++ b/net-mail/vchkuser/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qmail</herd>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Böhm</name>
+ </maintainer>
+ <use>
+ <flag name='debug'>Enables debug messages to syslog</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-mail/vchkuser/vchkuser-0.3.1.ebuild b/net-mail/vchkuser/vchkuser-0.3.1.ebuild
new file mode 100644
index 000000000000..0dbbf1202c48
--- /dev/null
+++ b/net-mail/vchkuser/vchkuser-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vchkuser/vchkuser-0.3.1.ebuild,v 1.1 2009/02/14 19:55:55 hollow Exp $
+
+EAPI="2"
+
+inherit autotools qmail
+
+DESCRIPTION="qmail-spp plugin to check recipient existance with vpopmail"
+HOMEPAGE="http://bb.xnull.de/projects/vchkuser/"
+SRC_URI="http://bb.xnull.de/projects/vchkuser/dist/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="net-mail/vpopmail
+ || ( mail-mta/netqmail[qmail-spp] mail-mta/qmail-ldap[qmail-spp] )"
+RDEPEND=""
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-vpopuser=vpopmail \
+ --with-qmailgroup=nofiles \
+ --with-vpopmaildir=/var/vpopmail \
+ --with-qmaildir=${QMAIL_HOME}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+}