summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-07-03 16:06:23 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-07-03 16:06:23 +0000
commitbe5f5612640c85cde3d44000fc4d35b4e97242c2 (patch)
tree556ff8b5d74233b68e94ad8305d838e1ea2e5feb /net-mail
parentCleanup old versions. (diff)
downloadgentoo-2-be5f5612640c85cde3d44000fc4d35b4e97242c2.tar.gz
gentoo-2-be5f5612640c85cde3d44000fc4d35b4e97242c2.tar.bz2
gentoo-2-be5f5612640c85cde3d44000fc4d35b4e97242c2.zip
Fix compilation with USE='kerberos', #274838
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog6
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild10
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild10
3 files changed, 21 insertions, 5 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index 75f75cffdbaf..9554c5d19343 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/cyrus-imap-admin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.84 2009/06/12 20:42:43 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.85 2009/07/03 16:06:23 dertobi123 Exp $
+
+ 03 Jul 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ cyrus-imap-admin-2.3.14.ebuild, cyrus-imap-admin-2.3.14-r1.ebuild:
+ Fix compilation with USE='kerberos', #274838
*cyrus-imap-admin-2.3.14-r1 (12 Jun 2009)
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild
index f8391800598b..d4bbf0654fe6 100644
--- a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild,v 1.1 2009/06/12 20:42:43 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild,v 1.2 2009/07/03 16:06:23 dertobi123 Exp $
inherit autotools perl-app eutils
@@ -55,7 +55,13 @@ src_compile() {
local myconf
myconf="${myconf} `use_with ssl openssl`"
- myconf="${myconf} `use_with kerberos krb`"
+ myconf="${myconf} $(use_enable kerberos gssapi) $(use_enable kerberos krb5afspts)"
+
+ if use kerberos; then
+ myconf="${myconf} --with-krb=$(krb5-config --prefix) --with-krbdes=no"
+ else
+ myconf="${myconf} --with-krb=no"
+ fi
econf \
--disable-server \
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild
index f0e1b94715b3..12a89eb944c5 100644
--- a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild,v 1.5 2009/06/08 03:33:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild,v 1.6 2009/07/03 16:06:23 dertobi123 Exp $
inherit autotools perl-app eutils
@@ -50,7 +50,13 @@ src_compile() {
local myconf
myconf="${myconf} `use_with ssl openssl`"
- myconf="${myconf} `use_with kerberos krb`"
+ myconf="${myconf} $(use_enable kerberos gssapi) $(use_enable kerberos krb5afspts)"
+
+ if use kerberos; then
+ myconf="${myconf} --with-krb=$(krb5-config --prefix) --with-krbdes=no"
+ else
+ myconf="${myconf} --with-krb=no"
+ fi
econf \
--disable-server \