summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-11-25 02:06:46 +0000
committerSebastian Pipping <sping@gentoo.org>2010-11-25 02:06:46 +0000
commitb6f34b2df7c4381ee924309911c5f414b03e8cea (patch)
tree67a22e6fa0b4f86a97e223d7ce761d7120803ee8 /net-mail
parentnet-mail/rss2email-2.69: Mask upcoming experimental bump (diff)
downloadgentoo-2-b6f34b2df7c4381ee924309911c5f414b03e8cea.tar.gz
gentoo-2-b6f34b2df7c4381ee924309911c5f414b03e8cea.tar.bz2
gentoo-2-b6f34b2df7c4381ee924309911c5f414b03e8cea.zip
net-mail/rss2email: Bump to 2.69
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/rss2email/ChangeLog11
-rw-r--r--net-mail/rss2email/files/rss2email-2.69-config-location.patch16
-rw-r--r--net-mail/rss2email/metadata.xml4
-rw-r--r--net-mail/rss2email/rss2email-2.69.ebuild61
4 files changed, 90 insertions, 2 deletions
diff --git a/net-mail/rss2email/ChangeLog b/net-mail/rss2email/ChangeLog
index 4a99109bb040..576cdc3a1d61 100644
--- a/net-mail/rss2email/ChangeLog
+++ b/net-mail/rss2email/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/rss2email
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/rss2email/ChangeLog,v 1.2 2009/07/26 13:57:27 rbu Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/rss2email/ChangeLog,v 1.3 2010/11/25 02:06:45 sping Exp $
+
+*rss2email-2.69 (25 Nov 2010)
+
+ 25 Nov 2010; Sebastian Pipping <sping@gentoo.org> +rss2email-2.69.ebuild,
+ +files/rss2email-2.69-config-location.patch, metadata.xml:
+ Bump to 2.69, add support for several Python ABIs, move code and config out
+ of /usr/share, add myself as maintainer
26 Jul 2009; Robert Buchholz <rbu@gentoo.org> rss2email-2.65.ebuild:
Include sample config on regular runs
diff --git a/net-mail/rss2email/files/rss2email-2.69-config-location.patch b/net-mail/rss2email/files/rss2email-2.69-config-location.patch
new file mode 100644
index 000000000000..215c1725a9c1
--- /dev/null
+++ b/net-mail/rss2email/files/rss2email-2.69-config-location.patch
@@ -0,0 +1,16 @@
+--- rss2email.py 2010-11-25 02:22:14.607431246 +0100
++++ rss2email.py 2010-11-25 02:26:54.478306015 +0100
+@@ -254,7 +254,12 @@
+
+ # Read options from config file if present.
+ import sys
+-sys.path.insert(0,".")
++import os
++_conf_dir = os.path.expanduser('~/.rss2email')
++if not os.path.exists(os.path.join(_conf_dir, 'config.py')):
++ _conf_dir = '/etc/rss2email'
++sys.path.insert(0, _conf_dir)
++
+ try:
+ from config import *
+ except:
diff --git a/net-mail/rss2email/metadata.xml b/net-mail/rss2email/metadata.xml
index 19022f09d41a..8334e18679bc 100644
--- a/net-mail/rss2email/metadata.xml
+++ b/net-mail/rss2email/metadata.xml
@@ -3,6 +3,10 @@
<pkgmetadata>
<herd>net-mail</herd>
<maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <maintainer>
<email>rbu@gentoo.org</email>
<name>Robert Buchholz</name>
</maintainer>
diff --git a/net-mail/rss2email/rss2email-2.69.ebuild b/net-mail/rss2email/rss2email-2.69.ebuild
new file mode 100644
index 000000000000..b4436c2028ae
--- /dev/null
+++ b/net-mail/rss2email/rss2email-2.69.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/rss2email/rss2email-2.69.ebuild,v 1.1 2010/11/25 02:06:45 sping Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils python
+
+DEBIAN_PV="2.65"
+
+DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
+HOMEPAGE="http://rss2email.infogami.com/"
+SRC_URI="http://www.allthingsrss.com/${PN}/${P}.tar.gz
+ mirror://debian/pool/main/r/${PN}/${PN}_${DEBIAN_PV}-1.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/patchutils"
+RDEPEND="dev-python/feedparser
+ dev-python/html2text"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-config-location.patch
+
+ # Extract man page from Debian patch
+ filterdiff --include=*/r2e.1 --decompress \
+ "${DISTDIR}"/${PN}_${DEBIAN_PV}-1.diff.gz > "${S}"/r2e.1.patch || die
+ EPATCH_OPTS="-p1" epatch r2e.1.patch
+}
+
+src_install() {
+ my_install() {
+ insinto "$(python_get_sitedir)"/${PN}
+ newins rss2email.py main.py || die
+
+ insinto /etc/${PN}
+ doins config.py || die
+ }
+ python_execute_function my_install
+
+ dodoc CHANGELOG readme.html || die
+ doman r2e.1 || die
+
+ # Replace r2e wrapper
+ cat <<-"EOF" >r2e
+ #! /bin/sh
+ SITE_PACKAGES=`python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()"`
+ CONF_DIR=${HOME}/.rss2email
+ mkdir -p "${CONF_DIR}"
+ exec python "${SITE_PACKAGES}"/rss2email/main.py "${CONF_DIR}"/feeds.dat $*
+ EOF
+
+ dobin r2e || die
+}