summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-13 21:56:06 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-13 21:56:06 +0000
commitb3be67e7c66ec5d4cb9e4a64337745f82eec8fa5 (patch)
tree37dafe020eab77f947ee0faeced3ee78e9e53851 /net-mail
parentphp fix (diff)
downloadgentoo-2-b3be67e7c66ec5d4cb9e4a64337745f82eec8fa5.tar.gz
gentoo-2-b3be67e7c66ec5d4cb9e4a64337745f82eec8fa5.tar.bz2
gentoo-2-b3be67e7c66ec5d4cb9e4a64337745f82eec8fa5.zip
Initial ebuild of cyrus-imapd
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imapd/ChangeLog13
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-2.1.5.ebuild191
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.conf41
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.rc622
-rw-r--r--net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.1.51
-rw-r--r--net-mail/cyrus-imapd/files/e2fsprogs-et.diff336
-rw-r--r--net-mail/cyrus-imapd/files/imapd.conf22
-rw-r--r--net-mail/cyrus-imapd/files/pam.d-imap3
8 files changed, 629 insertions, 0 deletions
diff --git a/net-mail/cyrus-imapd/ChangeLog b/net-mail/cyrus-imapd/ChangeLog
new file mode 100644
index 000000000000..4da07df5b33c
--- /dev/null
+++ b/net-mail/cyrus-imapd/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-mail/cyrus-imapd
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.1 2002/07/13 21:56:00 raker Exp $
+
+*cyrus-imapd-2.1.5 (13 Jul 2002)
+
+ 13 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ cyrus-imapd-2.1.5.ebuild and friends:
+
+ Ebuild and friends created by Alexander Holler. Thank you!
+ Created diff so program will compile with current version of
+ e2fsprogs.
+
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-2.1.5.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-2.1.5.ebuild
new file mode 100644
index 000000000000..e4a56f5b5e5a
--- /dev/null
+++ b/net-mail/cyrus-imapd/cyrus-imapd-2.1.5.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header $
+
+DESCRIPTION="The Cyrus IMAP Server"
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="1"
+KEYWORDS="x86"
+
+PROVIDE="virtual/imapd"
+RDEPEND="virtual/glibc
+ afs? ( >=net-fs/open-afs-1.2.2 )
+ snmp? ( >=net-analyzer/ucd-snmp-4.2.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ >=sys-libs/db-3.2
+ >=sys-libs/pam-0.75
+ >=dev-libs/cyrus-sasl-2.1.2
+ >=sys-apps/tcp-wrappers-7.6"
+DEPEND="virtual/glibc
+ afs? ( >=net-fs/open-afs-1.2.2 )
+ snmp? ( >=net-analyzer/ucd-snmp-4.2.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ >=sys-libs/db-3.2
+ >=sys-libs/pam-0.75
+ >=dev-libs/cyrus-sasl-2.1.2
+ >=sys-apps/tcp-wrappers-7.6"
+
+
+# recommended: flex, maybe: net-snmp, postfix, perl?, afs, inn, tcl (cyradm)
+
+pkg_setup() {
+
+ if ! grep -q ^cyrus: /etc/passwd ; then
+ useradd -c cyrus -d /usr/cyrus -g mail -s /bin/false -u 96 cyrus \
+ || die "problem adding user cyrus"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/e2fsprogs-et.diff
+}
+
+src_compile() {
+
+ local myconf
+
+ use afs || myconf="--without-afs"
+ use snmp || myconf="${myconf} --without-ucdsnmp"
+ use ssl || myconf="${myconf} --without-openssl"
+
+
+ ./configure \
+ --prefix=/usr \
+ --without-krb \
+ --without-gssapi \
+ --enable-listext \
+ --disable-cyradm \
+ --without-perl \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ # make depends break with -f... in CFLAGS
+ make depend CFLAGS="" || die "make depend problem"
+
+ emake || die "compile problem"
+
+}
+
+src_install () {
+
+ emake DESTDIR=${D} install || die
+
+ # Remove the developer stuff (-> dev-libs/cyrus-imap-devel)
+ rm -rf ${D}usr/include ${D}usr/lib
+
+ # Remove the manpages (wrong place)
+ rm -rf ${D}usr/man
+
+ mkdir ${D}etc
+ cp ${FILESDIR}/imapd.conf ${D}etc/imapd.conf
+ cp ${FILESDIR}/cyrus.conf ${D}etc/cyrus.conf
+ mkdir ${D}etc/pam.d
+ cp ${FILESDIR}/pam.d-imap ${D}etc/pam.d/imap
+
+ mkdir ${D}var ${D}var/log
+ touch ${D}var/log/imapd.log
+ touch ${D}var/log/auth.log
+
+ mkdir -m 0750 ${D}var/imap
+ chown -R cyrus.mail ${D}var/imap
+ mkdir -m 0755 ${D}var/imap/db
+ chown -R cyrus.mail ${D}var/imap/db
+ mkdir -m 0755 ${D}var/imap/log
+ chown -R cyrus.mail ${D}var/imap/log
+ mkdir -m 0755 ${D}var/imap/msg
+ chown -R cyrus.mail ${D}var/imap/msg
+ mkdir -m 0755 ${D}var/imap/user
+ chown -R cyrus.mail ${D}var/imap/user
+ for i in a b c d e f g h i j k l m n o p q r s t u v w x y z ; do mkdir -m 0755 ${D}var/imap/user/$i ; \
+ chown -R cyrus.mail ${D}var/imap/user/$i ; done
+ mkdir -m 0755 ${D}var/imap/proc
+ chown -R cyrus.mail ${D}var/imap/proc
+ mkdir -m 0755 ${D}var/imap/quota
+ for i in a b c d e f g h i j k l m n o p q r s t u v w x y z ; do mkdir -m 0755 ${D}var/imap/quota/$i ; \
+ chown -R cyrus.mail ${D}var/imap/quota/$i ; done
+ mkdir -m 0755 ${D}var/imap/sieve
+ chown -R cyrus.mail ${D}var/imap/sieve
+ for i in a b c d e f g h i j k l m n o p q r s t u v w x y z ; do mkdir -m 0755 ${D}var/imap/sieve/$i ; \
+ chown -R cyrus.mail ${D}var/imap/sieve/$i ; done
+ mkdir -m 0755 ${D}var/imap/socket
+ chown -R cyrus.mail ${D}var/imap/socket
+
+ mkdir ${D}var/spool
+ mkdir -m 0750 ${D}var/spool/imap
+ chown -R cyrus.mail ${D}var/spool/imap
+ mkdir -m 0755 ${D}var/spool/imap/stage.
+ chown -R cyrus.mail ${D}var/spool/imap/stage.
+ # For hashimapspool
+ for i in a b c d e f g h i j k l m n o p q r s t u v w x y z ; do mkdir -m 0755 ${D}var/spool/imap/$i ; \
+ chown -R cyrus.mail ${D}var/spool/imap/$i ; done
+
+
+ doman man/*.?
+ # remove man-pages from packet net-mail/cyrus-imapd-admin
+ rm ${D}usr/share/man/man1/installsieve.1.gz ${D}usr/share/man/man1/sieveshell.1.gz
+
+ dodoc COPYRIGHT README*
+ dohtml doc/*.html doc/murder.png
+ cp doc/cyrusv2.mc ${D}usr/share/doc/${PF}/html
+
+ cp -r contrib tools ${D}usr/share/doc/${PF}
+ # Remove the CVS directories
+ find 2>/dev/null ${D}usr/share/doc/ -type d -name CVS -exec rm -rf '{}' \;
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/cyrus.rc6 cyrus
+
+}
+
+pkg_postinst() {
+
+ ewarn "*****************************************************************"
+ ewarn "* WARNING: If you change the fs-type of /var/imap or *"
+ ewarn "* /var/spool/imap you should read step 9 of *"
+ ewarn "* /usr/share/doc/${P}/html/install-configure.html. *"
+ if df -T /var/imap | grep -q ' ext[23] ' ; then
+ ewarn "* Setting /var/imap/user/* and /var/imap/quota/* to synchronous *"
+ ewarn "* updates. *"
+ chattr +S /var/imap/user /var/imap/user/* /var/imap/quota /var/imap/quota/*
+ fi
+ if df -T /var/spool/imap | grep -q ' ext[23] ' ; then
+ ewarn "* Setting /var/spool/imap/* to synchronous updates. *"
+ chattr +S /var/spool/imap /var/spool/imap/*
+ fi
+ ewarn "* If the queue directory of the mail daemon resides on an ext2 *"
+ ewarn "* or ext3 partition you need to set it manually to update *"
+ ewarn "* synchronously. E.g. 'chattr +S /var/spool/mqueue'. *"
+ ewarn "*****************************************************************"
+
+ einfo "*****************************************************************"
+ einfo "* NOTE: For correct logging add *"
+ einfo "* local6.* /var/log/imapd.log *"
+ einfo "* auth.debug /var/log/auth.log *"
+ einfo "* to /etc/sylog.conf. *"
+ einfo "*****************************************************************"
+
+ if [ "'use ssl'" ]; then
+ ewarn "*****************************************************************"
+ ewarn "* WARNING: Read the section about SSL and TLS of *"
+ ewarn "* /usr/share/doc/${P}/html/install-configure.html. *"
+ ewarn "* about installing the needed keys. *"
+ ewarn "*****************************************************************"
+ fi
+
+ ewarn "*************************************************"
+ ewarn "* WARNING: Add these services to /etc/services: *"
+ ewarn "* pop3 110/tcp *"
+ ewarn "* imap 143/tcp *"
+ ewarn "* imsp 406/tcp *"
+ ewarn "* acap 674/tcp *"
+ ewarn "* sieve 2000/tcp *"
+ ewarn "* lmtp 2003/tcp *"
+ ewarn "* fud 4201/udp *"
+ ewarn "*************************************************"
+
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus.conf b/net-mail/cyrus-imapd/files/cyrus.conf
new file mode 100644
index 000000000000..abc8a5b0bf55
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.conf
@@ -0,0 +1,41 @@
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/files/cyrus.conf,v 1.1 2002/07/13 21:56:01 raker Exp $
+
+# standard standalone server implementation
+
+START {
+ # do not delete this entry!
+ recover cmd="ctl_cyrusdb -r"
+
+ # this is only necessary if using idled for IMAP IDLE
+# idled cmd="idled"
+}
+
+# UNIX sockets start with a slash and are put into /var/imap/socket
+SERVICES {
+ # add or remove based on preferences
+ imap cmd="imapd" listen="imap" prefork=0
+ pop3 cmd="pop3d" listen="pop3" prefork=0
+ # Don't forget to generate the needed keys for SSL or TLS
+ # (see doc/html/install-configure.html)
+ #imaps cmd="imapd -s" listen="imaps" prefork=0
+ #pop3s cmd="pop3d -s" listen="pop3s" prefork=0
+ sieve cmd="timsieved" listen="sieve" prefork=0
+
+ # at least one LMTP is required for delivery
+# lmtp cmd="lmtpd" listen="lmtp" prefork=0
+ lmtpunix cmd="lmtpd" listen="/var/imap/socket/lmtp" prefork=0
+
+ # this is only necessary if using notifications
+# notify cmd="notifyd" listen="/var/imap/socket/notify" proto="udp" prefork=1
+}
+
+EVENTS {
+ # this is required
+ checkpoint cmd="ctl_cyrusdb -c" period=30
+
+ # this is only necessary if using duplicate delivery suppression
+ delprune cmd="ctl_deliver -E 3" period=1440
+
+ # this is only necessary if caching TLS sessions
+ tlsprune cmd="tls_prune" period=1440
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus.rc6 b/net-mail/cyrus-imapd/files/cyrus.rc6
new file mode 100644
index 000000000000..74a819dc0b62
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.rc6
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/files/cyrus.rc6,v 1.1 2002/07/13 21:56:01 raker Exp $
+
+depend() {
+ need net
+ after saslauthd
+}
+
+start() {
+ ebegin "Starting Cyrus imapd"
+ start-stop-daemon --start --quiet --background --make-pidfile --pidfile /var/run/cyrus.pid --exec /usr/cyrus/bin/master
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Cyrus imapd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/cyrus.pid
+ rm /var/run/cyrus.pid
+ eend $?
+}
diff --git a/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.1.5 b/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.1.5
new file mode 100644
index 000000000000..0ef6f5ee45b9
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.1.5
@@ -0,0 +1 @@
+MD5 86eb126e818f998cf7ff2e1fe1a09cb3 cyrus-imapd-2.1.5.tar.gz 1627592
diff --git a/net-mail/cyrus-imapd/files/e2fsprogs-et.diff b/net-mail/cyrus-imapd/files/e2fsprogs-et.diff
new file mode 100644
index 000000000000..3140ef197821
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/e2fsprogs-et.diff
@@ -0,0 +1,336 @@
+diff -urN cyrus-imapd-2.1.5/imap/acapmbox.c cyrus-imapd-2.1.5-modified/imap/acapmbox.c
+--- cyrus-imapd-2.1.5/imap/acapmbox.c Sat May 25 14:57:43 2002
++++ cyrus-imapd-2.1.5-modified/imap/acapmbox.c Sat Jul 13 16:00:50 2002
+@@ -46,7 +46,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+diff -urN cyrus-imapd-2.1.5/imap/append.c cyrus-imapd-2.1.5-modified/imap/append.c
+--- cyrus-imapd-2.1.5/imap/append.c Fri Jun 14 13:20:25 2002
++++ cyrus-imapd-2.1.5-modified/imap/append.c Sat Jul 13 15:53:31 2002
+@@ -48,7 +48,7 @@
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <string.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <sys/types.h>
+ #include <syslog.h>
+ #include <sys/stat.h>
+diff -urN cyrus-imapd-2.1.5/imap/backend.c cyrus-imapd-2.1.5-modified/imap/backend.c
+--- cyrus-imapd-2.1.5/imap/backend.c Mon May 6 12:18:49 2002
++++ cyrus-imapd-2.1.5-modified/imap/backend.c Sat Jul 13 15:47:20 2002
+@@ -57,7 +57,7 @@
+ #include <sys/stat.h>
+ #include <sys/un.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+diff -urN cyrus-imapd-2.1.5/imap/chk_cyrus.c cyrus-imapd-2.1.5-modified/imap/chk_cyrus.c
+--- cyrus-imapd-2.1.5/imap/chk_cyrus.c Sat May 25 20:00:39 2002
++++ cyrus-imapd-2.1.5-modified/imap/chk_cyrus.c Sat Jul 13 16:23:00 2002
+@@ -55,7 +55,7 @@
+ #include <fcntl.h>
+ #include <netinet/in.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <errno.h>
+ #include <ctype.h>
+ #include <time.h>
+diff -urN cyrus-imapd-2.1.5/imap/config.c cyrus-imapd-2.1.5-modified/imap/config.c
+--- cyrus-imapd-2.1.5/imap/config.c Tue Jun 18 11:40:19 2002
++++ cyrus-imapd-2.1.5-modified/imap/config.c Sat Jul 13 15:59:21 2002
+@@ -48,7 +48,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+diff -urN cyrus-imapd-2.1.5/imap/ctl_cyrusdb.c cyrus-imapd-2.1.5-modified/imap/ctl_cyrusdb.c
+--- cyrus-imapd-2.1.5/imap/ctl_cyrusdb.c Wed May 29 11:49:14 2002
++++ cyrus-imapd-2.1.5-modified/imap/ctl_cyrusdb.c Sat Jul 13 16:40:21 2002
+@@ -53,7 +53,7 @@
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <errno.h>
+ #include <time.h>
+
+diff -urN cyrus-imapd-2.1.5/imap/ctl_deliver.c cyrus-imapd-2.1.5-modified/imap/ctl_deliver.c
+--- cyrus-imapd-2.1.5/imap/ctl_deliver.c Tue Jan 15 12:44:09 2002
++++ cyrus-imapd-2.1.5-modified/imap/ctl_deliver.c Sat Jul 13 16:38:12 2002
+@@ -52,7 +52,7 @@
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <errno.h>
+ #include <time.h>
+ #include <signal.h>
+diff -urN cyrus-imapd-2.1.5/imap/ctl_mboxlist.c cyrus-imapd-2.1.5-modified/imap/ctl_mboxlist.c
+--- cyrus-imapd-2.1.5/imap/ctl_mboxlist.c Mon Jun 24 11:29:04 2002
++++ cyrus-imapd-2.1.5-modified/imap/ctl_mboxlist.c Sat Jul 13 16:35:33 2002
+@@ -50,7 +50,7 @@
+ #include <unistd.h>
+ #endif
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sasl/sasl.h>
+diff -urN cyrus-imapd-2.1.5/imap/cvt_cyrusdb.c cyrus-imapd-2.1.5-modified/imap/cvt_cyrusdb.c
+--- cyrus-imapd-2.1.5/imap/cvt_cyrusdb.c Fri May 10 19:46:22 2002
++++ cyrus-imapd-2.1.5-modified/imap/cvt_cyrusdb.c Sat Jul 13 16:24:22 2002
+@@ -59,7 +59,7 @@
+ #include <ctype.h>
+ #include <time.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+
+ #include <sys/ipc.h>
+ #include <sys/msg.h>
+diff -urN cyrus-imapd-2.1.5/imap/cyrdump.c cyrus-imapd-2.1.5-modified/imap/cyrdump.c
+--- cyrus-imapd-2.1.5/imap/cyrdump.c Fri Feb 1 13:43:37 2002
++++ cyrus-imapd-2.1.5-modified/imap/cyrdump.c Sat Jul 13 16:20:54 2002
+@@ -48,7 +48,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <string.h>
+ #include <time.h>
+
+diff -urN cyrus-imapd-2.1.5/imap/deliver.c cyrus-imapd-2.1.5-modified/imap/deliver.c
+--- cyrus-imapd-2.1.5/imap/deliver.c Sat May 25 14:57:44 2002
++++ cyrus-imapd-2.1.5-modified/imap/deliver.c Sat Jul 13 16:25:44 2002
+@@ -56,7 +56,7 @@
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <errno.h>
+ #include <pwd.h>
+ #include <sys/types.h>
+diff -urN cyrus-imapd-2.1.5/imap/fud.c cyrus-imapd-2.1.5-modified/imap/fud.c
+--- cyrus-imapd-2.1.5/imap/fud.c Mon Jun 3 13:22:24 2002
++++ cyrus-imapd-2.1.5-modified/imap/fud.c Sat Jul 13 16:14:12 2002
+@@ -59,7 +59,7 @@
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <pwd.h>
+
+ #include "assert.h"
+diff -urN cyrus-imapd-2.1.5/imap/imapd.c cyrus-imapd-2.1.5-modified/imap/imapd.c
+--- cyrus-imapd-2.1.5/imap/imapd.c Thu Jun 6 21:05:32 2002
++++ cyrus-imapd-2.1.5-modified/imap/imapd.c Sat Jul 13 15:47:35 2002
+@@ -55,7 +55,7 @@
+ #include <sys/param.h>
+ #include <sys/stat.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <sys/wait.h>
+diff -urN cyrus-imapd-2.1.5/imap/index.c cyrus-imapd-2.1.5-modified/imap/index.c
+--- cyrus-imapd-2.1.5/imap/index.c Tue Jun 18 11:40:19 2002
++++ cyrus-imapd-2.1.5-modified/imap/index.c Sat Jul 13 15:51:32 2002
+@@ -53,7 +53,7 @@
+ #include <fcntl.h>
+ #include <netinet/in.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <errno.h>
+ #include <ctype.h>
+ #include <time.h>
+diff -urN cyrus-imapd-2.1.5/imap/index.h cyrus-imapd-2.1.5-modified/imap/index.h
+--- cyrus-imapd-2.1.5/imap/index.h Tue May 21 10:10:13 2002
++++ cyrus-imapd-2.1.5-modified/imap/index.h Sat Jul 13 15:51:45 2002
+@@ -60,7 +60,7 @@
+ #include <fcntl.h>
+ #include <netinet/in.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <errno.h>
+ #include <ctype.h>
+ #include <time.h>
+diff -urN cyrus-imapd-2.1.5/imap/ipurge.c cyrus-imapd-2.1.5-modified/imap/ipurge.c
+--- cyrus-imapd-2.1.5/imap/ipurge.c Tue Nov 13 13:59:04 2001
++++ cyrus-imapd-2.1.5-modified/imap/ipurge.c Sat Jul 13 16:18:33 2002
+@@ -56,7 +56,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <string.h>
+ #include <time.h>
+ #include <netinet/in.h>
+diff -urN cyrus-imapd-2.1.5/imap/lmtpd.c cyrus-imapd-2.1.5-modified/imap/lmtpd.c
+--- cyrus-imapd-2.1.5/imap/lmtpd.c Mon Jun 3 13:22:26 2002
++++ cyrus-imapd-2.1.5-modified/imap/lmtpd.c Sat Jul 13 16:09:13 2002
+@@ -55,7 +55,7 @@
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+diff -urN cyrus-imapd-2.1.5/imap/lmtpengine.c cyrus-imapd-2.1.5-modified/imap/lmtpengine.c
+--- cyrus-imapd-2.1.5/imap/lmtpengine.c Wed Jun 5 19:12:34 2002
++++ cyrus-imapd-2.1.5-modified/imap/lmtpengine.c Sat Jul 13 16:10:45 2002
+@@ -53,7 +53,7 @@
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <limits.h>
+diff -urN cyrus-imapd-2.1.5/imap/mailbox.c cyrus-imapd-2.1.5-modified/imap/mailbox.c
+--- cyrus-imapd-2.1.5/imap/mailbox.c Thu Jun 20 11:35:52 2002
++++ cyrus-imapd-2.1.5-modified/imap/mailbox.c Sat Jul 13 15:54:54 2002
+@@ -62,7 +62,7 @@
+ #include <sys/stat.h>
+ #include <ctype.h>
+ #include <time.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+
+ #ifdef HAVE_DIRENT_H
+ # include <dirent.h>
+diff -urN cyrus-imapd-2.1.5/imap/mbdump.c cyrus-imapd-2.1.5-modified/imap/mbdump.c
+--- cyrus-imapd-2.1.5/imap/mbdump.c Fri May 24 13:05:15 2002
++++ cyrus-imapd-2.1.5-modified/imap/mbdump.c Sat Jul 13 16:07:28 2002
+@@ -60,7 +60,7 @@
+ #include <dirent.h>
+ #include <time.h>
+ #include <assert.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+
+ #include "exitcodes.h"
+ #include "imap_err.h"
+diff -urN cyrus-imapd-2.1.5/imap/mboxlist.c cyrus-imapd-2.1.5-modified/imap/mboxlist.c
+--- cyrus-imapd-2.1.5/imap/mboxlist.c Thu Jun 20 11:36:13 2002
++++ cyrus-imapd-2.1.5-modified/imap/mboxlist.c Sat Jul 13 15:56:29 2002
+@@ -59,7 +59,7 @@
+ #include <ctype.h>
+ #include <time.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+
+ #include <sys/ipc.h>
+ #include <sys/msg.h>
+diff -urN cyrus-imapd-2.1.5/imap/mboxname.c cyrus-imapd-2.1.5-modified/imap/mboxname.c
+--- cyrus-imapd-2.1.5/imap/mboxname.c Thu Jan 24 10:39:28 2002
++++ cyrus-imapd-2.1.5-modified/imap/mboxname.c Sat Jul 13 15:57:54 2002
+@@ -46,7 +46,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <errno.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+
+ #include "assert.h"
+ #include "glob.h"
+diff -urN cyrus-imapd-2.1.5/imap/pop3d.c cyrus-imapd-2.1.5-modified/imap/pop3d.c
+--- cyrus-imapd-2.1.5/imap/pop3d.c Mon Jun 3 13:22:27 2002
++++ cyrus-imapd-2.1.5-modified/imap/pop3d.c Sat Jul 13 16:12:43 2002
+@@ -57,7 +57,7 @@
+ #include <sys/types.h>
+ #include <sys/param.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+diff -urN cyrus-imapd-2.1.5/imap/quota.c cyrus-imapd-2.1.5-modified/imap/quota.c
+--- cyrus-imapd-2.1.5/imap/quota.c Wed May 22 14:55:24 2002
++++ cyrus-imapd-2.1.5-modified/imap/quota.c Sat Jul 13 16:17:06 2002
+@@ -55,7 +55,7 @@
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <sys/stat.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+
+ #if HAVE_DIRENT_H
+ # include <dirent.h>
+diff -urN cyrus-imapd-2.1.5/imap/reconstruct.c cyrus-imapd-2.1.5-modified/imap/reconstruct.c
+--- cyrus-imapd-2.1.5/imap/reconstruct.c Sat Mar 30 13:46:57 2002
++++ cyrus-imapd-2.1.5-modified/imap/reconstruct.c Sat Jul 13 16:15:41 2002
+@@ -55,7 +55,7 @@
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <sys/stat.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <stdlib.h>
+
+ #if HAVE_DIRENT_H
+diff -urN cyrus-imapd-2.1.5/imap/squatter.c cyrus-imapd-2.1.5-modified/imap/squatter.c
+--- cyrus-imapd-2.1.5/imap/squatter.c Fri Jan 18 16:58:48 2002
++++ cyrus-imapd-2.1.5-modified/imap/squatter.c Sat Jul 13 16:44:03 2002
+@@ -78,7 +78,7 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <fcntl.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <syslog.h>
+ #include <string.h>
+
+diff -urN cyrus-imapd-2.1.5/notifyd/notifyd.c cyrus-imapd-2.1.5-modified/notifyd/notifyd.c
+--- cyrus-imapd-2.1.5/notifyd/notifyd.c Wed Jun 19 09:45:35 2002
++++ cyrus-imapd-2.1.5-modified/notifyd/notifyd.c Sat Jul 13 16:47:38 2002
+@@ -51,7 +51,7 @@
+ #include <stdio.h>
+ #include <errno.h>
+ #include <syslog.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+diff -urN cyrus-imapd-2.1.5/timsieved/timsieved.c cyrus-imapd-2.1.5-modified/timsieved/timsieved.c
+--- cyrus-imapd-2.1.5/timsieved/timsieved.c Sat May 25 14:57:53 2002
++++ cyrus-imapd-2.1.5-modified/timsieved/timsieved.c Sat Jul 13 16:45:55 2002
+@@ -60,7 +60,7 @@
+ #include <syslog.h>
+ #include <dirent.h>
+ #include <ctype.h>
+-#include <com_err.h>
++#include <et/com_err.h>
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
diff --git a/net-mail/cyrus-imapd/files/imapd.conf b/net-mail/cyrus-imapd/files/imapd.conf
new file mode 100644
index 000000000000..84a58bd8647a
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/imapd.conf
@@ -0,0 +1,22 @@
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/files/imapd.conf,v 1.1 2002/07/13 21:56:06 raker Exp $
+#
+# Don't forget to use chattr +S (if you are using ext[23])
+# when you change these directories (read the docs).
+configdirectory: /var/imap
+partition-default: /var/spool/imap
+sievedir: /var/imap/sieve
+
+# Don't use an everyday user as admin.
+admins: cyrus
+
+hashimapspool: yes
+allowanonymouslogin: no
+allowplaintext: no
+
+# Use this if sieve-scripts could be in ~user/.sieve.
+#sieveusehomedir: yes
+
+# Use saslauthd if you want to use pam for imap.
+# But be warned: login with DIGEST-MD5 or CRAM-MD5
+# is not possible using pam.
+#sasl_pwcheck_method: saslauthd
diff --git a/net-mail/cyrus-imapd/files/pam.d-imap b/net-mail/cyrus-imapd/files/pam.d-imap
new file mode 100644
index 000000000000..f562e963ed09
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/pam.d-imap
@@ -0,0 +1,3 @@
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/files/pam.d-imap,v 1.1 2002/07/13 21:56:06 raker Exp $
+auth required /lib/security/pam_pwdb.so nullok shadow
+account required /lib/security/pam_pwdb.so