summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-07-28 15:39:48 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-07-28 15:39:48 +0000
commit8433028047d596f4f29a35ec51b311b688914bbb (patch)
tree4c38f88fec662f5e4757c62ea99d2c97c62591d3 /net-mail
parentFix bug 175837, thanks to Cornelius Weig. (diff)
downloadgentoo-2-8433028047d596f4f29a35ec51b311b688914bbb.tar.gz
gentoo-2-8433028047d596f4f29a35ec51b311b688914bbb.tar.bz2
gentoo-2-8433028047d596f4f29a35ec51b311b688914bbb.zip
Fix autotools handling, bug #160169
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog7
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.12-r1.ebuild18
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild18
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.8.ebuild15
4 files changed, 24 insertions, 34 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index 9399188dbe4c..fd423185bfe3 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/cyrus-imap-admin
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.53 2007/07/28 15:09:48 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.54 2007/07/28 15:39:48 dertobi123 Exp $
+
+ 28 Jul 2007; Tobias Scherbaum <dertobi123@gentoo.org>
+ cyrus-imap-admin-2.2.12-r1.ebuild, cyrus-imap-admin-2.2.13.ebuild,
+ cyrus-imap-admin-2.3.8.ebuild:
+ Fix autotools handling, bug #160169
*cyrus-imap-admin-2.3.8 (28 Jul 2007)
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.12-r1.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.12-r1.ebuild
index af9f7872284c..5cfb2a4b866d 100644
--- a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.12-r1.ebuild
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.12-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.12-r1.ebuild,v 1.8 2007/07/21 17:27:10 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.12-r1.ebuild,v 1.9 2007/07/28 15:39:48 dertobi123 Exp $
-inherit perl-app eutils
+inherit autotools perl-app eutils
DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
@@ -32,22 +32,16 @@ S="${WORKDIR}/cyrus-imapd-${PV}"
src_unpack() {
unpack ${A} && cd "${S}"
- # DB4 detection and versioned symbols.
- #epatch "${FILESDIR}/cyrus-imapd-${PV}-db4.patch"
-
- # Recreate configure.
- export WANT_AUTOCONF="2.5"
- ebegin "Recreating configure"
- rm -rf configure config.h.in autom4te.cache
- sh SMakefile &>/dev/null || die "SMakefile failed"
- eend $?
-
# When linking with rpm, you need to link with more libraries.
sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
epatch "${FILESDIR}/${PN}-2.2-db45.patch"
epatch "${FILESDIR}/${PN}-2.2-fPIC.patch"
epatch "${FILESDIR}/${P}-gcc4.patch"
+
+ # Recreate configure.
+ WANT_AUTOCONF="2.5"
+ eautoreconf
}
src_compile() {
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild
index 28039a6e56ee..b236da79b769 100644
--- a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild,v 1.1 2007/07/21 17:27:10 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild,v 1.2 2007/07/28 15:39:48 dertobi123 Exp $
-inherit perl-app eutils
+inherit autotools perl-app eutils
DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
@@ -32,21 +32,15 @@ S="${WORKDIR}/cyrus-imapd-${PV}"
src_unpack() {
unpack ${A} && cd "${S}"
- # DB4 detection and versioned symbols.
- #epatch "${FILESDIR}/cyrus-imapd-${PV}-db4.patch"
-
- # Recreate configure.
- export WANT_AUTOCONF="2.5"
- ebegin "Recreating configure"
- rm -rf configure config.h.in autom4te.cache
- sh SMakefile &>/dev/null || die "SMakefile failed"
- eend $?
-
# When linking with rpm, you need to link with more libraries.
sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
epatch "${FILESDIR}/${PN}-2.2-db45.patch"
epatch "${FILESDIR}/${PN}-2.2-fPIC.patch"
+
+ # Recreate configure.
+ WANT_AUTOCONF="2.5"
+ eautoreconf
}
src_compile() {
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.8.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.8.ebuild
index 72290b84e557..895c647fb3c9 100644
--- a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.8.ebuild
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.8.ebuild,v 1.1 2007/07/28 15:09:48 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.8.ebuild,v 1.2 2007/07/28 15:39:48 dertobi123 Exp $
-inherit perl-app eutils
+inherit autotools perl-app eutils
PIC_PATCH_VER="2.2"
DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
@@ -34,15 +34,12 @@ src_unpack() {
unpack ${A} && cd "${S}"
# DB4 detection and versioned symbols.
- #epatch "${FILESDIR}/cyrus-imapd-${PV}-db4.patch"
- epatch ${FILESDIR}/${PN}-${PIC_PATCH_VER}-fPIC.patch
+ epatch "${FILESDIR}/${PN}-2.2-db45.patch"
+ epatch "${FILESDIR}/${PN}-${PIC_PATCH_VER}-fPIC.patch"
# Recreate configure.
- export WANT_AUTOCONF="2.5"
- ebegin "Recreating configure"
- rm -rf configure config.h.in autom4te.cache
- sh SMakefile &>/dev/null || die "SMakefile failed"
- eend $?
+ WANT_AUTOCONF="2.5"
+ eautoreconf
# When linking with rpm, you need to link with more libraries.
sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"