summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-07-08 14:29:19 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-07-08 14:29:19 +0000
commit61f942ac5bb83d5cdef63c9e5b093ea972957519 (patch)
tree2db60739468867abadb076f3c797f51012aa3367 /net-mail
parentVersion bump and minor changes to the ebuild; also lintool'd and repoman'd. ... (diff)
downloadgentoo-2-61f942ac5bb83d5cdef63c9e5b093ea972957519.tar.gz
gentoo-2-61f942ac5bb83d5cdef63c9e5b093ea972957519.tar.bz2
gentoo-2-61f942ac5bb83d5cdef63c9e5b093ea972957519.zip
new version; moved installation directory; removed unnecessary dependencies
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/squirrelmail/ChangeLog21
-rw-r--r--net-mail/squirrelmail/files/digest-squirrelmail-1.2.71
-rw-r--r--net-mail/squirrelmail/squirrelmail-1.2.7.ebuild53
3 files changed, 70 insertions, 5 deletions
diff --git a/net-mail/squirrelmail/ChangeLog b/net-mail/squirrelmail/ChangeLog
index b48e5e712a73..b981dcd6a128 100644
--- a/net-mail/squirrelmail/ChangeLog
+++ b/net-mail/squirrelmail/ChangeLog
@@ -1,14 +1,25 @@
# ChangeLog for net-mail/squirrelmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/squirrelmail/ChangeLog,v 1.4 2002/06/12 19:27:53 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/squirrelmail/ChangeLog,v 1.5 2002/07/08 14:29:18 blizzy Exp $
-*squirrelmail-1.2.6-r1 (12 June 2002)
+*squirrelmail-1.2.7 (08 Jul 2002)
- 12 June 2002; Grant Goodyear <g2boojum@gentoo.org> :
+ 08 Jul 2002; Maik Schreiber <bZ@iq-computing.de> :
- Fixed postisnt message to mention /etc/php4/php.ini, not
- /etc/PHP4/php.ini. Thanks to Roman Weber.
+ SquirrelMail will be installed into /home/httpd/htdocs/squirrelmail
+ directly instead of into a version-dependant directory and
+ symlinking to it.
+
+ Fixed SRC_URI.
+
+ Removed dependency on net-www/apache and virtual/imapd.
+*squirrelmail-1.2.6-r1 (12 Jun 2002)
+
+ 12 Jun 2002; Grant Goodyear <g2boojum@gentoo.org> :
+
+ Fixed postinst message to mention /etc/php4/php.ini, not
+ /etc/PHP4/php.ini. Thanks to Roman Weber.
*squirrelmail-1.2.6 (21 May 2002)
diff --git a/net-mail/squirrelmail/files/digest-squirrelmail-1.2.7 b/net-mail/squirrelmail/files/digest-squirrelmail-1.2.7
new file mode 100644
index 000000000000..530601c87a85
--- /dev/null
+++ b/net-mail/squirrelmail/files/digest-squirrelmail-1.2.7
@@ -0,0 +1 @@
+MD5 ad9cba89ac6babccdd0fa58b1e982dd6 squirrelmail-1.2.7.tar.bz2 1262469
diff --git a/net-mail/squirrelmail/squirrelmail-1.2.7.ebuild b/net-mail/squirrelmail/squirrelmail-1.2.7.ebuild
new file mode 100644
index 000000000000..e542732e5b1f
--- /dev/null
+++ b/net-mail/squirrelmail/squirrelmail-1.2.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/squirrelmail/squirrelmail-1.2.7.ebuild,v 1.1 2002/07/08 14:29:18 blizzy Exp $
+
+S=${WORKDIR}/${P}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="Webmail for nuts!"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/squirrelmail/${P}.tar.bz2"
+HOMEPAGE="http://www.squirrelmail.org"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="*"
+
+RDEPEND="dev-lang/php"
+DEPEND="${RDEPEND}"
+
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/squirrelmail ] ; then
+ ewarn "You need to unmerge your old SquirrelMail version first."
+ ewarn "SquirrelMail will be installed into ${HTTPD_ROOT}/squirrelmail"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+ dodir ${HTTPD_ROOT}/squirrelmail
+ cp -r . ${D}/${HTTPD_ROOT}/squirrelmail
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} squirrelmail
+}
+
+pkg_postinst() {
+ einfo "Squirrelmail requires PHP to have 'register_globals = On'"
+ einfo "Please edit /etc/php4/php.ini."
+ einfo ""
+ einfo "You will also want to move old SquirrelMail data to"
+ einfo "the new location:"
+ einfo ""
+ einfo "\tmv ${HTTPD_ROOT}/squirrelmail-OLDVERSION/data/* \\"
+ einfo "\t\t${HTTPD_ROOT}/squirrelmail-${PV}/data"
+ einfo "\tmv ${HTTPD_ROOT}/squirrelmail-OLDVERSION/config/config.php \\"
+ einfo "\t\t${HTTPD_ROOT}/squirrelmail-${PV}/config"
+}