summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-08-26 11:38:15 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-08-26 11:38:15 +0000
commit5b1e930b5ac529a19716d512afb032e43b4d4555 (patch)
tree85a63f2174bc37f7666f34319f1e3a374b635a2f /net-mail
parentvanilla-3.5.2 + genpatches-3.5-3 + grsecurity-2.9.1-3.5.2-201208241943 (diff)
downloadgentoo-2-5b1e930b5ac529a19716d512afb032e43b4d4555.tar.gz
gentoo-2-5b1e930b5ac529a19716d512afb032e43b4d4555.tar.bz2
gentoo-2-5b1e930b5ac529a19716d512afb032e43b4d4555.zip
Version bump.
NEWS ~~~~ (Extracted headlines from NEWS file. See it for details.) General bug fixes - Maildir tag synchronization Command-Line Interface - Changes to notmuch dump/restore syntax Emacs Interface - Search results now get re-colored when tags are updated - The formatting of tags in search results can now be customized - Experimental support for multi-line search result formats - Next/previous in search and show now move by boundaries - Search now uses the JSON format internally - The date shown in search results is no longer padded before applying user-specified formatting (Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog26
-rw-r--r--net-mail/notmuch/notmuch-0.14.ebuild166
2 files changed, 191 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index 70355ec2aec2..abcfd99056ec 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,30 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.59 2012/07/04 06:00:48 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.60 2012/08/26 11:38:15 aidecoe Exp $
+
+*notmuch-0.14 (26 Aug 2012)
+
+ 26 Aug 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +notmuch-0.14.ebuild:
+ Version bump.
+
+ NEWS
+ ~~~~
+ (Extracted headlines from NEWS file. See it for details.)
+
+ General bug fixes
+ - Maildir tag synchronization
+
+ Command-Line Interface
+ - Changes to notmuch dump/restore syntax
+
+ Emacs Interface
+ - Search results now get re-colored when tags are updated
+ - The formatting of tags in search results can now be customized
+ - Experimental support for multi-line search result formats
+ - Next/previous in search and show now move by boundaries
+ - Search now uses the JSON format internally
+ - The date shown in search results is no longer padded before applying
+ user-specified formatting
04 Jul 2012; Jeff Horelick <jdhore@gentoo.org> notmuch-0.13.1.ebuild:
marked x86 per bug 422861
diff --git a/net-mail/notmuch/notmuch-0.14.ebuild b/net-mail/notmuch/notmuch-0.14.ebuild
new file mode 100644
index 000000000000..1dce4b25030e
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.14.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.14.ebuild,v 1.1 2012/08/26 11:38:15 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.1"
+
+inherit elisp-common pax-utils distutils
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="test? ( crypt emacs python )"
+IUSE="bash-completion crypt debug doc emacs nmbug mutt python test vim
+ zsh-completion"
+
+CDEPEND="
+ >=dev-libs/glib-2.22
+ >=dev-libs/gmime-2.6.7
+ dev-libs/xapian
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ vim? ( || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 ) )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( python? ( dev-python/sphinx ) )
+ test? ( app-misc/dtach sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git virtual/perl-File-Temp virtual/perl-PodParser )
+ mutt? ( dev-perl/Mail-Box dev-perl/MailTools dev-perl/String-ShellQuote
+ dev-perl/Term-ReadLine-Gnu virtual/perl-File-Path
+ virtual/perl-Getopt-Long virtual/perl-PodParser
+ )
+ zsh-completion? ( app-shells/zsh )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+
+bindings() {
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ $@
+ popd || die
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ default
+ bindings python distutils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${ROOT}/usr/share/bash-completion"
+ --emacslispdir="${ROOT}/${SITELISP}/${PN}"
+ --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
+ --with-gmime-version=2.6
+ --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
+ $(use_with bash-completion)
+ $(use_with emacs)
+ $(use_with zsh-completion)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ bindings python distutils_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ mv README README-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ mv README README-python || die
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin contrib/nmbug
+ fi
+
+ if use mutt; then
+ [[ -e /etc/mutt/notmuch-mutt.rc ]] && NOTMUCH_MUTT_RC_EXISTS=1
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/plugin vim/syntax
+ fi
+
+ DOCS="" bindings python distutils_src_install
+
+ if use doc; then
+ bindings python dohtml -r python
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postinst
+
+ if use mutt && [[ ! ${NOTMUCH_MUTT_RC_EXISTS} ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postrm
+}