summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-02-01 04:26:01 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-02-01 04:26:01 +0000
commit4b67ac8e19c20e65e8678ecdc2bd6dc93f048130 (patch)
tree184f33a6d2a4e94ef2b98a886dde1ec3d2a4a565 /net-mail
parentbrltty-4.1 stable on x86/amd64 for bug #303049. (diff)
downloadgentoo-2-4b67ac8e19c20e65e8678ecdc2bd6dc93f048130.tar.gz
gentoo-2-4b67ac8e19c20e65e8678ecdc2bd6dc93f048130.tar.bz2
gentoo-2-4b67ac8e19c20e65e8678ecdc2bd6dc93f048130.zip
Actually bump, as have been using it in infra for a while.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mlmmj/ChangeLog7
-rw-r--r--net-mail/mlmmj/mlmmj-1.2.17.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-mail/mlmmj/ChangeLog b/net-mail/mlmmj/ChangeLog
index 9363148614c7..c59ece371e45 100644
--- a/net-mail/mlmmj/ChangeLog
+++ b/net-mail/mlmmj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mlmmj
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/ChangeLog,v 1.32 2010/01/06 19:22:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/ChangeLog,v 1.33 2010/02/01 04:26:01 robbat2 Exp $
+
+*mlmmj-1.2.17 (01 Feb 2010)
+
+ 01 Feb 2010; Robin H. Johnson <robbat2@gentoo.org> +mlmmj-1.2.17.ebuild:
+ Actually bump, as have been using it in infra for a while.
06 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
mlmmj-1.2.16-r1.ebuild:
diff --git a/net-mail/mlmmj/mlmmj-1.2.17.ebuild b/net-mail/mlmmj/mlmmj-1.2.17.ebuild
new file mode 100644
index 000000000000..ad51d35c6242
--- /dev/null
+++ b/net-mail/mlmmj/mlmmj-1.2.17.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/mlmmj-1.2.17.ebuild,v 1.1 2010/02/01 04:26:01 robbat2 Exp $
+
+inherit eutils
+
+MY_PV="${PV/_rc/-RC}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Mailing list managing made joyful"
+HOMEPAGE="http://mlmmj.mmj.dk/"
+SRC_URI="http://mlmmj.mmj.dk/files/${MY_P}.tar.bz2"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+DEPEND="virtual/mta"
+#RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+SHAREDIR="/usr/share/mlmmj"
+
+src_unpack() {
+ unpack ${A}
+ #epatch "${FILESDIR}"/${PN}-1.2.16-requeue-unlink-fix.patch
+ #epatch "${FILESDIR}"/${PN}-1.2.16-unsub-digest-text.patch
+ cd "${S}"
+ for i in "${S}" "${S}"/contrib/recievestrip ; do
+ pushd "${i}"
+ # Ignore errors
+ emake -j1 distclean 2>/dev/null 1>/dev/null
+ popd
+ done
+}
+
+src_compile() {
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodir ${SHAREDIR}
+ dodir ${SHAREDIR}/texts
+ insinto ${SHAREDIR}/texts
+ doins listtexts/*
+
+ dodoc AUTHORS ChangeLog FAQ README
+ dodoc TODO TUNABLES UPGRADE VERSION README.access
+ dodoc README.sendmail README.exim4 README.security
+
+ insinto /usr/share/mlmmj
+ cd "${S}"/contrib/web
+ doins -r *
+
+ dobin "${S}"/contrib/recievestrip
+}
+
+pkg_postinst() {
+ elog "mlmmj comes with serveral webinterfaces:"
+ elog "- One for user subscribing/unsubscribing"
+ elog "- One for admin tasks"
+ elog "both available in a php and perl module."
+ elog "For more info have a look in /usr/share/mlmmj"
+}