summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-01-06 22:25:52 +0000
committerEray Aslan <eras@gentoo.org>2012-01-06 22:25:52 +0000
commit4372838c329df5149c5482a479f7ca3e2d2ed406 (patch)
tree0a03933304c40628a322e223ac6abd5484cb39e0 /net-mail
parentAdditional prefix support, bug 396701 (diff)
downloadgentoo-2-4372838c329df5149c5482a479f7ca3e2d2ed406.tar.gz
gentoo-2-4372838c329df5149c5482a479f7ca3e2d2ed406.tar.bz2
gentoo-2-4372838c329df5149c5482a479f7ca3e2d2ed406.zip
version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog8
-rw-r--r--net-mail/dovecot/dovecot-2.1_rc3.ebuild (renamed from net-mail/dovecot/dovecot-2.1_rc1.ebuild)12
-rw-r--r--net-mail/dovecot/files/SnowballAnalyzer.h46
-rw-r--r--net-mail/dovecot/files/SnowballFilter.h41
4 files changed, 12 insertions, 95 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index ca1065ae8b8a..39df1ab11197 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/dovecot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.335 2012/01/06 21:46:27 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.336 2012/01/06 22:25:52 eras Exp $
+
+*dovecot-2.1_rc3 (06 Jan 2012)
+
+ 06 Jan 2012; Eray Aslan <eras@gentoo.org> -dovecot-2.1_rc1.ebuild,
+ +dovecot-2.1_rc3.ebuild, -files/SnowballAnalyzer.h, -files/SnowballFilter.h:
+ version bump
*dovecot-2.0.17 (06 Jan 2012)
diff --git a/net-mail/dovecot/dovecot-2.1_rc1.ebuild b/net-mail/dovecot/dovecot-2.1_rc3.ebuild
index 1fe65c14548d..9afed22c4627 100644
--- a/net-mail/dovecot/dovecot-2.1_rc1.ebuild
+++ b/net-mail/dovecot/dovecot-2.1_rc3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-2.1_rc1.ebuild,v 1.2 2011/12/05 11:24:12 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-2.1_rc3.ebuild,v 1.1 2012/01/06 22:25:52 eras Exp $
EAPI=4
@@ -10,14 +10,14 @@ MY_P="${P/_/.}"
major_minor="$( get_version_component_range 1-2 )"
major_dash_minor="$( replace_version_separator 1 - ${major_minor} )"
sieve_version="0.3.0"
-sieve_snapshot="b3bff60a18da"
+sieve_snapshot="d17f4a699ad2"
SRC_URI="http://www.dovecot.org/releases/${major_minor}/rc/${MY_P}.tar.gz
sieve? (
- http://hg.rename-it.nl/${PN}-${major_minor}-pigeonhole/archive/{sieve_snapshot}.tar.bz2 \
+ http://hg.rename-it.nl/${PN}-${major_minor}-pigeonhole/archive/${sieve_snapshot}.tar.bz2 \
-> ${PN}-${major_minor}-pigeonhole-${sieve_snapshot}.tar.bz2
)
managesieve? (
- http://hg.rename-it.nl/${PN}-${major_minor}-pigeonhole/archive/{sieve_snapshot}.tar.bz2 \
+ http://hg.rename-it.nl/${PN}-${major_minor}-pigeonhole/archive/${sieve_snapshot}.tar.bz2 \
-> ${PN}-${major_minor}-pigeonhole-${sieve_snapshot}.tar.bz2
) "
DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
@@ -67,8 +67,6 @@ pkg_setup() {
}
src_prepare() {
- cp "${FILESDIR}/SnowballAnalyzer.h" "${S}/src/plugins/fts-lucene" || die
- cp "${FILESDIR}/SnowballFilter.h" "${S}/src/plugins/fts-lucene" || die
if use sieve || use managesieve ; then
cd "../dovecot-${major_dash_minor}-pigeonhole-${sieve_snapshot}" \
|| die "cd failed"
diff --git a/net-mail/dovecot/files/SnowballAnalyzer.h b/net-mail/dovecot/files/SnowballAnalyzer.h
deleted file mode 100644
index c82fd990741f..000000000000
--- a/net-mail/dovecot/files/SnowballAnalyzer.h
+++ /dev/null
@@ -1,46 +0,0 @@
-/*------------------------------------------------------------------------------
-* Copyright (C) 2003-2006 Ben van Klinken and the CLucene Team
-*
-* Distributable under the terms of either the Apache License (Version 2.0) or
-* the GNU Lesser General Public License, as specified in the COPYING file.
-------------------------------------------------------------------------------*/
-#ifndef _lucene_analysis_snowball_analyser_
-#define _lucene_analysis_snowball_analyser_
-
-#include "CLucene/analysis/AnalysisHeader.h"
-
-CL_CLASS_DEF(util,BufferedReader)
-CL_NS_DEF2(analysis,snowball)
-
-/** Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link
- * LowerCaseFilter}, {@link StopFilter} and {@link SnowballFilter}.
- *
- * Available stemmers are listed in {@link net.sf.snowball.ext}. The name of a
- * stemmer is the part of the class name before "Stemmer", e.g., the stemmer in
- * {@link EnglishStemmer} is named "English".
- */
-class CLUCENE_CONTRIBS_EXPORT SnowballAnalyzer: public Analyzer {
- char* language;
- CLTCSetList* stopSet;
- TokenStream *prevstream;
-
-public:
- /** Builds the named analyzer with no stop words. */
- SnowballAnalyzer(const char* language="english");
-
- /** Builds the named analyzer with the given stop words.
- */
- SnowballAnalyzer(const char* language, const TCHAR** stopWords);
-
- ~SnowballAnalyzer();
-
- /** Constructs a {@link StandardTokenizer} filtered by a {@link
- StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}. */
- TokenStream* tokenStream(const TCHAR* fieldName, CL_NS(util)::Reader* reader);
- TokenStream* tokenStream(const TCHAR* fieldName, CL_NS(util)::Reader* reader, bool deleteReader);
- TokenStream* reusableTokenStream(const TCHAR* fieldName, CL_NS(util)::Reader* reader);
-};
-
-CL_NS_END2
-#endif
-
diff --git a/net-mail/dovecot/files/SnowballFilter.h b/net-mail/dovecot/files/SnowballFilter.h
deleted file mode 100644
index f35a58a13634..000000000000
--- a/net-mail/dovecot/files/SnowballFilter.h
+++ /dev/null
@@ -1,41 +0,0 @@
-/*------------------------------------------------------------------------------
-* Copyright (C) 2003-2006 Ben van Klinken and the CLucene Team
-*
-* Distributable under the terms of either the Apache License (Version 2.0) or
-* the GNU Lesser General Public License, as specified in the COPYING file.
-------------------------------------------------------------------------------*/
-#ifndef _lucene_analysis_snowball_filter_
-#define _lucene_analysis_snowball_filter_
-
-#include "CLucene/analysis/AnalysisHeader.h"
-#include "libstemmer.h"
-
-CL_NS_DEF2(analysis,snowball)
-
-/** A filter that stems words using a Snowball-generated stemmer.
- *
- * Available stemmers are listed in {@link net.sf.snowball.ext}. The name of a
- * stemmer is the part of the class name before "Stemmer", e.g., the stemmer in
- * {@link EnglishStemmer} is named "English".
- *
- * Note: todo: This is not thread safe...
- */
-class CLUCENE_CONTRIBS_EXPORT SnowballFilter: public TokenFilter {
- struct sb_stemmer * stemmer;
-public:
-
- /** Construct the named stemming filter.
- *
- * @param in the input tokens to stem
- * @param name the name of a stemmer
- */
- SnowballFilter(TokenStream* in, const char* language, bool deleteTS);
-
- ~SnowballFilter();
-
- /** Returns the next input Token, after being stemmed */
- Token* next(Token* token);
-};
-
-CL_NS_END2
-#endif