summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-02-29 20:09:07 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-02-29 20:09:07 +0000
commit39a2dcb3c168e7059d57337c5eb2aca70a79acd1 (patch)
treee1c13f4008b2c399a88f92fdc47a5e55d0935e48 /net-mail
parentVersion bump to 1.0.0 final. (diff)
downloadgentoo-2-39a2dcb3c168e7059d57337c5eb2aca70a79acd1.tar.gz
gentoo-2-39a2dcb3c168e7059d57337c5eb2aca70a79acd1.tar.bz2
gentoo-2-39a2dcb3c168e7059d57337c5eb2aca70a79acd1.zip
net-mail/notmuch: Fixed LD_LIBRARY_PATH for Python docs build and for tests.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog6
-rw-r--r--net-mail/notmuch/notmuch-0.10.2-r2.ebuild9
-rw-r--r--net-mail/notmuch/notmuch-0.11.1-r2.ebuild9
3 files changed, 19 insertions, 5 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index 37fd02d5542a..f9b7900aa315 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.31 2012/02/29 09:08:04 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.32 2012/02/29 20:09:07 aidecoe Exp $
+
+ 29 Feb 2012; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ notmuch-0.10.2-r2.ebuild, notmuch-0.11.1-r2.ebuild:
+ Fixed LD_LIBRARY_PATH for Python docs build and added for test suites.
29 Feb 2012; Amadeusz Żołnowski <aidecoe@gentoo.org>
notmuch-0.10.2-r2.ebuild, notmuch-0.11.1-r2.ebuild:
diff --git a/net-mail/notmuch/notmuch-0.10.2-r2.ebuild b/net-mail/notmuch/notmuch-0.10.2-r2.ebuild
index 235d40ebb743..41504f38bccd 100644
--- a/net-mail/notmuch/notmuch-0.10.2-r2.ebuild
+++ b/net-mail/notmuch/notmuch-0.10.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.10.2-r2.ebuild,v 1.3 2012/02/29 09:08:04 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.10.2-r2.ebuild,v 1.4 2012/02/29 20:09:07 aidecoe Exp $
EAPI=4
@@ -49,6 +49,7 @@ PATCHES=(
)
DOCS=( AUTHORS NEWS README TODO )
SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}_build/lib"
bindings() {
if use $1; then
@@ -95,10 +96,14 @@ src_compile() {
mv html ../python || die
popd || die
}
- LD_LIBRARY_PATH="${WORKDIR}/${PF}_build/lib" bindings python pydocs
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
fi
}
+src_test() {
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+}
+
src_install() {
autotools-utils_src_install
diff --git a/net-mail/notmuch/notmuch-0.11.1-r2.ebuild b/net-mail/notmuch/notmuch-0.11.1-r2.ebuild
index 3bffdae408f3..28cae1634dde 100644
--- a/net-mail/notmuch/notmuch-0.11.1-r2.ebuild
+++ b/net-mail/notmuch/notmuch-0.11.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.11.1-r2.ebuild,v 1.3 2012/02/29 09:08:04 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.11.1-r2.ebuild,v 1.4 2012/02/29 20:09:07 aidecoe Exp $
EAPI=4
@@ -44,6 +44,7 @@ RDEPEND="${CDEPEND}
DOCS=( AUTHORS NEWS README )
SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
bindings() {
if use $1; then
@@ -90,10 +91,14 @@ src_compile() {
mv html ../python || die
popd || die
}
- LD_LIBRARY_PATH="${WORKDIR}/${PF}_build/lib" bindings python pydocs
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
fi
}
+src_test() {
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+}
+
src_install() {
default