summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-01-22 16:51:12 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-01-22 16:51:12 +0000
commit2cfdc6a8c87ebd48ff6bf7169d2e98eca4eb5be7 (patch)
tree02e33aa80c9838b851a1ff41d1edca3a372cc773 /net-mail
parentMask >=dev-java/gcj-jdk-4.7.0 while coresponding gcc is still masked (diff)
downloadgentoo-2-2cfdc6a8c87ebd48ff6bf7169d2e98eca4eb5be7.tar.gz
gentoo-2-2cfdc6a8c87ebd48ff6bf7169d2e98eca4eb5be7.tar.bz2
gentoo-2-2cfdc6a8c87ebd48ff6bf7169d2e98eca4eb5be7.zip
Patch fixing parallel build. It is already accepted by upstream.
Fixes bug #453314. (Portage version: 2.1.11.47/cvs/Linux x86_64, signed Manifest commit with key E1DBFAB5)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog7
-rw-r--r--net-mail/notmuch/files/0.15-0001-lib-Makefile.local-depend-on-libs-we-a.patch25
-rw-r--r--net-mail/notmuch/notmuch-0.15.ebuild12
3 files changed, 41 insertions, 3 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index ee4758551462..dda6e58c2b32 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.67 2013/01/20 15:39:10 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.68 2013/01/22 16:51:12 aidecoe Exp $
+
+ 22 Jan 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> notmuch-0.15.ebuild,
+ +files/0.15-0001-lib-Makefile.local-depend-on-libs-we-a.patch:
+ Patch fixing parallel build. It is already accepted by upstream.
+ Fixes bug #453314.
20 Jan 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> notmuch-0.15.ebuild:
Fix dependency on emacs.
diff --git a/net-mail/notmuch/files/0.15-0001-lib-Makefile.local-depend-on-libs-we-a.patch b/net-mail/notmuch/files/0.15-0001-lib-Makefile.local-depend-on-libs-we-a.patch
new file mode 100644
index 000000000000..b0d1e91533b9
--- /dev/null
+++ b/net-mail/notmuch/files/0.15-0001-lib-Makefile.local-depend-on-libs-we-a.patch
@@ -0,0 +1,25 @@
+From 624cd2eef34963ca521d9dbabc886585ea2f5d54 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Mon, 21 Jan 2013 20:37:53 +0100
+Subject: [PATCH] lib/Makefile.local: depend on libs we are linking with
+
+---
+ lib/Makefile.local | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Makefile.local b/lib/Makefile.local
+index 7785944..155ac02 100644
+--- a/lib/Makefile.local
++++ b/lib/Makefile.local
+@@ -73,7 +73,7 @@ libnotmuch_modules := $(libnotmuch_c_srcs:.c=.o) $(libnotmuch_cxx_srcs:.cc=.o)
+ $(dir)/libnotmuch.a: $(libnotmuch_modules)
+ $(call quiet,AR) rcs $@ $^
+
+-$(dir)/$(LIBNAME): $(libnotmuch_modules) notmuch.sym
++$(dir)/$(LIBNAME): $(libnotmuch_modules) notmuch.sym util/libutil.a parse-time-string/libparse-time-string.a
+ $(call quiet,CXX $(CXXFLAGS)) $(libnotmuch_modules) $(FINAL_LIBNOTMUCH_LDFLAGS) $(LIBRARY_LINK_FLAG) -o $@ util/libutil.a parse-time-string/libparse-time-string.a
+
+ notmuch.sym: $(srcdir)/$(dir)/notmuch.h $(libnotmuch_modules)
+--
+1.8.1.1
+
diff --git a/net-mail/notmuch/notmuch-0.15.ebuild b/net-mail/notmuch/notmuch-0.15.ebuild
index 59ed5159f20e..eb1906b6dbb8 100644
--- a/net-mail/notmuch/notmuch-0.15.ebuild
+++ b/net-mail/notmuch/notmuch-0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.15.ebuild,v 1.2 2013/01/20 15:39:10 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.15.ebuild,v 1.3 2013/01/22 16:51:12 aidecoe Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="python? 2:2.6 3:3.2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[45] 3.1"
-inherit elisp-common pax-utils distutils
+inherit elisp-common eutils pax-utils distutils
DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
HOMEPAGE="http://notmuchmail.org/"
@@ -51,6 +51,9 @@ RDEPEND="${CDEPEND}
zsh-completion? ( app-shells/zsh )
"
+PATCHES=(
+ "${FILESDIR}/${PV}-0001-lib-Makefile.local-depend-on-libs-we-a.patch"
+ )
DOCS=( AUTHORS NEWS README )
SITEFILE="50${PN}-gentoo.el"
SITEFILE_PICK="60${PN}-pick-gentoo.el"
@@ -73,6 +76,11 @@ pkg_setup() {
}
src_prepare() {
+ local p
+ for p in "${PATCHES[@]}"; do
+ epatch "${p}"
+ done
+
default
bindings python distutils_src_prepare