summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-12-13 08:23:01 +0000
committerTorsten Veller <tove@gentoo.org>2010-12-13 08:23:01 +0000
commit29c7d550848a47812bb480e01b3f2f175abbb232 (patch)
treeb526431f8ec26be7d4971eb2fba4de8ac3dedb0b /net-mail
parentRedo how we handle forced gentoo-release update so we avoid md5/mtime mismatc... (diff)
downloadgentoo-2-29c7d550848a47812bb480e01b3f2f175abbb232.tar.gz
gentoo-2-29c7d550848a47812bb480e01b3f2f175abbb232.tar.bz2
gentoo-2-29c7d550848a47812bb480e01b3f2f175abbb232.zip
Version bump. s/com_err/e2fsprogs-libs
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/ChangeLog7
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.19.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 433fb2acdc74..e18fc47103a6 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.196 2010/10/10 07:57:03 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.197 2010/12/13 08:23:01 tove Exp $
+
+*fetchmail-6.3.19 (13 Dec 2010)
+
+ 13 Dec 2010; Torsten Veller <tove@gentoo.org> +fetchmail-6.3.19.ebuild:
+ Version bump. s/com_err/e2fsprogs-libs
*fetchmail-6.3.18 (10 Oct 2010)
diff --git a/net-mail/fetchmail/fetchmail-6.3.19.ebuild b/net-mail/fetchmail/fetchmail-6.3.19.ebuild
new file mode 100644
index 000000000000..3c1a7d98e140
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.19.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.19.ebuild,v 1.1 2010/12/13 08:23:01 tove Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="tk? 2"
+PYTHON_USE_WITH_OPT="tk"
+PYTHON_USE_WITH="tk"
+
+inherit python eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl nls kerberos hesiod tk"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 >=dev-libs/openssl-0.9.6 )
+ nls? ( virtual/libintl )
+ elibc_FreeBSD? ( sys-libs/e2fsprogs-libs )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+ use tk && python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # dont compile during src_install
+ : > "${S}"/py-compile
+}
+
+src_configure() {
+ if use tk ; then
+ export PYTHON=$(PYTHON -a )
+ else
+ export PYTHON=:
+ fi
+ econf \
+ --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ $(use kerberos && echo "--with-ssl" ) \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ $(use_with hesiod)
+}
+
+src_install() {
+ # dir for pidfile
+ keepdir /var/run/${PN} || die
+ fowners ${PN}:${PN} /var/run/${PN} || die
+
+ # fetchmail's homedir (holds fetchmail's .fetchids)
+ keepdir /var/lib/${PN} || die
+ fowners ${PN}:${PN} /var/lib/${PN} || die
+ fperms 700 /var/lib/${PN} || die
+
+ emake DESTDIR="${D}" install || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO || die
+
+ newinitd "${FILESDIR}"/fetchmail.new fetchmail || die
+ newconfd "${FILESDIR}"/conf.d-fetchmail fetchmail || die
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ use tk && python_mod_optimize "$(python_get_sitedir)/fetchmailconf.py"
+
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+}
+
+pkg_postrm() {
+ use tk && python_mod_cleanup "$(python_get_sitedir)/fetchmailconf.py"
+}