summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 13:53:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 13:53:59 +0000
commit2556ec1113a9ec067a0ecc70b05e8fffc759f66d (patch)
tree80ab47b300e637f8ad4e4afe724a0ed9192b00f6 /net-mail
parentAdd patch to build against berkdb 5 (bug #321299). (diff)
downloadgentoo-2-2556ec1113a9ec067a0ecc70b05e8fffc759f66d.tar.gz
gentoo-2-2556ec1113a9ec067a0ecc70b05e8fffc759f66d.tar.bz2
gentoo-2-2556ec1113a9ec067a0ecc70b05e8fffc759f66d.zip
Add patch to build against berkdb 5 (bug #351009).
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imapd/ChangeLog8
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-2.3.16.ebuild6
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-2.3.16+db-5.0.patch49
3 files changed, 59 insertions, 4 deletions
diff --git a/net-mail/cyrus-imapd/ChangeLog b/net-mail/cyrus-imapd/ChangeLog
index 96b51be41a28..160da826b079 100644
--- a/net-mail/cyrus-imapd/ChangeLog
+++ b/net-mail/cyrus-imapd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/cyrus-imapd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.155 2009/12/31 09:29:16 dertobi123 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.156 2011/01/10 13:53:59 flameeyes Exp $
+
+ 10 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ cyrus-imapd-2.3.16.ebuild, +files/cyrus-imapd-2.3.16+db-5.0.patch:
+ Add patch to build against berkdb 5 (bug #351009).
*cyrus-imapd-2.3.16 (31 Dec 2009)
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-2.3.16.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-2.3.16.ebuild
index 794d016b0cea..d9fc57e85503 100644
--- a/net-mail/cyrus-imapd/cyrus-imapd-2.3.16.ebuild
+++ b/net-mail/cyrus-imapd/cyrus-imapd-2.3.16.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.3.16.ebuild,v 1.1 2009/12/31 09:29:16 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.3.16.ebuild,v 1.2 2011/01/10 13:53:59 flameeyes Exp $
EAPI=1
@@ -106,6 +106,8 @@ src_unpack() {
# Fix prestripped binaries
epatch "${FILESDIR}/${PN}-strip.patch"
+ epatch "${FILESDIR}/${P}+db-5.0.patch"
+
# Add libwrap defines as we don't have a dynamicly linked library.
use tcpd && epatch "${FILESDIR}/${PN}-${LIBWRAP_PATCH_VER}-libwrap.patch"
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.16+db-5.0.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.16+db-5.0.patch
new file mode 100644
index 000000000000..319abf1f6bb7
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.16+db-5.0.patch
@@ -0,0 +1,49 @@
+Index: cyrus-imapd-2.3.16/lib/cyrusdb_berkeley.c
+===================================================================
+--- cyrus-imapd-2.3.16.orig/lib/cyrusdb_berkeley.c
++++ cyrus-imapd-2.3.16/lib/cyrusdb_berkeley.c
+@@ -108,7 +108,7 @@ static void db_panic(DB_ENV *dbenv __att
+ exit(EC_TEMPFAIL);
+ }
+
+-#if (DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)
++#if ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)) || (DB_VERSION_MAJOR >= 5)
+ static void db_err(const DB_ENV *dbenv __attribute__((unused)),
+ const char *db_prfx, const char *buffer)
+ #else
+@@ -164,7 +164,7 @@ static int init(const char *dbdir, int m
+ #endif
+ }
+
+-#if (DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)
++#if ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)) || (DB_VERSION_MAJOR >= 5)
+ dbenv->set_msgcall(dbenv, db_msg);
+ #endif
+ dbenv->set_errcall(dbenv, db_err);
+@@ -282,7 +282,7 @@ static int mysync(void)
+
+ assert(dbinit);
+
+-#if !(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
++#if !((DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1) || DB_VERSION_MAJOR >= 5)
+ do {
+ #endif
+ #if (DB_VERSION_MAJOR > 3) || ((DB_VERSION_MAJOR == 3) && (DB_VERSION_MINOR > 0))
+@@ -290,7 +290,7 @@ static int mysync(void)
+ #else
+ r = txn_checkpoint(dbenv, 0, 0);
+ #endif
+-#if !(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
++#if !((DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1) || DB_VERSION_MAJOR >= 5)
+ } while (r == DB_INCOMPLETE); /* Never returned by BDB 4.1 */
+ #endif
+ if (r) {
+@@ -413,7 +413,7 @@ static int myopen(const char *fname, DBT
+ /* xxx set comparator! */
+ if (flags & CYRUSDB_MBOXSORT) db->set_bt_compare(db, mbox_compar);
+
+-#if DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1
++#if (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1) || (DB_VERSION_MAJOR >= 5)
+ r = (db->open)(db, NULL, fname, NULL, type, dbflags | DB_AUTO_COMMIT, 0664);
+ #else
+ r = (db->open)(db, fname, NULL, type, dbflags, 0664);