summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-01-14 13:21:03 +0000
committerTorsten Veller <tove@gentoo.org>2011-01-14 13:21:03 +0000
commit2371c2798ff9bb01d3d2b016ea580276d9be8dcb (patch)
tree3a8493b9a22a1cf7516805437651fa089daf585a /net-mail
parentConvert ebuild version. Fix cpan #58053 (diff)
downloadgentoo-2-2371c2798ff9bb01d3d2b016ea580276d9be8dcb.tar.gz
gentoo-2-2371c2798ff9bb01d3d2b016ea580276d9be8dcb.tar.bz2
gentoo-2-2371c2798ff9bb01d3d2b016ea580276d9be8dcb.zip
Fix fix_nonexistent_mailbox_test (#296657)
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/grepmail/ChangeLog8
-rw-r--r--net-mail/grepmail/files/5.30.33-fix_nonexistent_mailbox_test.patch33
-rw-r--r--net-mail/grepmail/grepmail-5.30.33.ebuild5
3 files changed, 42 insertions, 4 deletions
diff --git a/net-mail/grepmail/ChangeLog b/net-mail/grepmail/ChangeLog
index f7640b30532e..f6576673f0c9 100644
--- a/net-mail/grepmail/ChangeLog
+++ b/net-mail/grepmail/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/grepmail
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/grepmail/ChangeLog,v 1.31 2008/03/07 19:08:28 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/grepmail/ChangeLog,v 1.32 2011/01/14 13:21:02 tove Exp $
+
+ 14 Jan 2011; Torsten Veller <tove@gentoo.org>
+ +files/5.30.33-fix_nonexistent_mailbox_test.patch, grepmail-5.30.33.ebuild:
+ Fix fix_nonexistent_mailbox_test (#296657)
07 Mar 2008; Raúl Porcel <armin76@gentoo.org> grepmail-5.30.33.ebuild:
sparc stable wrt #212470
diff --git a/net-mail/grepmail/files/5.30.33-fix_nonexistent_mailbox_test.patch b/net-mail/grepmail/files/5.30.33-fix_nonexistent_mailbox_test.patch
new file mode 100644
index 000000000000..cdab28bb635c
--- /dev/null
+++ b/net-mail/grepmail/files/5.30.33-fix_nonexistent_mailbox_test.patch
@@ -0,0 +1,33 @@
+Description: Fix FTBFS with libmail-mbox-messageparser-perl 1.5002
+ From 1.5002, it does not return "No data on standard input" anymore.
+Author: Vincent Legout <vincent@legout.info>
+Last-Update: 2010-04-28
+Bug-Debian: http://bugs.debian.org/549782
+Bug-Gentoo: https://bugs.gentoo.org/296657
+
+--- grepmail/t/nonexistent_mailbox.t
++++ grepmail/t/nonexistent_mailbox.t
+@@ -13,21 +13,15 @@
+ => ['none','no_such_file'],
+ "$^X -MExtUtils::Command -e cat no_such_file 2>" . devnull() .
+ " | grepmail pattern"
+- => ['none','no_data'],
++ => ['none','none'],
+ "grepmail -E $single_quote\$email =~ /pattern/$single_quote no_such_file"
+ => ['none','no_such_file'],
+ "$^X -MExtUtils::Command -e cat no_such_file 2>" . devnull() .
+ " | grepmail -E $single_quote\$email =~ /pattern/$single_quote"
+- => ['none','no_data'],
++ => ['none','none'],
+ );
+
+ my %expected_errors = (
+-"$^X -MExtUtils::Command -e cat no_such_file 2>" . devnull() .
+- " | grepmail pattern"
+- => 1,
+-"$^X -MExtUtils::Command -e cat no_such_file 2>" . devnull() .
+- " | grepmail -E $single_quote\$email =~ /pattern/$single_quote"
+- => 1,
+ );
+
+ my %localization = (
diff --git a/net-mail/grepmail/grepmail-5.30.33.ebuild b/net-mail/grepmail/grepmail-5.30.33.ebuild
index 21b42c81a8b9..ee35a00f7a82 100644
--- a/net-mail/grepmail/grepmail-5.30.33.ebuild
+++ b/net-mail/grepmail/grepmail-5.30.33.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/grepmail/grepmail-5.30.33.ebuild,v 1.4 2008/03/07 19:08:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/grepmail/grepmail-5.30.33.ebuild,v 1.5 2011/01/14 13:21:02 tove Exp $
inherit versionator perl-app
@@ -23,3 +23,4 @@ DEPEND="dev-perl/Inline
>=dev-perl/Mail-Mbox-MessageParser-1.40.01"
SRC_TEST="do"
+PATCHES=( "${FILESDIR}"/5.30.33-fix_nonexistent_mailbox_test.patch )