summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J. Cohen <mjc@gentoo.org>2002-07-14 16:40:47 +0000
committerMichael J. Cohen <mjc@gentoo.org>2002-07-14 16:40:47 +0000
commit1d7f74c00e3ac87d4be4deb71df5ea96fc4baf7a (patch)
tree577e0860ccb8add7b1c7be3c4d21c6035483adbb /net-mail
parentAlways download the same stuff, fix digest. (diff)
downloadgentoo-2-1d7f74c00e3ac87d4be4deb71df5ea96fc4baf7a.tar.gz
gentoo-2-1d7f74c00e3ac87d4be4deb71df5ea96fc4baf7a.tar.bz2
gentoo-2-1d7f74c00e3ac87d4be4deb71df5ea96fc4baf7a.zip
Version Bump.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed/ChangeLog10
-rw-r--r--net-mail/sylpheed/sylpheed-0.8.0.ebuild56
2 files changed, 65 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index 936c2a674896..ce3546bfc363 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.10 2002/06/29 09:40:15 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.11 2002/07/14 16:40:47 mjc Exp $
+
+*sylpheed-0.8.0 (14 Jul 2002)
+
+ 14 Jul 2002; Michael Cohen <mjc@gentoo.org> sylpheed-0.8.0.ebuild
+ files/digest-sylpheed-0.8.0 :
+
+ Version bump.
+
*sylpheed-0.7.8-r1 (29 Jun 2002)
diff --git a/net-mail/sylpheed/sylpheed-0.8.0.ebuild b/net-mail/sylpheed/sylpheed-0.8.0.ebuild
new file mode 100644
index 000000000000..316426cf62d0
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.8.0.ebuild,v 1.1 2002/07/14 16:40:47 mjc Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+SLOT=""
+LICENSE="GPL-2"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/compface-1.4
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+
+ local myconf
+
+ use gnome || myconf="--disable-gdk-pixbuf --disable-imlib"
+ use nls || myconf="$myconf --disable-nls"
+ use ssl && myconf="$myconf --enable-ssl"
+ use crypt && myconf="$myconf --enable-gpgme"
+ use pda && myconf="$myconf --enable-jpilot"
+ use ldap && myconf="$myconf --enable-ldap"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}
+