summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-02-04 10:31:33 +0000
committerThomas Kahle <tomka@gentoo.org>2011-02-04 10:31:33 +0000
commit1a261f3b6ecec3a8c87e7603548dde9516f5ce06 (patch)
treeef267ef842d1e69731f5e843c8adcbafe5aa7ef0 /net-mail
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-1a261f3b6ecec3a8c87e7603548dde9516f5ce06.tar.gz
gentoo-2-1a261f3b6ecec3a8c87e7603548dde9516f5ce06.tar.bz2
gentoo-2-1a261f3b6ecec3a8c87e7603548dde9516f5ce06.zip
introduce USE=gui to build the experimental gui, QA per bug #353653.
(Portage version: 2.1.9.35/cvs/Linux i686)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/ChangeLog5
-rw-r--r--net-mail/mu/metadata.xml3
-rw-r--r--net-mail/mu/mu-0.9.2.ebuild30
3 files changed, 31 insertions, 7 deletions
diff --git a/net-mail/mu/ChangeLog b/net-mail/mu/ChangeLog
index dbecda84787d..5c7b13bf90cd 100644
--- a/net-mail/mu/ChangeLog
+++ b/net-mail/mu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/mu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/ChangeLog,v 1.1 2011/02/03 10:11:42 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/ChangeLog,v 1.2 2011/02/04 10:31:33 tomka Exp $
+
+ 04 Feb 2011; Thomas Kahle <tomka@gentoo.org> mu-0.9.2.ebuild, metadata.xml:
+ introduce USE=gui to build the experimental gui, QA per bug #353653.
*mu-0.9.2 (03 Feb 2011)
diff --git a/net-mail/mu/metadata.xml b/net-mail/mu/metadata.xml
index 63c9f019b7dc..d981a5278096 100644
--- a/net-mail/mu/metadata.xml
+++ b/net-mail/mu/metadata.xml
@@ -10,4 +10,7 @@
'mu' is a set of command-line tools for Linux/Unix that enable you to quickly find the e-mails you
are looking for, assuming that you store your e-mails in Maildirs.
</longdescription>
+<use>
+ <flag name="gui">Build and install the experimental gui 'mug'.</flag>
+</use>
</pkgmetadata>
diff --git a/net-mail/mu/mu-0.9.2.ebuild b/net-mail/mu/mu-0.9.2.ebuild
index c358fe795596..21dee77bbe9a 100644
--- a/net-mail/mu/mu-0.9.2.ebuild
+++ b/net-mail/mu/mu-0.9.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/mu-0.9.2.ebuild,v 1.1 2011/02/03 10:11:42 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/mu-0.9.2.ebuild,v 1.2 2011/02/04 10:31:33 tomka Exp $
EAPI=3
-inherit base eutils
+inherit base
DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
@@ -13,15 +13,33 @@ SRC_URI="http://mu0.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="gui"
DEPEND=">=dev-libs/gmime-2.4
dev-libs/xapian
- >=dev-libs/glib-2.22"
+ >=dev-libs/glib-2.22
+ gui? ( x11-libs/gtk+
+ net-libs/webkit-gtk ) "
RDEPEND="${DEPEND}"
-src_test () {
- emake check || die
+src_configure() {
+ local guiconf
+ if use gui; then
+ guiconf="--with-gui=gtk2"
+ else
+ guiconf="--with-gui=none"
+ fi
+
+ econf "${guiconf}"
+}
+
+src_install () {
+ base_src_install
+ # Installing the guis is not supported by upstream
+ if use gui; then
+ dobin toys/mug/mug || die
+ dobin toys/mug2/mug2 || die
+ fi
}
DOCS=( "AUTHORS" "HACKING" "NEWS" "TODO" )