summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-09-26 10:35:58 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-09-26 10:35:58 +0000
commit0e4483291d2de28752c24a867095e03463339056 (patch)
treebe2f228632ae6f19c1ae35941d838c222997d38e /net-mail
parentsync with default-linux + minimal profile updated (diff)
downloadgentoo-2-0e4483291d2de28752c24a867095e03463339056.tar.gz
gentoo-2-0e4483291d2de28752c24a867095e03463339056.tar.bz2
gentoo-2-0e4483291d2de28752c24a867095e03463339056.zip
Version bump.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/hotwayd/ChangeLog7
-rw-r--r--net-mail/hotwayd/Manifest12
-rw-r--r--net-mail/hotwayd/files/digest-hotwayd-0.8.41
-rw-r--r--net-mail/hotwayd/hotwayd-0.8.4.ebuild74
4 files changed, 83 insertions, 11 deletions
diff --git a/net-mail/hotwayd/ChangeLog b/net-mail/hotwayd/ChangeLog
index 06ef73941453..7e9909186cb3 100644
--- a/net-mail/hotwayd/ChangeLog
+++ b/net-mail/hotwayd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/hotwayd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/ChangeLog,v 1.18 2005/05/31 17:25:28 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/ChangeLog,v 1.19 2005/09/26 10:35:58 ticho Exp $
+
+*hotwayd-0.8.4 (26 Sep 2005)
+
+ 26 Sep 2005; Andrej Kacian <ticho@gentoo.org> +hotwayd-0.8.4.ebuild:
+ Version bump.
*hotwayd-0.8.2-r2 (31 May 2005)
diff --git a/net-mail/hotwayd/Manifest b/net-mail/hotwayd/Manifest
index 7cafba3e39a3..74809af6049c 100644
--- a/net-mail/hotwayd/Manifest
+++ b/net-mail/hotwayd/Manifest
@@ -1,6 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 64563fc891745f5909bec7f505e3aff4 hotwayd-0.8.4.ebuild 2045
MD5 d130382c71df97e64a7d60317b279974 ChangeLog 3629
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 4ec167872cd1d41158d03bc0a06a3923 hotwayd-0.8.2-r2.ebuild 2145
@@ -9,10 +7,4 @@ MD5 11f58c76db54b710b16843e031fd58ab files/hotwayd-0.8-headerfix.patch 557
MD5 dd6f3b429961f43d5dc98ae6cb7a7135 files/hotwayd-0.8.xinetd 1096
MD5 d6cae8d0287ee4805fbaafdd12240d8e files/hotwayd.xinetd 787
MD5 2d2ee1259a0fd2a7f3e82f7b3449be37 files/hotwayd-0.8-amd64.patch 563
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCnJ4kQlM6RnzZP+IRAiEZAJwOqWjT6a5PYuayDKNyHJsW+M0tUQCfcEh8
-Jk2VXMKSegUNDfOnKg7Z46Y=
-=WEXG
------END PGP SIGNATURE-----
+MD5 36f8adb9857fd91a0c2a2ac243d3316b files/digest-hotwayd-0.8.4 66
diff --git a/net-mail/hotwayd/files/digest-hotwayd-0.8.4 b/net-mail/hotwayd/files/digest-hotwayd-0.8.4
new file mode 100644
index 000000000000..57cea1b96e2f
--- /dev/null
+++ b/net-mail/hotwayd/files/digest-hotwayd-0.8.4
@@ -0,0 +1 @@
+MD5 c3f59d9b7c61640a557bc9007c28cec3 hotwayd-0.8.4.tar.bz2 161274
diff --git a/net-mail/hotwayd/hotwayd-0.8.4.ebuild b/net-mail/hotwayd/hotwayd-0.8.4.ebuild
new file mode 100644
index 000000000000..84c60002ef40
--- /dev/null
+++ b/net-mail/hotwayd/hotwayd-0.8.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/hotwayd-0.8.4.ebuild,v 1.1 2005/09/26 10:35:58 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="Hotmail to pop3 daemon"
+HOMEPAGE="http://hotwayd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hotwayd/${P}.tar.bz2"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="smtp"
+
+DEPEND="virtual/inetd
+ dev-libs/libxml2
+ smtp? ( >=dev-libs/cyrus-sasl-2 )"
+
+hotmail_greed_warning() {
+ echo
+ ewarn "WARNING:"
+ ewarn "Since Hotmail started to charge for WebDAV access, you need a Hotmail Plus"
+ ewarn "(or equivalent MSN) account to keep using hotwayd. More info:"
+ ewarn "http://www.boolean.ca/hotpop/"
+ ewarn "http://sourceforge.net/forum/forum.php?thread_id=1277989&forum_id=80217"
+ echo
+ ebeep 3
+ sleep 10
+}
+
+pkg_setup() {
+ hotmail_greed_warning
+}
+
+src_install () {
+ # The original make install is broken, since it also tries to install
+ # the libghttp files. This is not needed, since this library is statically
+ # linked into the executable.
+ # Lets just copy the (one) file manually...
+ dosbin hotwayd
+ if use smtp; then
+ dosbin hotsmtpd/hotsmtpd
+ insinto /etc/xinetd.d
+ sed -i -e 's:^disable = no:disable = yes:' hotsmtpd/hotsmtpd.xinetd
+ newins hotsmtpd/hotsmtpd.xinetd hotsmtpd
+ fi
+
+ dodoc AUTHORS NEWS README
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/${PN}.xinetd ${PN}
+}
+
+pkg_postinst () {
+ hotmail_greed_warning
+ echo
+ einfo " By default daemons that use xinetd are not started automatically in gentoo"
+ einfo " To activate do the following steps: "
+ einfo " - Edit the file /etc/xinetd.d/hotwayd and change disable "
+ einfo " from yes to no "
+ einfo " - Restart xinetd with \`/etc/init.d/xinetd restart\` "
+ echo
+ if use smtp; then
+ einfo "You chose to install hotsmtpd, a SMTP proxy for hotmail. Please"
+ einfo "Configure /etc/xinetd.d/hotsmtpd and restart xinetd to start using it."
+ echo
+ fi
+ einfo "Set your e-mail applications to use port 1100 for receiving email."
+ if use smtp; then
+ einfo "Use port 2500 for sending email."
+ fi
+}