summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-04-02 10:00:10 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-04-02 10:00:10 +0000
commit0b5f5922a748745d63b006cce2d14783b81b64a8 (patch)
tree663f9e042b8d3abc665b94e9372d9b405ad8cde2 /net-mail
parentBump unix-compat to 0.4.1.1 (diff)
downloadgentoo-2-0b5f5922a748745d63b006cce2d14783b81b64a8.tar.gz
gentoo-2-0b5f5922a748745d63b006cce2d14783b81b64a8.tar.bz2
gentoo-2-0b5f5922a748745d63b006cce2d14783b81b64a8.zip
As identified & fixed by Peter Wilmott, there is an overzealous version check that does not cope with newer IO-Socket-SSL packages. Taking maintainership.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sendEmail/ChangeLog12
-rw-r--r--net-mail/sendEmail/files/1.56-overzealous-version-check.patch11
-rw-r--r--net-mail/sendEmail/metadata.xml2
-rw-r--r--net-mail/sendEmail/sendEmail-1.56-r1.ebuild29
4 files changed, 51 insertions, 3 deletions
diff --git a/net-mail/sendEmail/ChangeLog b/net-mail/sendEmail/ChangeLog
index 17a7df40f472..a4eb87dfc55c 100644
--- a/net-mail/sendEmail/ChangeLog
+++ b/net-mail/sendEmail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/sendEmail
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sendEmail/ChangeLog,v 1.20 2012/09/26 18:58:51 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sendEmail/ChangeLog,v 1.21 2013/04/02 10:00:09 chainsaw Exp $
+
+*sendEmail-1.56-r1 (02 Apr 2013)
+
+ 02 Apr 2013; Tony Vroon <chainsaw@gentoo.org>
+ +files/1.56-overzealous-version-check.patch, +sendEmail-1.56-r1.ebuild,
+ metadata.xml:
+ As identified & fixed by Peter Wilmott, there is an overzealous version check
+ that does not cope with newer IO-Socket-SSL packages. Taking maintainership.
26 Sep 2012; Michael Palimaka <kensington@gentoo.org> -sendEmail-1.55.ebuild:
Remove old.
diff --git a/net-mail/sendEmail/files/1.56-overzealous-version-check.patch b/net-mail/sendEmail/files/1.56-overzealous-version-check.patch
new file mode 100644
index 000000000000..5cd47b06788d
--- /dev/null
+++ b/net-mail/sendEmail/files/1.56-overzealous-version-check.patch
@@ -0,0 +1,11 @@
+--- a/sendEmail 2013-03-25 08:59:12.000000000 +0000
++++ b/sendEmail 2013-03-25 08:59:22.000000000 +0000
+@@ -1903,7 +1903,7 @@
+ if ($conf{'tls_server'} == 1 and $conf{'tls_client'} == 1 and $opt{'tls'} =~ /^(yes|auto)$/) {
+ printmsg("DEBUG => Starting TLS", 2);
+ if (SMTPchat('STARTTLS')) { quit($conf{'error'}, 1); }
+- if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'SSLv3 TLSv1')) {
++ if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'SSLv3')) {
+ quit("ERROR => TLS setup failed: " . IO::Socket::SSL::errstr(), 1);
+ }
+ printmsg("DEBUG => TLS: Using cipher: ". $SERVER->get_cipher(), 3);
diff --git a/net-mail/sendEmail/metadata.xml b/net-mail/sendEmail/metadata.xml
index a709ba50ccfb..bff87badf2f3 100644
--- a/net-mail/sendEmail/metadata.xml
+++ b/net-mail/sendEmail/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>chainsaw@gentoo.org</email>
</maintainer>
<longdescription> SendEmail is a lightweight, completely command line based,
SMTP email agent. If you have the need to send email from a command prompt
diff --git a/net-mail/sendEmail/sendEmail-1.56-r1.ebuild b/net-mail/sendEmail/sendEmail-1.56-r1.ebuild
new file mode 100644
index 000000000000..345b1ebe14f0
--- /dev/null
+++ b/net-mail/sendEmail/sendEmail-1.56-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sendEmail/sendEmail-1.56-r1.ebuild,v 1.1 2013/04/02 10:00:09 chainsaw Exp $
+
+EAPI=5
+MY_P="${PN}-v${PV}"
+
+inherit base
+
+DESCRIPTION="Command line based, SMTP email agent"
+HOMEPAGE="http://caspian.dotconf.net/menu/Software/SendEmail/"
+SRC_URI="http://caspian.dotconf.net/menu/Software/SendEmail/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ ssl? ( dev-perl/IO-Socket-SSL )"
+
+PATCHES=( "${FILESDIR}/${PV}-overzealous-version-check.patch" )
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dobin sendEmail || die "failed to install sendEmail script"
+ dodoc CHANGELOG README TODO
+}