summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-01-02 18:37:38 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-01-02 18:37:38 +0000
commit0ad5f7cdb0592cab8442de9633d7989fbfb98076 (patch)
tree11471e2edf77a5ef0b03c37d035d67440bbf4353 /net-mail
parentHOMEPAGE updated. (diff)
downloadgentoo-2-0ad5f7cdb0592cab8442de9633d7989fbfb98076.tar.gz
gentoo-2-0ad5f7cdb0592cab8442de9633d7989fbfb98076.tar.bz2
gentoo-2-0ad5f7cdb0592cab8442de9633d7989fbfb98076.zip
Version bump, bug #201952
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imapd/ChangeLog9
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-2.3.11.ebuild252
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-2.3.11-drac_with_autocreate.patch46
-rw-r--r--net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.3.116
4 files changed, 312 insertions, 1 deletions
diff --git a/net-mail/cyrus-imapd/ChangeLog b/net-mail/cyrus-imapd/ChangeLog
index 36fa74eff897..50f95b9a6223 100644
--- a/net-mail/cyrus-imapd/ChangeLog
+++ b/net-mail/cyrus-imapd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/cyrus-imapd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.115 2008/01/01 14:30:21 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.116 2008/01/02 18:37:37 dertobi123 Exp $
+
+*cyrus-imapd-2.3.11 (02 Jan 2008)
+
+ 02 Jan 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +files/cyrus-imapd-2.3.11-drac_with_autocreate.patch,
+ +cyrus-imapd-2.3.11.ebuild:
+ Version bump, bug #201952
01 Jan 2008; Markus Meier <maekke@gentoo.org> cyrus-imapd-2.3.9-r1.ebuild:
x86 stable, bug #201684
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-2.3.11.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-2.3.11.ebuild
new file mode 100644
index 000000000000..cea121c80c5a
--- /dev/null
+++ b/net-mail/cyrus-imapd/cyrus-imapd-2.3.11.ebuild
@@ -0,0 +1,252 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.3.11.ebuild,v 1.1 2008/01/02 18:37:37 dertobi123 Exp $
+
+inherit autotools eutils ssl-cert fixheadtails pam
+
+DESCRIPTION="The Cyrus IMAP Server."
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz
+ mirror://gentoo/${P}-uoa.tbz2"
+LIBWRAP_PATCH_VER="2.2"
+DRAC_PATCH_VER="2.3.11"
+AUTOCREATE_PATCH_VER="0.10-0"
+AUTOSIEVE_PATCH_VER="0.6.0"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="autocreate autosieve drac idled kerberos nntp pam replication snmp ssl tcpd"
+
+PROVIDE="virtual/imapd"
+RDEPEND=">=sys-libs/db-3.2
+ >=dev-libs/cyrus-sasl-2.1.13
+ pam? (
+ virtual/pam
+ >=net-mail/mailbase-1
+ )
+ kerberos? ( virtual/krb5 )
+ snmp? ( >=net-analyzer/net-snmp-5.2.2-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ drac? ( >=mail-client/drac-1.12-r1 )"
+
+DEPEND="$RDEPEND
+ sys-devel/libtool
+ >=sys-devel/autoconf-2.58
+ sys-devel/automake"
+
+new_net-snmp_check() {
+ # tcpd USE flag check. Bug #68254.
+ if use tcpd ; then
+ if has_version net-analyzer/net-snmp && ! built_with_use net-analyzer/net-snmp tcpd ; then
+ eerror "You are emerging this package with USE=\"tcpd\""
+ eerror "but \"net-analyzer/net-snmp\" has been emerged with USE=\"-tcpd\""
+ fail_msg
+ fi
+ else
+ if has_version net-analyzer/net-snmp && built_with_use net-analyzer/net-snmp tcpd ; then
+ eerror "You are emerging this package with USE=\"-tcpd\""
+ eerror "but \"net-analyzer/net-snmp\" has been emerged with USE=\"tcpd\""
+ fail_msg
+ fi
+ fi
+ # DynaLoader check. Bug #67411
+
+ if [ -x "$(type -p net-snmp-config)" ]; then
+ einfo "$(type -p net-snmp-config) is found and executable."
+ NSC_AGENTLIBS="$(net-snmp-config --agent-libs)"
+ einfo "NSC_AGENTLIBS=\""${NSC_AGENTLIBS}"\""
+ if [ -z "$NSC_AGENTLIBS" ]; then
+ eerror "NSC_AGENTLIBS is null"
+ einfo "please report this to bugs.gentoo.org"
+ fi
+ for i in ${NSC_AGENTLIBS}; do
+ # check for the DynaLoader path.
+ if [ "$(expr "$i" : '.*\(DynaLoader\)')" == "DynaLoader" ] ; then
+ DYNALOADER_PATH="$i"
+ einfo "DYNALOADER_PATH=\""${DYNALOADER_PATH}"\""
+ if [[ ! -f "${DYNALOADER_PATH}" ]]; then
+ eerror "\""${DYNALOADER_PATH}"\" is not found."
+ einfo "Have you upgraded \"perl\" after"
+ einfo "you emerged \"net-snmp\". Please re-emerge"
+ einfo "\"net-snmp\" then try again. Bug #67411."
+ die "\""${DYNALOADER_PATH}"\" is not found."
+ fi
+ fi
+ done
+ else
+ eerror "\"net-snmp-config\" not found or not executable!"
+ die "You have \"net-snmp\" installed but \"net-snmp-config\" is not found or not executable. Please re-emerge \"net-snmp\" and try again!"
+ fi
+}
+
+fail_msg() {
+ eerror "enable "snmp" USE flag for this package requires"
+ eerror "that net-analyzer/net-snmp and this package both build with"
+ eerror "\"tcpd\" or \"-tcpd\". Bug #68254"
+ die "sanity check failed."
+}
+
+pkg_setup() {
+ use snmp && new_net-snmp_check
+ enewuser cyrus -1 -1 /usr/cyrus mail
+}
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ ht_fix_file "${S}"/imap/xversion.sh
+
+ # Fix prestripped binaries
+ epatch "${FILESDIR}/${PN}-strip.patch"
+
+ # Unsupported UoA patch. Bug #112912 .
+ # http://email.uoa.gr/projects/cyrus/autocreate/
+ if use autocreate ; then
+ epatch "${WORKDIR}/${P}-autocreate-${AUTOCREATE_PATCH_VER}.diff"
+ use drac \
+ && epatch "${FILESDIR}/${PN}-${DRAC_PATCH_VER}-drac_with_autocreate.patch" \
+ && epatch "${S}/contrib/drac_auth.patch"
+ else
+ use drac && epatch "${S}/contrib/drac_auth.patch"
+ fi
+
+ # Unsupported UoA patch. Bug #133187 .
+ # http://email.uoa.gr/projects/cyrus/autosievefolder/
+ use autosieve && epatch "${WORKDIR}/${P}-autosieve-${AUTOSIEVE_PATCH_VER}.diff"
+
+ # Add libwrap defines as we don't have a dynamicly linked library.
+ use tcpd && epatch "${FILESDIR}/${PN}-${LIBWRAP_PATCH_VER}-libwrap.patch"
+
+ # Fix master(8)->cyrusmaster(8) manpage.
+ for i in `grep -rl -e 'master\.8' -e 'master(8)' "${S}"` ; do
+ sed -i -e 's:master\.8:cyrusmaster.8:g' \
+ -e 's:master(8):cyrusmaster(8):g' \
+ "${i}" || die "sed failed" || die "sed failed"
+ done
+ mv man/master.8 man/cyrusmaster.8 || die "mv failed"
+ sed -i -e "s:MASTER:CYRUSMASTER:g" \
+ -e "s:Master:Cyrusmaster:g" \
+ -e "s:master:cyrusmaster:g" \
+ man/cyrusmaster.8 || die "sed failed"
+
+ # Recreate configure.
+ WANT_AUTOCONF="2.5"
+ eautoreconf
+
+ # When linking with rpm, you need to link with more libraries.
+ sed -i -e "s:lrpm:lrpm -lrpmio -lrpmdb:" configure || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} $(use_with drac)"
+ myconf="${myconf} $(use_with ssl openssl)"
+ myconf="${myconf} $(use_with snmp ucdsnmp)"
+ myconf="${myconf} $(use_with tcpd libwrap)"
+ myconf="${myconf} $(use_enable kerberos gssapi) $(use_enable kerberos krb5afspts)"
+ myconf="${myconf} $(use_enable idled)"
+ myconf="${myconf} $(use_enable nntp nntp)"
+ myconf="${myconf} $(use_enable replication)"
+
+ if use kerberos; then
+ myconf="${myconf} --with-auth=krb5"
+ else
+ myconf="${myconf} --with-auth=unix"
+ fi
+
+ econf \
+ --enable-murder \
+ --enable-listext \
+ --enable-netscapehack \
+ --with-extraident=Gentoo \
+ --with-service-path=/usr/lib/cyrus \
+ --with-cyrus-user=cyrus \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --without-perl \
+ --disable-cyradm \
+ ${myconf} || die "econf failed"
+
+ # needed for parallel make. Bug #72352.
+ cd "${S}"/imap
+ emake xversion.h || die "emake xversion.h failed"
+
+ cd "${S}"
+ emake || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/bin /usr/lib
+ for subdir in master imap imtest timsieved notifyd sieve; do
+ make -C "${subdir}" DESTDIR="${D}" install || die "make install failed"
+ done
+
+ # Link master to cyrusmaster (postfix has a master too)
+ dosym /usr/lib/cyrus/master /usr/lib/cyrus/cyrusmaster
+
+ doman man/*.[0-8]
+ dodoc COPYRIGHT README*
+ dohtml doc/*.html doc/murder.png
+ cp doc/cyrusv2.mc "${D}/usr/share/doc/${PF}/html"
+ cp -r contrib tools "${D}/usr/share/doc/${PF}"
+ find "${D}/usr/share/doc" -name CVS -print0 | xargs -0 rm -rf
+
+ insinto /etc
+ doins "${FILESDIR}/cyrus.conf" "${FILESDIR}/imapd.conf"
+
+ newinitd "${FILESDIR}/cyrus.rc6" cyrus
+ newconfd "${FILESDIR}/cyrus.confd" cyrus
+ newpamd "${FILESDIR}/cyrus.pam-include" sieve
+
+ for subdir in imap/{,db,log,msg,proc,socket,sieve} spool/imap/{,stage.} ; do
+ keepdir "/var/${subdir}"
+ fowners cyrus:mail "/var/${subdir}"
+ fperms 0750 "/var/${subdir}"
+ done
+ for subdir in imap/{user,quota,sieve} spool/imap ; do
+ for i in a b c d e f g h i j k l m n o p q r s t v u w x y z ; do
+ keepdir "/var/${subdir}/${i}"
+ fowners cyrus:mail "/var/${subdir}/${i}"
+ fperms 0750 "/var/${subdir}/${i}"
+ done
+ done
+}
+
+pkg_postinst() {
+ # do not install server.{key,pem) if they are exist.
+ use ssl && {
+ if [ ! -f "${ROOT}"etc/ssl/cyrus/server.key ]; then
+ install_cert /etc/ssl/cyrus/server
+ chown cyrus:mail "${ROOT}"etc/ssl/cyrus/server.{key,pem}
+ fi
+ }
+
+ enewuser cyrus -1 -1 /usr/cyrus mail
+
+ if df -T /var/imap | grep -q ' ext[23] ' ; then
+ ebegin "Making /var/imap/user/* and /var/imap/quota/* synchronous."
+ chattr +S /var/imap/{user,quota}{,/*}
+ eend $?
+ fi
+
+ if df -T /var/spool/imap | grep -q ' ext[23] ' ; then
+ ebegin "Making /var/spool/imap/* synchronous."
+ chattr +S /var/spool/imap{,/*}
+ eend $?
+ fi
+
+ ewarn "If the queue directory of the mail daemon resides on an ext2"
+ ewarn "or ext3 filesystem you need to set it manually to update"
+ ewarn "synchronously. E.g. 'chattr +S /var/spool/mqueue'."
+ echo
+
+ elog "For correct logging add the following to /etc/syslog.conf:"
+ elog " local6.* /var/log/imapd.log"
+ elog " auth.debug /var/log/auth.log"
+ echo
+
+ elog "You have to add user cyrus to the sasldb2. Do this with:"
+ elog " saslpasswd2 cyrus"
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.11-drac_with_autocreate.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.11-drac_with_autocreate.patch
new file mode 100644
index 000000000000..5e7929d7b439
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.11-drac_with_autocreate.patch
@@ -0,0 +1,46 @@
+--- contrib/drac_auth.patch.orig 2008-01-02 20:22:53.244043151 +0100
++++ contrib/drac_auth.patch 2008-01-02 20:23:42.858474159 +0100
+@@ -107,23 +107,23 @@
+ DEPLIBS = ../lib/libcyrus.a ../lib/libcyrus_min.a @DEPLIBS@
+
+ @@ -201,17 +202,17 @@
+- imapd: $(IMAPDOBJS) mutex_fake.o libimap.a $(DEPLIBS) $(SERVICE)
++ imapd: $(IMAPDOBJS) mutex_fake.o libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(SERVICE)
+ $(CC) $(LDFLAGS) -o imapd \
+ $(SERVICE) $(IMAPDOBJS) mutex_fake.o \
+-- libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+-+ libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
++- libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+++ libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
+
+- imapd.pure: $(IMAPDOBJS) mutex_fake.o libimap.a $(DEPLIBS) $(SERVICE)
++ imapd.pure: $(IMAPDOBJS) mutex_fake.o libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(SERVICE)
+ $(PURIFY) $(PUREOPT) $(CC) $(LDFLAGS) -o imapd.pure \
+ $(SERVICE) $(IMAPDOBJS) mutex_fake.o libimap.a \
+-- $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+-+ $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
++- $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+++ $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
+
+- imapd.quant: $(IMAPDOBJS) mutex_fake.o libimap.a $(DEPLIBS) $(SERVICE)
++ imapd.quant: $(IMAPDOBJS) mutex_fake.o libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(SERVICE)
+ $(QUANTIFY) $(QUANTOPT) $(CC) $(LDFLAGS) -o imapd.quant \
+ $(SERVICE) $(IMAPDOBJS) mutex_fake.o libimap.a \
+-- $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+-+ $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
++- $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+++ $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
+
+ mupdate: mupdate.o mupdate-slave.o mupdate-client.o mutex_pthread.o tls.o \
+ libimap.a $(DEPLIBS)
+@@ -131,8 +131,8 @@
+ pop3d: pop3d.o proxy.o backend.o tls.o mutex_fake.o libimap.a \
+ $(DEPLIBS) $(SERVICE)
+ $(CC) $(LDFLAGS) -o pop3d pop3d.o proxy.o backend.o tls.o $(SERVICE) \
+-- mutex_fake.o libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+-+ mutex_fake.o libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
++- mutex_fake.o libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+++ mutex_fake.o libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
+
+ nntpd: nntpd.o proxy.o backend.o index.o smtpclient.o spool.o tls.o \
+ mutex_fake.o nntp_err.o libimap.a $(DEPLIBS) $(SERVICE)
diff --git a/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.3.11 b/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.3.11
new file mode 100644
index 000000000000..a4c083d3114a
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.3.11
@@ -0,0 +1,6 @@
+MD5 2c1bad387120e6738b4bf917b4514cd4 cyrus-imapd-2.3.11-uoa.tbz2 18045
+RMD160 8f35b2399b47669d99fd301be1e14aaaab903234 cyrus-imapd-2.3.11-uoa.tbz2 18045
+SHA256 c67f97274c328c80f1cbaab7514fdd0de05c032e57b526e4e13e8f63d212aa9d cyrus-imapd-2.3.11-uoa.tbz2 18045
+MD5 df632eb2a89e36e6296e4abd687435ed cyrus-imapd-2.3.11.tar.gz 2275173
+RMD160 34727e08cc25f3cb6e0ea0195b96de942de10f48 cyrus-imapd-2.3.11.tar.gz 2275173
+SHA256 87ce58b28ed1f8974118c02ac009377bb3de62adccd699a67f0100158106d842 cyrus-imapd-2.3.11.tar.gz 2275173