summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-10-01 02:57:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-10-01 02:57:34 +0000
commit04d912d03c6f865590cb843672272701eba6f99e (patch)
tree66f85daa5872ffa052050be14bdb7a64a21771cd /net-mail
parenttidy (diff)
downloadgentoo-2-04d912d03c6f865590cb843672272701eba6f99e.tar.gz
gentoo-2-04d912d03c6f865590cb843672272701eba6f99e.tar.bz2
gentoo-2-04d912d03c6f865590cb843672272701eba6f99e.zip
Two binaries are not installed by the buildsystem installer, add them manually.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/ezmlm-idx/ChangeLog9
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r2.ebuild62
2 files changed, 70 insertions, 1 deletions
diff --git a/net-mail/ezmlm-idx/ChangeLog b/net-mail/ezmlm-idx/ChangeLog
index 87bb53f7cb91..2fe30de682e6 100644
--- a/net-mail/ezmlm-idx/ChangeLog
+++ b/net-mail/ezmlm-idx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/ezmlm-idx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.30 2010/06/17 20:53:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.31 2010/10/01 02:57:34 robbat2 Exp $
+
+*ezmlm-idx-7.0.0-r2 (01 Oct 2010)
+
+ 01 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +ezmlm-idx-7.0.0-r2.ebuild:
+ Two binaries are not installed by the buildsystem installer, add them
+ manually.
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> ezmlm-idx-0.40-r2.ebuild,
ezmlm-idx-6.0.0.ebuild, ezmlm-idx-7.0.0.ebuild, ezmlm-idx-7.0.0-r1.ebuild:
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r2.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r2.ebuild
new file mode 100644
index 000000000000..ab2f953238f8
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r2.ebuild,v 1.1 2010/10/01 02:57:34 robbat2 Exp $
+
+inherit qmail multilib
+
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
+HOMEPAGE="http://www.ezmlm.org"
+SRC_URI="http://www.ezmlm.org/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql postgres"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+
+pkg_setup() {
+ if use mysql && use postgres; then
+ die "cannot build mysql and pgsql support at the same time"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+
+ echo /usr/bin > conf-bin
+ echo /usr/$(get_libdir)/ezmlm > conf-lib
+ echo /etc/ezmlm > conf-etc
+ echo /usr/share/man > conf-man
+ echo ${QMAIL_HOME} > conf-qmail
+
+ echo $(tc-getCC) ${CFLAGS} -I/usr/include/{my,postgre}sql > conf-cc
+ echo $(tc-getCC) ${CFLAGS} -Wl,-E > conf-ld
+
+ # fix DESTDIR and skip cat man-pages
+ sed -e "s:\(/install\) \(\"\`head\):\1 ${D}\2:" \
+ -e "s:\(./install.*\) < MAN$:grep -v \:/cat MAN | \1:" \
+ -e "s:\(\"\`head -n 1 conf-etc\`\"/default\):${D}\1:" \
+ -i Makefile
+}
+
+src_compile() {
+ emake it man || die "make failed"
+
+ if use mysql; then
+ emake mysql || die "make mysql failed"
+ elif use postgres; then
+ emake pgsql || die "make pgsql failed"
+ fi
+}
+
+src_install () {
+ dodir /usr/bin /usr/$(get_libdir)/ezmlm /etc/ezmlm /usr/share/man
+ dobin ezmlm-{cgi,checksub,import,rmtab}
+
+ make DESTDIR="${D}" setup || die "make setup failed"
+}