summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2003-02-05 02:02:49 +0000
committerJon Nall <nall@gentoo.org>2003-02-05 02:02:49 +0000
commit2702c5d13afbab7e774f70434cf4cce7032de1f0 (patch)
treeaecd74fce34fa5f85ea86230350eb8bbd7157e6e /net-mail/ximian-connector/ximian-connector-1.2.1_p2-r1.ebuild
parentMoved ssl cert creation to pkg_config() and only runs if ssl and if cert (diff)
downloadgentoo-2-2702c5d13afbab7e774f70434cf4cce7032de1f0.tar.gz
gentoo-2-2702c5d13afbab7e774f70434cf4cce7032de1f0.tar.bz2
gentoo-2-2702c5d13afbab7e774f70434cf4cce7032de1f0.zip
fix for #15054; d/l rpm from ximian's site (w/ RESTRICT="nomirror")
Diffstat (limited to 'net-mail/ximian-connector/ximian-connector-1.2.1_p2-r1.ebuild')
-rw-r--r--net-mail/ximian-connector/ximian-connector-1.2.1_p2-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-mail/ximian-connector/ximian-connector-1.2.1_p2-r1.ebuild b/net-mail/ximian-connector/ximian-connector-1.2.1_p2-r1.ebuild
new file mode 100644
index 000000000000..c8599081aaed
--- /dev/null
+++ b/net-mail/ximian-connector/ximian-connector-1.2.1_p2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ximian-connector/ximian-connector-1.2.1_p2-r1.ebuild,v 1.1 2003/02/05 02:02:49 nall Exp $
+
+DESCRIPTION="Ximian Connector (An Evolution Plugin to talk to Exchange Servers)"
+HOMEPAGE="http://www.ximian.com"
+LICENSE="Ximian-Connector"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -sparc -alpha -mips"
+RESTRICT="mirror nostrip"
+
+XIMIAN_ARCH="blargh"
+XIMIAN_DIST="frobs"
+
+if [ `use ppc` ]; then
+ XIMIAN_DIST="yellowdog-22-ppc"
+ XIMIAN_ARCH="ppc"
+elif [ `use x86` ]; then
+ XIMIAN_DIST="redhat-73-i386"
+ XIMIAN_ARCH="i386"
+else
+ die "Unsupported ARCH: ${ARCH}"
+fi
+
+# make the ximian rev from the package version
+# 1.2.1_p2 should result in 1.2.1-2
+XIMIAN_REV=`echo ${PV} | sed -e "s/_p/-/"`
+
+SRC_URI="http://red-carpet.ximian.com/${PN}/${XIMIAN_DIST}/${PN}-${XIMIAN_REV}.ximian.1.${XIMIAN_ARCH}.rpm"
+
+DEPEND="app-arch/rpm2targz
+ >=net-mail/evolution-1.2.1*"
+RDEPEND=">=net-mail/evolution-1.2.1*"
+
+pkg_setup() {
+ if [ "${ARCH}" != "x86" -a "${ARCH}" != "ppc" ]
+ then
+ einfo "This package is only available for x86 and ppc, sorry"
+ die "Not supported on your ARCH"
+ fi
+}
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${A}
+ tar -xzf ${WORKDIR}/${PN}-${XIMIAN_REV}.ximian.1.${XIMIAN_ARCH}.tar.gz
+}
+
+src_install() {
+ cd ${WORKDIR}
+ rm -f ${PN}-${XIMIAN_REV}.ximian.1.${XIMIAN_ARCH}.tar.gz
+ cp -dpR * ${D}
+ dosym /usr/lib/libssl.so /usr/lib/libssl.so.2
+ dosym /usr/lib/libcrypto.so /usr/lib/libcrypto.so.2
+}
+
+post_install(){
+ einfo "NOTE: Ximian connector requires the purchase of a"
+ einfo "key from Ximian to function properly."
+}