summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-03 00:29:15 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-03 00:29:15 +0000
commit1774468136418e6897f211f507b3009134dc38fa (patch)
treedebf254915e8261031956f5bc68553451ce36d5a /net-mail/vpopmail
parentrestore egethome as some packages in the tree have been parsing getent direct... (diff)
downloadgentoo-2-1774468136418e6897f211f507b3009134dc38fa.tar.gz
gentoo-2-1774468136418e6897f211f507b3009134dc38fa.tar.bz2
gentoo-2-1774468136418e6897f211f507b3009134dc38fa.zip
Use new egethome helper rather than calling getent directly.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/vpopmail')
-rw-r--r--net-mail/vpopmail/ChangeLog6
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.16.ebuild11
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild6
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild6
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.33.ebuild6
5 files changed, 18 insertions, 17 deletions
diff --git a/net-mail/vpopmail/ChangeLog b/net-mail/vpopmail/ChangeLog
index 30510f89d6f8..c42d36b5fbfa 100644
--- a/net-mail/vpopmail/ChangeLog
+++ b/net-mail/vpopmail/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/vpopmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.105 2011/09/10 16:43:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.106 2011/11/03 00:29:15 vapier Exp $
+
+ 03 Nov 2011; Mike Frysinger <vapier@gentoo.org> vpopmail-5.4.16.ebuild,
+ vpopmail-5.4.30-r1.ebuild, vpopmail-5.4.30-r2.ebuild, vpopmail-5.4.33.ebuild:
+ Use new egethome helper rather than calling getent directly.
10 Sep 2011; Raúl Porcel <armin76@gentoo.org> vpopmail-5.4.30-r1.ebuild:
ia64 stable wrt #378373
diff --git a/net-mail/vpopmail/vpopmail-5.4.16.ebuild b/net-mail/vpopmail/vpopmail-5.4.16.ebuild
index b2a5d3afd79e..e151b7b06646 100644
--- a/net-mail/vpopmail/vpopmail-5.4.16.ebuild
+++ b/net-mail/vpopmail/vpopmail-5.4.16.ebuild
@@ -1,11 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.16.ebuild,v 1.15 2010/10/03 17:41:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.16.ebuild,v 1.16 2011/11/03 00:29:15 vapier Exp $
-WANT_AUTOCONF=latest
-WANT_AUTOMAKE=latest
-
-inherit eutils fixheadtails autotools
+inherit eutils fixheadtails autotools user
# TODO: all ldap, sybase support
#MY_PV=${PV/_/-}
@@ -37,7 +34,7 @@ VPOP_HOME="$VPOP_DEFAULT_HOME"
# This makes sure the variable is set, and that it isn't null.
vpopmail_set_homedir() {
- VPOP_HOME=`getent passwd vpopmail | cut -d: -f6`
+ VPOP_HOME=$(egethome)
if [ -z "$VPOP_HOME" ]; then
echo -ne "\a"
eerror "vpopmail's home directory is null in passwd data!"
diff --git a/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild b/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild
index 3823e36934ad..1f7363583548 100644
--- a/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild
+++ b/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild,v 1.8 2011/09/10 16:43:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild,v 1.9 2011/11/03 00:29:15 vapier Exp $
EAPI="2"
-inherit autotools eutils fixheadtails qmail
+inherit autotools eutils fixheadtails qmail user
HOMEPAGE="http://www.inter7.com/index.php?page=vpopmail"
DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail mail servers."
@@ -24,7 +24,7 @@ RDEPEND="${DEPEND}"
VPOP_DEFAULT_HOME="/var/vpopmail"
vpopmail_set_homedir() {
- VPOP_HOME=$(getent passwd vpopmail | cut -d: -f6)
+ VPOP_HOME=$(egethome)
if [[ -z "${VPOP_HOME}" ]]; then
ebeep
eerror "vpopmail's home directory is null in passwd data!"
diff --git a/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild b/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild
index a0ee5121f172..bdd03921051b 100644
--- a/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild
+++ b/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild,v 1.3 2011/05/15 10:13:15 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild,v 1.4 2011/11/03 00:29:15 vapier Exp $
EAPI="2"
-inherit autotools eutils fixheadtails qmail
+inherit autotools eutils fixheadtails qmail user
HOMEPAGE="http://www.inter7.com/index.php?page=vpopmail"
DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail mail servers."
@@ -25,7 +25,7 @@ RDEPEND="${DEPEND}"
VPOP_DEFAULT_HOME="/var/vpopmail"
vpopmail_set_homedir() {
- VPOP_HOME=$(getent passwd vpopmail | cut -d: -f6)
+ VPOP_HOME=$(egethome)
if [[ -z "${VPOP_HOME}" ]]; then
ebeep
eerror "vpopmail's home directory is null in passwd data!"
diff --git a/net-mail/vpopmail/vpopmail-5.4.33.ebuild b/net-mail/vpopmail/vpopmail-5.4.33.ebuild
index 05c88cb0dffc..18f4e402dbf6 100644
--- a/net-mail/vpopmail/vpopmail-5.4.33.ebuild
+++ b/net-mail/vpopmail/vpopmail-5.4.33.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.33.ebuild,v 1.3 2011/08/20 07:28:13 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.33.ebuild,v 1.4 2011/11/03 00:29:15 vapier Exp $
EAPI=4
-inherit autotools eutils fixheadtails qmail
+inherit autotools eutils fixheadtails qmail user
HOMEPAGE="http://www.inter7.com/index.php?page=vpopmail"
DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail mail servers."
@@ -25,7 +25,7 @@ RDEPEND="${DEPEND}"
VPOP_DEFAULT_HOME="/var/vpopmail"
vpopmail_set_homedir() {
- VPOP_HOME=$(getent passwd vpopmail | cut -d: -f6)
+ VPOP_HOME=$(egethome)
if [[ -z "${VPOP_HOME}" ]]; then
ebeep
eerror "vpopmail's home directory is null in passwd data!"