summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-02-01 15:43:45 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-02-01 15:43:45 +0000
commit79af2f86c397bf3231b80039f43895318c93aa41 (patch)
tree9db0efd165d4f39af9577189179a3fedb52e6d3d /net-mail/uw-imap
parentPatched Makefile to build shared library for amd64 (2004a-r1), also fixed the... (diff)
downloadgentoo-2-79af2f86c397bf3231b80039f43895318c93aa41.tar.gz
gentoo-2-79af2f86c397bf3231b80039f43895318c93aa41.tar.bz2
gentoo-2-79af2f86c397bf3231b80039f43895318c93aa41.zip
Patched Makefile to build shared library for amd64, as well as use -fPIC only for the shared library. Also fixed symlinking of c-client.a on multilib d added respect for CFLAGS.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-mail/uw-imap')
-rw-r--r--net-mail/uw-imap/ChangeLog10
-rw-r--r--net-mail/uw-imap/files/digest-uw-imap-2004c-r11
-rw-r--r--net-mail/uw-imap/files/uw-imap-2004c-amd64-so-fix.patch13
-rw-r--r--net-mail/uw-imap/uw-imap-2004c-r1.ebuild153
4 files changed, 176 insertions, 1 deletions
diff --git a/net-mail/uw-imap/ChangeLog b/net-mail/uw-imap/ChangeLog
index a9bd07398367..76694457b20e 100644
--- a/net-mail/uw-imap/ChangeLog
+++ b/net-mail/uw-imap/ChangeLog
@@ -1,10 +1,18 @@
# ChangeLog for net-mail/uw-imap
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.54 2005/01/30 19:43:26 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.55 2005/02/01 15:43:45 cryos Exp $
30 Jan 2005; Bryan Østergaard <kloeri@gentoo.org> uw-imap-2004c.ebuild:
Stable on alpha, bug 79874.
+*uw-imap-2004c-r1 (01 Feb 2005)
+
+ 01 Feb 2005; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/uw-imap-2004c-amd64-so-fix.patch, +uw-imap-2004c-r1.ebuild:
+ Patched Makefile to build a shared library for amd64, allowing PHP 5 with imap
+ to compile. Also fixed the symlinking of c-client.a for multilib archs, and
+ made the ebuild respect user CFLAGS.
+
29 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org> uw-imap-2004c.ebuild:
stable on amd64.
diff --git a/net-mail/uw-imap/files/digest-uw-imap-2004c-r1 b/net-mail/uw-imap/files/digest-uw-imap-2004c-r1
new file mode 100644
index 000000000000..3e0d89c32ffc
--- /dev/null
+++ b/net-mail/uw-imap/files/digest-uw-imap-2004c-r1
@@ -0,0 +1 @@
+MD5 f0a1a2abfa4b1ed8074ce023724416f3 imap-2004c1.tar.Z 2227092
diff --git a/net-mail/uw-imap/files/uw-imap-2004c-amd64-so-fix.patch b/net-mail/uw-imap/files/uw-imap-2004c-amd64-so-fix.patch
new file mode 100644
index 000000000000..1400fc254c6d
--- /dev/null
+++ b/net-mail/uw-imap/files/uw-imap-2004c-amd64-so-fix.patch
@@ -0,0 +1,13 @@
+diff -ruN src/osdep/unix/Makefile src/osdep/unix/Makefile
+--- src/osdep/unix/Makefile 2005-01-29 22:43:25.739341544 +0000
++++ src/osdep/unix/Makefile 2005-01-29 22:43:50.375596264 +0000
+@@ -912,6 +912,9 @@
+ -DRSHPATH=\"$(RSHPATH)\" -DLOCKPGM=\"$(LOCKPGM)\" > OSCFLAGS
+ echo $(BASELDFLAGS) $(EXTRALDFLAGS) > LDFLAGS
+ echo "$(ARRC) $(ARCHIVE) $(BINARIES);$(RANLIB) $(ARCHIVE)" > ARCHIVE
++ echo "`$(CAT) CCTYPE` `$(CAT) CFLAGS` `$(CAT) OSFLAGS` -shared \
++ -Wl,-soname,libc-client.so.1 -o libc-client.so.1.0.0 $(BINARIES)" \
++ >> ARCHIVE
+ echo $(OS) > OSTYPE
+ ./drivers $(EXTRADRIVERS) $(DEFAULTDRIVERS) dummy
+ ./mkauths $(EXTRAAUTHENTICATORS) $(DEFAULTAUTHENTICATORS)
diff --git a/net-mail/uw-imap/uw-imap-2004c-r1.ebuild b/net-mail/uw-imap/uw-imap-2004c-r1.ebuild
new file mode 100644
index 000000000000..49beb1da2816
--- /dev/null
+++ b/net-mail/uw-imap/uw-imap-2004c-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2004c-r1.ebuild,v 1.1 2005/02/01 15:43:45 cryos Exp $
+
+inherit flag-o-matic
+
+MY_P="imap-${PV}1"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW server daemons for IMAP and POP network mail protocols."
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+HOMEPAGE="http://www.washington.edu/imap/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~hppa ~alpha ~amd64"
+IUSE="ipv6 ssl pic kerberos"
+
+PROVIDE="virtual/imapd"
+PROVIDE="${PROVIDE} virtual/imap-c-client"
+DEPEND="!net-mail/vimap
+ !virtual/imap-c-client
+ virtual/libc
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ kerberos? ( virtual/krb5 )"
+
+src_unpack() {
+ unpack ${A}
+ # Tarball packed with bad file perms
+ chmod -R ug+w ${S}
+
+ cd ${S}
+
+ if use amd64; then
+ # Now we must make all the individual Makefiles use different CFLAGS,
+ # otherwise they would all use -fPIC
+ sed -i -e "s|\`cat \$C/CFLAGS\`|${CFLAGS}|g" src/dmail/Makefile \
+ src/imapd/Makefile src/ipopd/Makefile src/mailutil/Makefile \
+ src/mlock/Makefile src/mtest/Makefile src/tmail/Makefile \
+ || die "sed failed patching Makefile CFLAGS."
+ # Now there is only c-client left, which should be built with -fPIC
+ append-flags -fPIC
+ # Apply our patch to actually build the shared library for PHP5
+ epatch ${FILESDIR}/${P}-amd64-so-fix.patch
+ fi
+
+ use pic || use alpha && append-flags -fPIC
+
+ cd ${S}/src/osdep/unix/
+ cp Makefile Makefile.orig
+ sed \
+ -e "s:BASECFLAGS=\".*\":BASECFLAGS=:g" \
+ -e 's,SSLDIR=/usr/local/ssl,SSLDIR=/usr,g' \
+ -e 's,SSLCERTS=$(SSLDIR)/certs,SSLCERTS=/etc/ssl/certs,g' \
+ < Makefile.orig > Makefile
+
+ # Uncomment this for MBX support
+ #cp Makefile Makefile.orig2
+ #sed \
+ # -e "s:CREATEPROTO=unixproto:CREATEPROTO=mbxproto:" \
+ # -e "s:EMPTYPROTO=unixproto:EMPTYPROTO=mbxproto:" \
+ # < Makefile.orig2 > Makefile
+}
+
+src_compile() {
+ local mymake
+ local ipver
+ ipver="IP=4"
+
+ use ipv6 && echo ipv6
+ use kerberos && echo kerberos
+ use ssl && echo ssl
+ use ipv6 && ipver="IP=6"
+ use kerberos \
+ && mymake="EXTRAAUTHENTICATORS=gss"
+ if use ssl; then
+ cd ${S}
+ echo ${mymake}
+ yes | make lnp ${mymake} ${ipver} SSLTYPE=unix EXTRACFLAGS="${CFLAGS}" || die
+
+ local i
+ for i in imapd ipop3d; do
+ umask 077
+ PEM1=`/bin/mktemp ${T}/openssl.XXXXXX`
+ PEM2=`/bin/mktemp ${T}/openssl.XXXXXX`
+ /usr/bin/openssl req -newkey rsa:1024 -keyout $$PEM1 \
+ -nodes -x509 -days 365 -out $$PEM2 << EOF
+--
+SomeState
+SomeCity
+SomeOrganization
+SomeOrganizationalUnit
+localhost.localdomain
+root@localhost.localdomain
+EOF
+
+ cat $$PEM1 > ${i}.pem
+ echo "" >> ${i}.pem
+ cat $$PEM2 >> ${i}.pem
+ rm $$PEM1 $$PEM2
+ umask 022
+ done
+ else
+ yes | make lnp ${mymake} ${ipver} SSLTYPE=none EXTRACFLAGS="${CFLAGS}" || die
+ fi
+}
+
+src_install() {
+ into /usr
+ dosbin imapd/imapd ipopd/ipop?d dmail/dmail tmail/tmail
+ dobin mailutil/mailutil mlock/mlock mtest/mtest
+
+ if use ssl; then
+ dodir /etc/ssl/certs
+ mv imapd.pem ${D}/etc/ssl/certs
+ mv ipop3d.pem ${D}/etc/ssl/certs
+ fi
+
+ if use amd64; then
+ dolib.so c-client/libc-client.so*
+ cd ${D}/usr/$(get_libdir)
+ ln -s libc-client.so.1.0.0 libc-client.so.1
+ ln -s libc-client.so.1 libc-client.so
+ fi
+
+ cd ${S}
+
+ insinto /usr/include/imap
+ doins c-client/{c-client,mail,imap4r1,rfc822,linkage,misc,smtp,nntp}.h
+ doins c-client/{osdep,env_unix,env,fs,ftl,nl,tcp}.h
+ dolib.a c-client/c-client.a
+ dosym /usr/$(get_libdir)/c-client.a /usr/$(get_libdir)/libc-client.a
+
+ doman src/ipopd/ipopd.8 src/imapd/imapd.8
+ doman src/dmail/dmail.1 src/tmail/tmail.1 src/mailutil/mailutil.1
+
+ dodoc CPYRIGHT README docs/*.txt docs/CONFIG docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+
+ # gentoo config stuff
+ insinto /etc/pam.d
+ newins ${FILESDIR}/uw-imap.pam-system-auth imap
+ newins ${FILESDIR}/uw-imap.pam-system-auth pop
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/uw-imap.xinetd imap
+ newins ${FILESDIR}/uw-ipop2.xinetd ipop2
+ newins ${FILESDIR}/uw-ipop3.xinetd ipop3
+ newins ${FILESDIR}/uw-ipop3s.xinetd ipop3s
+ newins ${FILESDIR}/uw-imaps.xinetd imaps
+}