summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-12-10 21:14:07 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-12-10 21:14:07 +0000
commit1260768daddc2040d7a5b09c81f930d75b26a856 (patch)
tree579203b386c949b164c85d5bd1107010db355b79 /net-mail/tmda
parentadd -fPIC to allowed flags for ia64 (diff)
downloadgentoo-2-1260768daddc2040d7a5b09c81f930d75b26a856.tar.gz
gentoo-2-1260768daddc2040d7a5b09c81f930d75b26a856.tar.bz2
gentoo-2-1260768daddc2040d7a5b09c81f930d75b26a856.zip
Version update.
Diffstat (limited to 'net-mail/tmda')
-rw-r--r--net-mail/tmda/ChangeLog8
-rw-r--r--net-mail/tmda/Manifest2
-rw-r--r--net-mail/tmda/files/digest-tmda-0.921
-rw-r--r--net-mail/tmda/tmda-0.92.ebuild59
4 files changed, 69 insertions, 1 deletions
diff --git a/net-mail/tmda/ChangeLog b/net-mail/tmda/ChangeLog
index 800501aba18e..fc8aa8ff6672 100644
--- a/net-mail/tmda/ChangeLog
+++ b/net-mail/tmda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/tmda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.38 2003/12/01 19:21:39 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.39 2003/12/10 21:14:07 agenkin Exp $
+
+*tmda-0.92 (10 Dec 2003)
+
+ 10 Dec 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
+ Changed the official mirror to be http://tmda.sourceforge.net/releases/.
*tmda-0.90 (01 Dec 2003)
diff --git a/net-mail/tmda/Manifest b/net-mail/tmda/Manifest
index 79976aa69cdd..1f46e477c550 100644
--- a/net-mail/tmda/Manifest
+++ b/net-mail/tmda/Manifest
@@ -6,9 +6,11 @@ MD5 c98081c92f693a7c4faf4d5b32d1bb5b tmda-0.82.ebuild 1551
MD5 4ba4a6d08c451e52eeb86ac25ac0cb6d metadata.xml 253
MD5 69d21896f4d8e4a8921ef7e7567bab03 tmda-0.90.ebuild 1573
MD5 3dc6bf25fd1e0d7c47d9964709f33a3a tmda-0.86.ebuild 1552
+MD5 0843776769e0b5be92b3aea7e69a9102 tmda-0.92.ebuild 1579
MD5 95616117ddaf3c139d00283eb765647e files/digest-tmda-0.87 58
MD5 d8634a47ed967d8369e5f1031acb4e7a files/digest-tmda-0.89 58
MD5 42462478761427da2aeb91f7bdd47328 files/digest-tmda-0.80 58
MD5 cd268ee6ff6b0b618d5033beafe75465 files/digest-tmda-0.82 58
MD5 e19a7fd18db9b20bbc8b6670d4abcbbf files/digest-tmda-0.86 58
MD5 fb1355496a5f65d4e0b5f0b68b816097 files/digest-tmda-0.90 58
+MD5 7bb9e7641e04129bd8f857fb7feb59e3 files/digest-tmda-0.92 58
diff --git a/net-mail/tmda/files/digest-tmda-0.92 b/net-mail/tmda/files/digest-tmda-0.92
new file mode 100644
index 000000000000..94cb5b4e2fed
--- /dev/null
+++ b/net-mail/tmda/files/digest-tmda-0.92
@@ -0,0 +1 @@
+MD5 1d56e7be312dd3f74a76a0623241b727 tmda-0.92.tgz 399205
diff --git a/net-mail/tmda/tmda-0.92.ebuild b/net-mail/tmda/tmda-0.92.ebuild
new file mode 100644
index 000000000000..94e47abc9f14
--- /dev/null
+++ b/net-mail/tmda/tmda-0.92.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.92.ebuild,v 1.1 2003/12/10 21:14:07 agenkin Exp $
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.2
+ virtual/mta"
+
+SRC_URI="http://tmda.sf.net/releases/${P}.tgz
+ http://tmda.sf.net/releases/old/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+
+S="${WORKDIR}/${P}"
+
+src_compile () {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+ dohtml -r htdocs/img
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe collectaddys def2html getuserinfo-vpopmail.sh printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins ChangeLog sample.config tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+
+}