summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-04-23 02:24:08 +0000
committerJon Nelson <jnelson@gentoo.org>2002-04-23 02:24:08 +0000
commit771c10faf3c24e85b8ec13ce2c4bf824c571807b (patch)
treea114fdd7d5013b3e2cef7c9386539614b9846194 /net-mail/sylpheed
parentarts dependency changed from kdelibs to arts (diff)
downloadgentoo-2-771c10faf3c24e85b8ec13ce2c4bf824c571807b.tar.gz
gentoo-2-771c10faf3c24e85b8ec13ce2c4bf824c571807b.tar.bz2
gentoo-2-771c10faf3c24e85b8ec13ce2c4bf824c571807b.zip
update to 0.7.5
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/ChangeLog8
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.7.51
-rw-r--r--net-mail/sylpheed/sylpheed-0.7.5.ebuild49
3 files changed, 57 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index 146ebb948772..65855d504077 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.4 2002/04/16 01:05:15 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.5 2002/04/23 02:24:08 jnelson Exp $
+
+*sylpheed-0.7.5 (22 Apr 2002)
+
+ 22 Apr 2002; Jon Nelson <jnelson@gentoo.org> sylpheed-0.7.5.ebuild:
+
+ New upstream
*sylpheed-0.7.4-r1 (15 Apr 2002)
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.7.5 b/net-mail/sylpheed/files/digest-sylpheed-0.7.5
new file mode 100644
index 000000000000..138a3d5bfe19
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.7.5
@@ -0,0 +1 @@
+MD5 6a471e8b0569f03d1c6a3dcfb0e27896 sylpheed-0.7.5.tar.bz2 1701512
diff --git a/net-mail/sylpheed/sylpheed-0.7.5.ebuild b/net-mail/sylpheed/sylpheed-0.7.5.ebuild
new file mode 100644
index 000000000000..c183fa017e93
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.7.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.7.5.ebuild,v 1.1 2002/04/23 02:24:08 jnelson Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/sylpheed/sylpheed-${PV}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/compface-1.4
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+
+ local myconf
+
+ use gnome || myconf="--disable-gdk-pixbuf --disable-imlib"
+ use nls || myconf="$myconf --disable-nls"
+ use ssl && myconf="$myconf --enable-ssl"
+ use crypt && myconf="$myconf --enable-gpgme"
+ use pda && myconf="$myconf --enable-jpilot"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}
+