summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-10 01:07:30 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-10 01:07:30 +0000
commit5ad42ae03a6e814d65952c1d0475d7aa770cb134 (patch)
treeb6b8ed849bd6ffefbf20b9d2db4007e41863ff3b /net-mail/sylpheed
parentNew ebuild. Still needs work! (diff)
downloadgentoo-2-5ad42ae03a6e814d65952c1d0475d7aa770cb134.tar.gz
gentoo-2-5ad42ae03a6e814d65952c1d0475d7aa770cb134.tar.bz2
gentoo-2-5ad42ae03a6e814d65952c1d0475d7aa770cb134.zip
Added ldap USE variable support. Fixes #3478
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/ChangeLog8
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.7.7-r11
-rw-r--r--net-mail/sylpheed/sylpheed-0.7.7-r1.ebuild52
3 files changed, 60 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index 43a6373be414..a9663b27a6ca 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.7 2002/06/09 18:28:22 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.8 2002/06/10 01:07:29 rphillips Exp $
+*sylpheed-0.7.7-r1 (09 Jun 2002)
+
+ 09 Jun 2002; Ryan Phillips <rphillips@gentoo.org> sylpheed-0.7.7-r1.ebuild:
+
+ Added support for ldap USE variable
+
*sylpheed-0.7.7 (09 Jun 2002)
09 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> sylpheed-0.7.7.ebuild:
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.7.7-r1 b/net-mail/sylpheed/files/digest-sylpheed-0.7.7-r1
new file mode 100644
index 000000000000..b5c49246035b
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.7.7-r1
@@ -0,0 +1 @@
+MD5 a6f5c90e791706dc4ceee6590a3e2a5a sylpheed-0.7.7.tar.bz2 1797388
diff --git a/net-mail/sylpheed/sylpheed-0.7.7-r1.ebuild b/net-mail/sylpheed/sylpheed-0.7.7-r1.ebuild
new file mode 100644
index 000000000000..1e93c44a6cd6
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.7.7-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.7.7-r1.ebuild,v 1.1 2002/06/10 01:07:29 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/sylpheed/sylpheed-${PV}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/compface-1.4
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+
+ local myconf
+
+ use gnome || myconf="--disable-gdk-pixbuf --disable-imlib"
+ use nls || myconf="$myconf --disable-nls"
+ use ssl && myconf="$myconf --enable-ssl"
+ use crypt && myconf="$myconf --enable-gpgme"
+ use pda && myconf="$myconf --enable-jpilot"
+ use ldap && myconf="$myconf --enable-ldap"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}
+