summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-09-12 08:37:41 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-09-12 08:37:41 +0000
commit8197f55874167c20b2c76676bc1dba662cef4b33 (patch)
tree0b1877e32cf5bd062998f0f591973907ea20d7b8 /net-mail/swaks/swaks-20050709.1.ebuild
parentDo not use ${HOMEPAGE} in SRC_URI. (diff)
downloadgentoo-2-8197f55874167c20b2c76676bc1dba662cef4b33.tar.gz
gentoo-2-8197f55874167c20b2c76676bc1dba662cef4b33.tar.bz2
gentoo-2-8197f55874167c20b2c76676bc1dba662cef4b33.zip
20050605.3 stable on x86. Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-mail/swaks/swaks-20050709.1.ebuild')
-rw-r--r--net-mail/swaks/swaks-20050709.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-mail/swaks/swaks-20050709.1.ebuild b/net-mail/swaks/swaks-20050709.1.ebuild
new file mode 100644
index 000000000000..faddf4e5669d
--- /dev/null
+++ b/net-mail/swaks/swaks-20050709.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/swaks/swaks-20050709.1.ebuild,v 1.1 2005/09/12 08:37:41 ticho Exp $
+
+MY_P=${P/-/.}
+DESCRIPTION="Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH"
+HOMEPAGE="http://www.jetmore.org/john/code/#swaks"
+SRC_URI="http://www.jetmore.org/john/code/${MY_P}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+IUSE="ssl"
+
+DEPEND=">=dev-lang/perl-5.8.3"
+
+RDEPEND="${DEPEND}
+ >=dev-perl/Net-DNS-0.40
+ ssl? ( >=dev-perl/Net-SSLeay-1.23 )
+ >=perl-core/MIME-Base64-3.00
+ >=perl-core/Digest-MD5-2.33
+ >=perl-core/Time-HiRes-1.54
+ >=dev-perl/Authen-NTLM-1.02
+ >=dev-perl/Authen-DigestMD5-0.04"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${DISTDIR}/${A} ${WORKDIR}
+}
+
+src_install() {
+ newbin ${MY_P} swaks
+}
+