summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-18 18:26:10 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-18 18:26:10 +0000
commitc49a9b4a50b392ebc372a42a7df1b1f42f154b8f (patch)
tree40c1b2afab19bb76f77cd3a7cdd905f447aeaf79 /net-mail/squirrelmail/squirrelmail-1.2.11.ebuild
parentversion bump (diff)
downloadgentoo-2-c49a9b4a50b392ebc372a42a7df1b1f42f154b8f.tar.gz
gentoo-2-c49a9b4a50b392ebc372a42a7df1b1f42f154b8f.tar.bz2
gentoo-2-c49a9b4a50b392ebc372a42a7df1b1f42f154b8f.zip
Version bump. Bug fixes.
Diffstat (limited to 'net-mail/squirrelmail/squirrelmail-1.2.11.ebuild')
-rw-r--r--net-mail/squirrelmail/squirrelmail-1.2.11.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-mail/squirrelmail/squirrelmail-1.2.11.ebuild b/net-mail/squirrelmail/squirrelmail-1.2.11.ebuild
new file mode 100644
index 000000000000..9d6d56cfe409
--- /dev/null
+++ b/net-mail/squirrelmail/squirrelmail-1.2.11.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/squirrelmail/squirrelmail-1.2.11.ebuild,v 1.1 2003/02/18 18:26:10 raker Exp $
+
+HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="Webmail for nuts!"
+SRC_URI="mirror://sourceforge/squirrelmail/${P}.tar.bz2"
+HOMEPAGE="http://www.squirrelmail.org/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="x86 ppc sparc"
+
+RDEPEND="virtual/php"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/squirrelmail ] ; then
+ ewarn "You need to unmerge your old SquirrelMail version first."
+ ewarn "SquirrelMail will be installed into ${HTTPD_ROOT}/squirrelmail"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p2 < ${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ #we need to have this empty function ... default compile hangs
+ echo "Nothing to compile"
+}
+
+src_install() {
+ dodir ${HTTPD_ROOT}/squirrelmail
+ cp -r . ${D}/${HTTPD_ROOT}/squirrelmail
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} squirrelmail
+}
+
+pkg_postinst() {
+ einfo "Squirrelmail NO LONGER requires PHP to have "
+ einfo "'register_globals = On' !!!"
+ einfo ""
+ einfo "You will also want to move old SquirrelMail data to"
+ einfo "the new location:"
+ einfo ""
+ einfo "\tmv ${HTTPD_ROOT}/squirrelmail-OLDVERSION/data/* \\"
+ einfo "\t\t${HTTPD_ROOT}/squirrelmail/data"
+ einfo "\tmv ${HTTPD_ROOT}/squirrelmail-OLDVERSION/config/config.php \\"
+ einfo "\t\t${HTTPD_ROOT}/squirrelmail/config"
+}