summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-09-21 19:35:13 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-09-21 19:35:13 +0000
commita373225d0e6370f2b92d93865f5299f7918ab4af (patch)
treee37449bfd28fa56b136ef930a5762d926093ae6b /net-mail/safecat/safecat-1.11.ebuild
parentAdded patch to compile with gcc-2.9x. Closes #29204. (diff)
downloadgentoo-2-a373225d0e6370f2b92d93865f5299f7918ab4af.tar.gz
gentoo-2-a373225d0e6370f2b92d93865f5299f7918ab4af.tar.bz2
gentoo-2-a373225d0e6370f2b92d93865f5299f7918ab4af.zip
fix bug #28978 and head -1 mess
Diffstat (limited to 'net-mail/safecat/safecat-1.11.ebuild')
-rw-r--r--net-mail/safecat/safecat-1.11.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-mail/safecat/safecat-1.11.ebuild b/net-mail/safecat/safecat-1.11.ebuild
index 9965fbe6d8fa..82b1299c124e 100644
--- a/net-mail/safecat/safecat-1.11.ebuild
+++ b/net-mail/safecat/safecat-1.11.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.11.ebuild,v 1.2 2003/09/05 09:13:50 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.11.ebuild,v 1.3 2003/09/21 19:35:11 robbat2 Exp $
IUSE=""
+inherit fixheadtails
+
S=${WORKDIR}/${P}
DESCRIPTION="Safecat implements qmail's maildir algorithm, copying standard input safely to a specified directory."
@@ -16,7 +18,7 @@ DEPEND="virtual/glibc
RDEPEND="virtual/glibc"
SLOT="0"
LICENSE="BSD"
-KEYWORDS="~x86 ~ppc ~sparc"
+KEYWORDS="~x86 ~ppc ~sparc ~arm ~alpha ~hppa ~amd64 ~mips"
src_unpack() {
unpack ${P}.tar.gz
@@ -29,10 +31,12 @@ src_unpack() {
echo "${CC} ${CFLAGS}" > conf-cc
echo "${CC} ${LDFLAGS}" > conf-ld
+ ht_fix_file Makefile make-compile.sh
}
src_compile() {
- grep -v man hier.c | grep -v doc > hier.c
+ egrep -v 'man|doc' hier.c > hier.c.new
+ mv hier.c.new hier.c
make it man || die
}