summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-16 12:45:42 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-16 12:45:42 +0000
commit56d9471620489ba430d0f6bf392577148a88f3e0 (patch)
tree9cac9bf4d1375385c7b03f7d3d380408a93d4119 /net-mail/qmail-autoresponder
parenta small webserver ~20k (diff)
downloadgentoo-2-56d9471620489ba430d0f6bf392577148a88f3e0.tar.gz
gentoo-2-56d9471620489ba430d0f6bf392577148a88f3e0.tar.bz2
gentoo-2-56d9471620489ba430d0f6bf392577148a88f3e0.zip
qmail-autoresonder ebuild - will be needed by vmailmgr, works also with the plain qmail install
Diffstat (limited to 'net-mail/qmail-autoresponder')
-rw-r--r--net-mail/qmail-autoresponder/ChangeLog23
-rw-r--r--net-mail/qmail-autoresponder/files/digest-qmail-autoresponder-0.951
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild41
3 files changed, 65 insertions, 0 deletions
diff --git a/net-mail/qmail-autoresponder/ChangeLog b/net-mail/qmail-autoresponder/ChangeLog
new file mode 100644
index 000000000000..c20dcca0463c
--- /dev/null
+++ b/net-mail/qmail-autoresponder/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for net-mail/qmail-autoresponder
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*qmail-autoresponder-0.95 ( Apr 2002)
+
+ 11 Apr 2002; Thilo Bangert <thilo.bangert@gmx.net> ChangeLog:
+
+ qmail RDEPEND cleanup & a speling eror
+
+
+*qmail-autoresponder-0.95 (25 Mar 2002)
+
+ 25 Mar 2002; Gontran <gontran@gontran.net> ChangeLog:
+
+ added qmail RDEPEND - Notice on how to use qmail-autoresponder at the end
+
+
+*qmail-autoresponder-0.95 (13 Mar 2002)
+
+ 13 Mar 2002; Thilo Bangert <thilo.bangert@gmx.net> ChangeLog:
+
+ initial release
diff --git a/net-mail/qmail-autoresponder/files/digest-qmail-autoresponder-0.95 b/net-mail/qmail-autoresponder/files/digest-qmail-autoresponder-0.95
new file mode 100644
index 000000000000..f228ba921cf2
--- /dev/null
+++ b/net-mail/qmail-autoresponder/files/digest-qmail-autoresponder-0.95
@@ -0,0 +1 @@
+MD5 78ae710f7607fc5712e6ba38742fff04 qmail-autoresponder-0.95.tar.gz 17386
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild
new file mode 100644
index 000000000000..d2a9578c9f50
--- /dev/null
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+
+DEPEND="virtual/glibc"
+RDEPEND=">=net-mail/qmail-1.03-r7"
+
+DESCRIPTION="Rate-limited autoresponder for qmail."
+SRC_URI="http://untroubled.org/qmail-autoresponder/${P}.tar.gz"
+
+HOMEPAGE="http://untroubled.org/qmail-autoresponder/"
+
+src_compile() {
+ cd ${S}
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ emake || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe qmail-autoresponder
+ doman qmail-autoresponder.1
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "Using qmail-autoresponder ..."
+ echo
+ einfo "Put \"|qmail-autoresponder MESSAGE_FILE DIRECTORY\" into your \".qmail\""
+ einfo "file before other delivery instructions. MESSAGE_FILE is a"
+ einfo "pre-formatted response, including headers, and DIRECTORY is the"
+ einfo "directory into which rate-limiting information will be stored. Any"
+ einfo "instance of "%S" in MESSAGE_FILE will be replaced with the original"
+ einfo "subject."
+ echo
+}