summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-06 14:49:06 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-06 14:49:06 +0000
commit18cbb3bc94ed9d501e6f6b0a4530db91f8dc5d57 (patch)
tree1e98fabb8ae86bcf56db838d11e4bb106380468a /net-mail/postfix
parentUpdate (diff)
downloadgentoo-2-18cbb3bc94ed9d501e6f6b0a4530db91f8dc5d57.tar.gz
gentoo-2-18cbb3bc94ed9d501e6f6b0a4530db91f8dc5d57.tar.bz2
gentoo-2-18cbb3bc94ed9d501e6f6b0a4530db91f8dc5d57.zip
Removed typo 2001022999999999 is 20010228
Update with FHS2.1 libexec->lib fix
Diffstat (limited to 'net-mail/postfix')
-rw-r--r--net-mail/postfix/files/digest-postfix-20010228.21
-rw-r--r--net-mail/postfix/files/digest-postfix-20010229.11
-rw-r--r--net-mail/postfix/postfix-20010228.1.ebuild (renamed from net-mail/postfix/postfix-20010229.1.ebuild)2
-rw-r--r--net-mail/postfix/postfix-20010228.2.ebuild144
4 files changed, 146 insertions, 2 deletions
diff --git a/net-mail/postfix/files/digest-postfix-20010228.2 b/net-mail/postfix/files/digest-postfix-20010228.2
new file mode 100644
index 000000000000..d3db8e911e45
--- /dev/null
+++ b/net-mail/postfix/files/digest-postfix-20010228.2
@@ -0,0 +1 @@
+MD5 9a0730bf0c95922c82157465dda718c4 postfix-20010228-pl02.tar.gz
diff --git a/net-mail/postfix/files/digest-postfix-20010229.1 b/net-mail/postfix/files/digest-postfix-20010229.1
deleted file mode 100644
index 6e153e36d8d9..000000000000
--- a/net-mail/postfix/files/digest-postfix-20010229.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e05f316a87f568a6416f48a9241e73ae postfix-20010228-pl01.tar.gz
diff --git a/net-mail/postfix/postfix-20010229.1.ebuild b/net-mail/postfix/postfix-20010228.1.ebuild
index 321fa6ba50af..d19b24fff5f2 100644
--- a/net-mail/postfix/postfix-20010229.1.ebuild
+++ b/net-mail/postfix/postfix-20010228.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-20010229.1.ebuild,v 1.1 2001/04/29 21:51:11 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-20010228.1.ebuild,v 1.1 2001/05/06 14:49:06 achim Exp $
P=${PN}-20010228-pl01
A=${P}.tar.gz
diff --git a/net-mail/postfix/postfix-20010228.2.ebuild b/net-mail/postfix/postfix-20010228.2.ebuild
new file mode 100644
index 000000000000..4faaf4f85d6a
--- /dev/null
+++ b/net-mail/postfix/postfix-20010228.2.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-20010228.2.ebuild,v 1.1 2001/05/06 14:49:06 achim Exp $
+
+P=${PN}-20010228-pl02
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A fast and secure drop-in replacement for sendmail"
+SRC_URI="ftp://ftp.porcupine.org/mirrors/postfix-release/official/${A}"
+HOMEPAGE="http://www.postfix.org/"
+
+DEPEND=">=net-mail/mailbase-0.00
+ >=dev-libs/libpcre-3.4
+ >=sys-libs/glibc-2.1.3"
+
+RDEPEND="!virtual/mta"
+
+TLS_DEP=">=dev-libs/openssl-0.9.6"
+LDAP_DEP=">=net-nds/openldap-2.0.7"
+MYSQL_DEP=">=dev-db/mysql-3.23.28"
+
+#TLS_URI=
+
+#if [ -n "`use mta-tls`" ]; then
+# DEPEND="${DEPEND} ${TLS_DEP}"
+# echo $DEPEND
+#fi
+
+if [ -n "`use mta-ldap`" ]; then
+ DEPEND="${DEPEND} ${LDAP_DEP}"
+ echo $DEPEND
+fi
+
+if [ -n "`use mta-mysql`" ]; then
+ DEPEND="${DEPEND} ${MYSQL_DEP}"
+ echo $DEPEND
+fi
+
+PROVIDE="virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/conf
+ cp main.cf main.cf.orig
+ sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" \
+ main.cf.orig > main.cf
+ cd ${S}/src/global
+ cp mail_params.h mail_params.h.orig
+ sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" \
+ mail_params.h.orig > mail_params.h
+ cd ${S}
+ CCARGS="-I/usr/include -DHAS_PCRE"
+ AUXLIBS="-L/usr/lib -lpcre"
+
+# if [ -n "`use mta-tls`" ]; then
+# CCARGS="${CCARGS} -DUSE_SASL_AUTH"
+# AUXLIBS="${AUXLIBS} -lsasl"
+# fi
+
+ if [ -n "`use mta-ldap`" ]; then
+ CCARGS="${CCARGS} -DHAS_LDAP"
+ AUXLIBS="${AUXLIBS} -lldap -lbre"
+ fi
+
+ if [ -n "`use mta-mysql`" ]; then
+ CCARGS="${CCARGS} -DHAS_MYSQL"
+ AUXLIBS="${AUXLIBS} -lmysqlclient -lm"
+ fi
+
+ make makefiles CC="cc ${CFLAGS} ${CCARGS} ${AUXLIBS}"
+}
+
+src_compile() {
+ cd ${S}
+ try make
+}
+
+src_install () {
+ cd ${S}/bin
+ insopts -o root -g root -m 0755
+ insinto /usr/sbin
+ doins post* sendmail
+
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosym /usr/sbin/sendmail /usr/bin/mail
+ dosym /usr/sbin/sendmail /usr/bin/mailq
+ dosym /usr/sbin/sendmail /usr/bin/newaliases
+ dosym /usr/sbin/sendmail /usr/lib/sendmail
+
+ cd ${S}/libexec
+ dodir /usr/lib/postfix
+ insopts -o root -g root -m 0755
+ insinto /usr/lib/postfix
+ doins *
+
+ cd ${S}
+ dodir /etc/postfix
+ insopts -o root -g root -m 0644
+ insinto /etc/postfix
+ doins ${FILESDIR}/main.cf
+ doins ${FILESDIR}/master.cf
+
+ cd ${S}/conf
+ dodir /etc/postfix/sample
+ insopts -o root -g root -m 0644
+ insinto /etc/postfix/sample
+ doins *.cf access aliases canonical relocated transport \
+ pcre_table regexp_table postfix-script*
+
+ insopts -o root -g root -m 0755
+ insinto /etc/postfix
+ donewins postfix-script-sgid postfix-script
+
+ cd ${S}/man
+ for i in man*
+ do
+ doman $i/*
+ done
+
+ cd ${S}
+ dodoc *README COMPATIBILITY HISTORY LICENSE PORTING \
+ RELEASE_NOTES RESTRICTION_CLASS TODO
+
+ cd ${S}/html
+ docinto html
+ dodoc *
+
+ dodir /var/spool/postfix
+ fperms 0755 /var/spool/postfix
+ fowners root.root /var/spool/postfix
+
+ dodir /var/spool/postfix/maildrop
+ fperms 1733 /var/spool/postfix/maildrop
+ fowners postfix.root /var/spool/postfix/maildrop
+
+ insopts -o root -g root -m 0755
+ insinto /etc/rc.d/init.d
+ doins ${FILESDIR}/postfix
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/rc-update add postfix
+}