summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-28 12:32:43 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-28 12:32:43 +0000
commit8703b03b70842a847843d8f5a776573462580955 (patch)
tree180cdff0885b139b6df28807d05378e2d771d075 /net-mail/pine
parentnew revisions to fix bug #7179. masked for now. (diff)
downloadgentoo-2-8703b03b70842a847843d8f5a776573462580955.tar.gz
gentoo-2-8703b03b70842a847843d8f5a776573462580955.tar.bz2
gentoo-2-8703b03b70842a847843d8f5a776573462580955.zip
More chappa patches for pine-4.53
Diffstat (limited to 'net-mail/pine')
-rw-r--r--net-mail/pine/ChangeLog9
-rw-r--r--net-mail/pine/files/digest-pine-4.53-r11
-rw-r--r--net-mail/pine/pine-4.53-r1.ebuild120
3 files changed, 129 insertions, 1 deletions
diff --git a/net-mail/pine/ChangeLog b/net-mail/pine/ChangeLog
index d5368f6ad107..6640373b6f78 100644
--- a/net-mail/pine/ChangeLog
+++ b/net-mail/pine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/pine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.21 2003/01/18 00:35:04 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.22 2003/01/28 12:32:42 raker Exp $
+
+*pine-4.53-r1 (28 Jan 2003)
+
+ 28 Jan 2003; Nick Hadaway <raker@gentoo.org> pine-4.53-r1.ebuild,
+ files/digest-pine-4.53-r1 :
+ Chappa updated the patches upstream. Release -r1 to account for the
+ changes. New digest file, ebuild is still the same.
*pine-4.53 (17 Jan 2003)
diff --git a/net-mail/pine/files/digest-pine-4.53-r1 b/net-mail/pine/files/digest-pine-4.53-r1
new file mode 100644
index 000000000000..05c1e68cda3a
--- /dev/null
+++ b/net-mail/pine/files/digest-pine-4.53-r1
@@ -0,0 +1 @@
+MD5 e7d0f2ae3766bd9a7a9733547346b637 pine4.53.tar.gz 3924153
diff --git a/net-mail/pine/pine-4.53-r1.ebuild b/net-mail/pine/pine-4.53-r1.ebuild
new file mode 100644
index 000000000000..4db36e4e2f26
--- /dev/null
+++ b/net-mail/pine/pine-4.53-r1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.53-r1.ebuild,v 1.1 2003/01/28 12:32:43 raker Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+SRC_URI="http://www.math.washington.edu/~chappa/pine/patches/${PN}${PV}/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.washington.edu/pine/
+ http://www.math.washington.edu/~chappa/pine/patches/"
+
+SLOT="0"
+LICENSE="PICO"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="ssl ldap"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ net-www/lynx
+ !net-mail/pine-maildir"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/pine-4.21-fixhome.patch
+
+ epatch ${FILESDIR}/imap-4.7c2-flock.patch
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+
+ if [ "`use ldap`" ] ; then
+ # link to shared ldap libs instead of static
+ epatch ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+
+ epatch ${FILESDIR}/pine-4.40-boguswarning.patch
+
+ epatch ${FILESDIR}/pine-4.31-segfix.patch
+
+ epatch ${FILESDIR}/pine-4.40-lockfile-perm.patch
+
+ epatch ${FILESDIR}/imap-2000-time.patch
+
+ epatch ${FILESDIR}/pine-4.33-whitespace.patch
+
+ if [ -n "$DEBUGBUILD" ]; then
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ < makefile.orig > makefile.lnx
+ else
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+ fi
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ cd ${S}/imap/src/osdep/unix
+ cp Makefile Makefile.orig
+ sed \
+ -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
+ -e "s:\$(SSLCERTS):/etc/ssl/certs:" \
+ -e "s:-I\$(SSLINCLUDE) ::" \
+ < Makefile.orig > Makefile
+ cd ${S}
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}