summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-01-05 02:42:31 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-01-05 02:42:31 +0000
commit884a345055187acf5026d794801c569e3f472cea (patch)
tree5dd2d23254e9d81a391e7b62a89f54538a719bd1 /net-mail/perdition
parentkeyworded ~amd64 (bug #176064) (diff)
downloadgentoo-2-884a345055187acf5026d794801c569e3f472cea.tar.gz
gentoo-2-884a345055187acf5026d794801c569e3f472cea.tar.bz2
gentoo-2-884a345055187acf5026d794801c569e3f472cea.zip
Version bump to fix CVE-2007-5740 (security bug #197679). Adding ~amd64 keyword (bug #176064).
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'net-mail/perdition')
-rw-r--r--net-mail/perdition/ChangeLog10
-rw-r--r--net-mail/perdition/files/digest-perdition-1.17.13
-rw-r--r--net-mail/perdition/perdition-1.17.1.ebuild59
3 files changed, 70 insertions, 2 deletions
diff --git a/net-mail/perdition/ChangeLog b/net-mail/perdition/ChangeLog
index bed26d5604b1..73520b5227dc 100644
--- a/net-mail/perdition/ChangeLog
+++ b/net-mail/perdition/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/perdition
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/perdition/ChangeLog,v 1.8 2007/09/02 11:38:18 ferdy Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/perdition/ChangeLog,v 1.9 2008/01/05 02:42:30 rbu Exp $
+
+*perdition-1.17.1 (05 Jan 2008)
+
+ 05 Jan 2008; Robert Buchholz <rbu@gentoo.org> +perdition-1.17.1.ebuild:
+ Version bump to fix CVE-2007-5740 (security bug #197679).
+ Adding ~amd64 keyword (bug #176064).
02 Sep 2007; Fernando J. Pereda <ferdy@gentoo.org> perdition-1.17.ebuild:
Parallel make seems to fail as per bug #134802. Disable it.
diff --git a/net-mail/perdition/files/digest-perdition-1.17.1 b/net-mail/perdition/files/digest-perdition-1.17.1
new file mode 100644
index 000000000000..23b66b279392
--- /dev/null
+++ b/net-mail/perdition/files/digest-perdition-1.17.1
@@ -0,0 +1,3 @@
+MD5 5464c517f8be810519b6187b694c9d98 perdition-1.17.1.tar.gz 638162
+RMD160 2ea351c189b330308a022e97c9dcc8c9bd381377 perdition-1.17.1.tar.gz 638162
+SHA256 e2abd57aa76b106591056ef835e26816c71c3b39dc55bc3aeba6dfeefac7af26 perdition-1.17.1.tar.gz 638162
diff --git a/net-mail/perdition/perdition-1.17.1.ebuild b/net-mail/perdition/perdition-1.17.1.ebuild
new file mode 100644
index 000000000000..f893cd53d857
--- /dev/null
+++ b/net-mail/perdition/perdition-1.17.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/perdition/perdition-1.17.1.ebuild,v 1.1 2008/01/05 02:42:30 rbu Exp $
+
+inherit eutils
+
+DESCRIPTION="modular and fully featured POP3 and IMAP4 proxy"
+HOMEPAGE="http://www.vergenet.net/linux/perdition/"
+SRC_URI="http://www.vergenet.net/linux/${PN}/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls pam ssl mysql odbc postgres gdbm ldap"
+
+DEPEND="!mail-client/mailx
+ !mail-client/nmh
+ dev-scheme/guile
+ >=dev-libs/vanessa-logger-0.0.6
+ >=dev-libs/vanessa-adt-0.0.6
+ >=net-libs/vanessa-socket-0.0.7
+ ssl? ( dev-libs/openssl )
+ odbc? ( dev-db/unixODBC )
+ gdbm? ( sys-libs/gdbm )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ ldap? ( net-nds/openldap )
+ pam? ( sys-libs/pam )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf --disable-sendmail \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_enable ssl) \
+ $(use_enable mysql) \
+ $(use_enable odbc) \
+ $(use_enable postgres) \
+ $(use_enable gdbm) \
+ $(use_enable ldap) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ dodoc README AUTHORS TODO
+
+ newinitd "${FILESDIR}"/perdition.initd perdition
+ newconfd "${FILESDIR}"/perdition.confd perdition
+
+ keepdir /var/run/perdition
+}
+
+pkg_preinst() {
+ enewuser perdition
+ chown perdition "${D}"/var/run/perdition
+}