summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-11-25 10:38:06 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-11-25 10:38:06 +0000
commit9116c7cece2ee77c1f6047501e046ec536489d73 (patch)
treea84e53599b0c9c241897cd6f16563999a501bf1e /net-mail/notmuch
parentFixed compilation with dev-lang/yasm-1.2.0 (bug #391189) (diff)
downloadgentoo-2-9116c7cece2ee77c1f6047501e046ec536489d73.tar.gz
gentoo-2-9116c7cece2ee77c1f6047501e046ec536489d73.tar.bz2
gentoo-2-9116c7cece2ee77c1f6047501e046ec536489d73.zip
net-mail/notmuch-0.10: Fixed out of tree build of test-suites.
Corrected postinst message, btw. (Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/ChangeLog6
-rw-r--r--net-mail/notmuch/files/0.10-fix-test-build.patch104
-rw-r--r--net-mail/notmuch/notmuch-0.10.ebuild5
3 files changed, 112 insertions, 3 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index 6c99604c6854..5b5c4c911a3c 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.14 2011/11/24 18:07:59 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.15 2011/11/25 10:38:06 aidecoe Exp $
+
+ 25 Nov 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +files/0.10-fix-test-build.patch, notmuch-0.10.ebuild:
+ Fixed out of tree build of test-suites. Corrected postinst message, btw.
*notmuch-0.10 (24 Nov 2011)
diff --git a/net-mail/notmuch/files/0.10-fix-test-build.patch b/net-mail/notmuch/files/0.10-fix-test-build.patch
new file mode 100644
index 000000000000..7b326fb85c61
--- /dev/null
+++ b/net-mail/notmuch/files/0.10-fix-test-build.patch
@@ -0,0 +1,104 @@
+From dc1fae07d2896d9eace61989b7c25d9434ee7f3f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Fri, 25 Nov 2011 10:08:47 +0100
+Subject: [PATCH] Build symbol-test with make instead of hardcoding in
+ symbol-hiding.
+
+If symbol-test is built in symbol-hiding with hardcoded g++ invokation, it's
+not so easy to pass $(srcdir) which is required to find notmuch.h when srcdir
+and builddir are separate directories.
+
+Fixed warnings in symbol-test.cc, btw.
+---
+ test/.gitignore | 1 +
+ test/Makefile.local | 5 ++++-
+ test/basic | 2 +-
+ test/symbol-hiding | 3 +--
+ test/symbol-test.cc | 9 ++++-----
+ 5 files changed, 11 insertions(+), 9 deletions(-)
+
+diff --git a/test/.gitignore b/test/.gitignore
+index 9e97052..7e30e8d 100644
+--- a/test/.gitignore
++++ b/test/.gitignore
+@@ -1,4 +1,5 @@
+ test-results
+ corpus.mail
+ smtp-dummy
++symbol-test
+ tmp.*
+diff --git a/test/Makefile.local b/test/Makefile.local
+index 8eb0433..a672fd3 100644
+--- a/test/Makefile.local
++++ b/test/Makefile.local
+@@ -11,8 +11,11 @@ smtp_dummy_modules = $(smtp_dummy_srcs:.c=.o)
+ $(dir)/smtp-dummy: $(smtp_dummy_modules)
+ $(call quiet,CC) $^ -o $@
+
++$(dir)/symbol-test: $(dir)/symbol-test.o
++ $(call quiet,CC) $^ -o $@ -Llib -lnotmuch -lxapian
++
+ .PHONY: test check
+-test: all $(dir)/smtp-dummy
++test: all $(dir)/smtp-dummy $(dir)/symbol-test
+ @${dir}/notmuch-test $(OPTIONS)
+
+ check: test
+diff --git a/test/basic b/test/basic
+index 38db2ba..5463bf8 100755
+--- a/test/basic
++++ b/test/basic
+@@ -56,7 +56,7 @@ tests_in_suite=$(for i in $TESTS; do echo $i; done | sort)
+ available=$(ls -1 $TEST_DIRECTORY/ | \
+ sed -r -e "/^(aggregate-results.sh|Makefile|Makefile.local|notmuch-test)/d" \
+ -e "/^(README|test-lib.sh|test-lib.el|test-results|tmp.*|valgrind|corpus*)/d" \
+- -e "/^(emacs.expected-output|smtp-dummy|smtp-dummy.c|test-verbose|symbol-test.cc)/d" \
++ -e "/^(emacs.expected-output|smtp-dummy|smtp-dummy.c|test-verbose|symbol-test.cc|symbol-test|symbol-test.o)/d" \
+ -e "/^(test.expected-output|.*~)/d" \
+ -e "/^(gnupg-secret-key.asc)/d" \
+ -e "/^(gnupg-secret-key.NOTE)/d" \
+diff --git a/test/symbol-hiding b/test/symbol-hiding
+index d0b31ae..f67b653 100755
+--- a/test/symbol-hiding
++++ b/test/symbol-hiding
+@@ -12,13 +12,12 @@ test_description='exception symbol hiding'
+ . ./test-lib.sh
+
+ run_test(){
+- result=$(LD_LIBRARY_PATH=$TEST_DIRECTORY/../lib ./symbol-test 2>&1)
++ result=$(LD_LIBRARY_PATH=$TEST_DIRECTORY/../lib $TEST_DIRECTORY/symbol-test 2>&1)
+ }
+
+ output="A Xapian exception occurred opening database: Couldn't stat 'fakedb/.notmuch/xapian'
+ caught No chert database found at path \`./nonexistant'"
+
+-g++ -o symbol-test -I$TEST_DIRECTORY/../lib $TEST_DIRECTORY/symbol-test.cc -L$TEST_DIRECTORY/../lib -lnotmuch -lxapian
+ mkdir -p fakedb/.notmuch
+ test_expect_success 'running test' run_test
+ test_begin_subtest 'checking output'
+diff --git a/test/symbol-test.cc b/test/symbol-test.cc
+index 1de06ea..bfbe38f 100644
+--- a/test/symbol-test.cc
++++ b/test/symbol-test.cc
+@@ -1,14 +1,13 @@
+ #include <stdio.h>
+ #include <xapian.h>
+ #include <notmuch.h>
+-main (int argc, char **argv){
++int main (){
+
+- notmuch_database_t *notmuch
+- = notmuch_database_open ("fakedb",
+- NOTMUCH_DATABASE_MODE_READ_ONLY);
++ //notmuch_database_t *notmuch =
++ notmuch_database_open ("fakedb", NOTMUCH_DATABASE_MODE_READ_ONLY);
+
+ try{
+- (void)new Xapian::WritableDatabase ("./nonexistant", Xapian::DB_OPEN);
++ (void)new Xapian::WritableDatabase ("./nonexistant", Xapian::DB_OPEN);
+ } catch (const Xapian::Error &error) {
+ printf("caught %s\n",error.get_msg().c_str());
+ return 0;
+--
+1.7.8.rc3
+
diff --git a/net-mail/notmuch/notmuch-0.10.ebuild b/net-mail/notmuch/notmuch-0.10.ebuild
index 84f73ac442ae..f1be8c8f5b62 100644
--- a/net-mail/notmuch/notmuch-0.10.ebuild
+++ b/net-mail/notmuch/notmuch-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.10.ebuild,v 1.1 2011/11/24 18:07:59 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.10.ebuild,v 1.2 2011/11/25 10:38:06 aidecoe Exp $
EAPI=4
@@ -44,6 +44,7 @@ RDEPEND="${CDEPEND}
zsh-completion? ( app-shells/zsh )
"
+PATCHES=( "${FILESDIR}"/0.10-fix-test-build.patch )
DOCS=( AUTHORS NEWS README TODO )
SITEFILE="50${PN}-gentoo.el"
@@ -143,7 +144,7 @@ pkg_postinst() {
if use python; then
echo
- elog "Python API documentation is also online available at:"
+ elog "Python API documentation is also available online at:"
elog " http://packages.python.org/notmuch/"
fi
}