summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-11-03 13:54:52 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-11-03 13:54:52 +0000
commit8cf29f88cb5c6df3539fd14bd3eb068d48dfd63f (patch)
tree53c3302782ece1e76ec5653b51e6b3736c4c784e /net-mail/notmuch
parentEAPI4, fix kernel >=3.1 detection thanks to Ivan Dorna, drop old, fix #379765. (diff)
downloadgentoo-2-8cf29f88cb5c6df3539fd14bd3eb068d48dfd63f.tar.gz
gentoo-2-8cf29f88cb5c6df3539fd14bd3eb068d48dfd63f.tar.bz2
gentoo-2-8cf29f88cb5c6df3539fd14bd3eb068d48dfd63f.zip
net-mail/notmuch: Added python bindings.
(Portage version: 2.1.10.31/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/ChangeLog8
-rw-r--r--net-mail/notmuch/notmuch-0.9-r1.ebuild105
2 files changed, 112 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index b325efece67b..fe157fdb553e 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.3 2011/11/02 17:46:33 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.4 2011/11/03 13:54:52 aidecoe Exp $
+
+*notmuch-0.9-r1 (03 Nov 2011)
+
+ 03 Nov 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +notmuch-0.9-r1.ebuild:
+ Added python bindings.
02 Nov 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
files/0.9-emacsetcdir.patch, files/0.9-fix-lib-makefile-local.patch,
diff --git a/net-mail/notmuch/notmuch-0.9-r1.ebuild b/net-mail/notmuch/notmuch-0.9-r1.ebuild
new file mode 100644
index 000000000000..57ab90da7ca0
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.9-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.9-r1.ebuild,v 1.1 2011/11/03 13:54:52 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit elisp-common distutils
+inherit autotools-utils
+
+DESCRIPTION="The mail indexer"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion debug emacs python vim zsh-completion"
+
+DEPEND="
+ >=dev-libs/glib-2.14
+ dev-libs/gmime:2.4
+ dev-libs/xapian
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ vim? ( || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 ) )
+ "
+RDEPEND="${DEPEND}
+ zsh-completion? ( app-shells/zsh )
+ "
+
+DOCS=( AUTHORS NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}/${PV}-fix-lib-makefile-local.patch"
+ "${FILESDIR}/${PV}-emacsetcdir.patch"
+ )
+SITEFILE="50${PN}-gentoo.el"
+
+py_bindings() {
+ if use python; then
+ pushd bindings/python || die
+ $@
+ popd || die
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+ py_bindings distutils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${ROOT}/usr/share/bash-completion"
+ --emacslispdir="${ROOT}/${SITELISP}/${PN}"
+ --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
+ --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
+ $(use_with bash-completion)
+ $(use_with emacs)
+ $(use_with zsh-completion)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ py_bindings distutils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/plugin vim/syntax
+ fi
+
+ DOCS="" py_bindings distutils_src_install
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postrm
+}