summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCalum Selkirk <cselkirk@gentoo.org>2002-09-03 16:46:02 +0000
committerCalum Selkirk <cselkirk@gentoo.org>2002-09-03 16:46:02 +0000
commit72540d705f9fe321ca424849c7da29b883df080e (patch)
treed63b129b3c3cff979e0d109b50ca8ecbbc89ef0e /net-mail/mutt
parentremoved DEPEND="<sys-devel/gcc-3", updated ChangeLog (diff)
downloadgentoo-2-72540d705f9fe321ca424849c7da29b883df080e.tar.gz
gentoo-2-72540d705f9fe321ca424849c7da29b883df080e.tar.bz2
gentoo-2-72540d705f9fe321ca424849c7da29b883df080e.zip
Added the compressed folder patch. This closes bug #7398
Diffstat (limited to 'net-mail/mutt')
-rw-r--r--net-mail/mutt/ChangeLog7
-rw-r--r--net-mail/mutt/files/digest-mutt-1.4-r32
-rw-r--r--net-mail/mutt/mutt-1.4-r3.ebuild74
3 files changed, 82 insertions, 1 deletions
diff --git a/net-mail/mutt/ChangeLog b/net-mail/mutt/ChangeLog
index 6321d541ec51..d233c057d737 100644
--- a/net-mail/mutt/ChangeLog
+++ b/net-mail/mutt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mutt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.8 2002/07/28 14:45:48 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.9 2002/09/03 16:46:02 cselkirk Exp $
+
+*mutt-1.4-r3 (03 Sept 2002) Calum Selkirk <cselkirk@gentoo.org>
+ mutt-1.4-r3.ebuild files/digest-mutt-1.4-r3 :
+
+ Added the compressed folder patch. This closes bug #7398
*mutt-1.4-r2 (28 Jul 2002)
diff --git a/net-mail/mutt/files/digest-mutt-1.4-r3 b/net-mail/mutt/files/digest-mutt-1.4-r3
new file mode 100644
index 000000000000..1e939d76b360
--- /dev/null
+++ b/net-mail/mutt/files/digest-mutt-1.4-r3
@@ -0,0 +1,2 @@
+MD5 a67bcdf1a1cd53d61ccd3ebf3993ba59 mutt-1.4i.tar.gz 2554158
+MD5 57b241046d0c0bbfe6a4fe7e3ba5f0ec patch-1.4.rr.compressed.1.gz 14133
diff --git a/net-mail/mutt/mutt-1.4-r3.ebuild b/net-mail/mutt/mutt-1.4-r3.ebuild
new file mode 100644
index 000000000000..41e6168218f0
--- /dev/null
+++ b/net-mail/mutt/mutt-1.4-r3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.4-r3.ebuild,v 1.1 2002/09/03 16:46:02 cselkirk Exp $
+
+S=$WORKDIR/${P}
+DESCRIPTION="a small but very powerful text-based mail client"
+SRC_URI="ftp://ftp.mutt.org/pub/mutt/mutt-${PV}i.tar.gz
+ http://www.spinnaker.de/mutt/compressed/patch-${PV}.rr.compressed.1.gz
+ cjk?( http://www.emaillab.org/mutt/1.4/mutt-${PV}i-ja.1.tar.gz )"
+HOMEPAGE="http://www.mutt.org"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ slang? ( >=sys-libs/slang-1.4.2 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc64"
+
+src_unpack() {
+ unpack ${P}i.tar.gz
+ if [ "`use cjk`" ]; then
+ unpack ${P}i-ja.1.tar.gz
+ cd ${S}
+ patch -p1 < ../mutt-1.4i-ja.1/patch-1.4.tt.ja.1 || die
+ fi
+ zcat ${DISTDIR}/patch-${PV}.rr.compressed.1.gz | patch -d ${S} -p1 ||
+ die
+}
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ # --without-slang doesn't work;
+ # specify --with-curses if you don't want slang
+ # (26 Sep 2001 agriffis)
+
+ use slang \
+ && myconf="${myconf} --with-slang" \
+ || myconf="${myconf} --with-curses"
+
+ use cjk && myconf="$myconf --enable-default-japanese"
+
+ econf \
+ --sysconfdir=/etc/mutt \
+ --with-docdir=/usr/share/doc/mutt-$PVR \
+ --with-regex --enable-pop --enable-imap --enable-nfs-fix \
+ --disable-fcntl --enable-flock --enable-external-dotlock \
+ --with-homespool=Maildir \
+ --enable-compressed \
+ ${myconf} || die
+
+ cp doc/Makefile doc/Makefile.orig
+ sed 's/README.UPGRADE//' doc/Makefile.orig > doc/Makefile
+ make || die "make failed (myconf=${myconf})"
+}
+
+src_install () {
+ make DESTDIR=$D install || die
+ find $D/usr/share/doc -type f |grep -v html | xargs gzip
+ insinto /etc/mutt
+ doins $FILESDIR/Muttrc
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}