summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-11-21 12:18:55 +0000
committerEray Aslan <eras@gentoo.org>2011-11-21 12:18:55 +0000
commitf3d92fc1cc21e075b4085b09be7bbb1f5864bd5f (patch)
tree48297bf75efba7fa96081cf5853f8add64dacd50 /net-mail/mu
parentUse java-vm-2.eclass to set PaX markings (diff)
downloadgentoo-2-f3d92fc1cc21e075b4085b09be7bbb1f5864bd5f.tar.gz
gentoo-2-f3d92fc1cc21e075b4085b09be7bbb1f5864bd5f.tar.bz2
gentoo-2-f3d92fc1cc21e075b4085b09be7bbb1f5864bd5f.zip
version bump
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/ChangeLog7
-rw-r--r--net-mail/mu/mu-0.9.7.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-mail/mu/ChangeLog b/net-mail/mu/ChangeLog
index 8806ff153860..803a5bf32317 100644
--- a/net-mail/mu/ChangeLog
+++ b/net-mail/mu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/ChangeLog,v 1.7 2011/07/07 17:04:47 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/ChangeLog,v 1.8 2011/11/21 12:18:55 eras Exp $
+
+*mu-0.9.7 (21 Nov 2011)
+
+ 21 Nov 2011; Eray Aslan <eras@gentoo.org> +mu-0.9.7.ebuild:
+ version bump
07 Jul 2011; Thomas Kahle <tomka@gentoo.org> mu-0.9.6.ebuild:
x86 stable per bug 373623
diff --git a/net-mail/mu/mu-0.9.7.ebuild b/net-mail/mu/mu-0.9.7.ebuild
new file mode 100644
index 000000000000..19c2ee1bdd6f
--- /dev/null
+++ b/net-mail/mu/mu-0.9.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/mu-0.9.7.ebuild,v 1.1 2011/11/21 12:18:55 eras Exp $
+
+EAPI=3
+
+inherit base
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
+SRC_URI="http://mu0.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+DEPEND=">=dev-libs/gmime-2.4:2.4
+ dev-libs/xapian
+ >=dev-libs/glib-2.22:2
+ gui? ( x11-libs/gtk+:2
+ net-libs/webkit-gtk:2 ) "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local guiconf
+ if use gui; then
+ guiconf="--with-gui=gtk2"
+ else
+ guiconf="--with-gui=none"
+ fi
+
+ econf "${guiconf}"
+}
+
+src_install () {
+ base_src_install
+ # Installing the guis is not supported by upstream
+ if use gui; then
+ dobin toys/mug/mug || die
+ dobin toys/mug2/mug2 || die
+ fi
+ dodoc AUTHORS HACKING NEWS TODO README ChangeLog INSTALL
+}