summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-04-02 14:14:27 +0000
committerThomas Kahle <tomka@gentoo.org>2013-04-02 14:14:27 +0000
commit031c5ee9cf433930f5b60b52d575d23737887d03 (patch)
tree5777b42af39cd197b30f9fbb89853b52458700be /net-mail/mu
parentFix "@GTK_SPELL_CFLAGS@: No such file or directory" build failure (bug #46367... (diff)
downloadgentoo-2-031c5ee9cf433930f5b60b52d575d23737887d03.tar.gz
gentoo-2-031c5ee9cf433930f5b60b52d575d23737887d03.tar.bz2
gentoo-2-031c5ee9cf433930f5b60b52d575d23737887d03.zip
bump
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/ChangeLog9
-rw-r--r--net-mail/mu/mu-0.9.9.5.ebuild86
2 files changed, 93 insertions, 2 deletions
diff --git a/net-mail/mu/ChangeLog b/net-mail/mu/ChangeLog
index de7cb2d4f6d4..bd48283a52f0 100644
--- a/net-mail/mu/ChangeLog
+++ b/net-mail/mu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mu
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/ChangeLog,v 1.18 2012/12/06 04:37:52 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/ChangeLog,v 1.19 2013/04/02 14:14:27 tomka Exp $
+
+*mu-0.9.9.5 (02 Apr 2013)
+
+ 02 Apr 2013; Thomas Kahle <tomka@gentoo.org> +mu-0.9.9.5.ebuild:
+ bump
06 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> mu-0.9.9.ebuild:
x86 stable wrt bug #445692
diff --git a/net-mail/mu/mu-0.9.9.5.ebuild b/net-mail/mu/mu-0.9.9.5.ebuild
new file mode 100644
index 000000000000..7007d7c757ac
--- /dev/null
+++ b/net-mail/mu/mu-0.9.9.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/mu-0.9.9.5.ebuild,v 1.1 2013/04/02 14:14:27 tomka Exp $
+
+EAPI=4
+
+inherit base elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
+SRC_URI="http://mu0.googlecode.com/files/${P}.tar.gz
+ doc? ( http://mu0.googlecode.com/files/mu4e-manual-${PV}.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs gui"
+
+# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
+# really wants both installed at the same time.
+DEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/xapian
+ dev-libs/glib:2
+ gui? (
+ x11-libs/gtk+:3
+ net-libs/webkit-gtk:3 )
+ emacs? ( >=virtual/emacs-23 )
+ !net-mail/mailutils"
+RDEPEND="${DEPEND}"
+
+SITEFILE="70mu-gentoo.el"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc ; then
+ cp "${DISTDIR}"/mu4e-manual-${PV}.pdf "${S}" || die
+ fi
+}
+
+src_configure() {
+ # Todo: Make a guile USE-flag as soon as >=guile-2 is avaiable
+ # Note: --disable-silent-rules is included in EAPI-5
+ econf --disable-guile \
+ --disable-silent-rules \
+ $(use_enable gui webkit) \
+ $(use_enable gui gtk) \
+ $(use_enable emacs mu4e)
+}
+
+src_install () {
+ base_src_install
+ # Installing the guis is not supported by upstream
+ if use gui; then
+ dobin toys/mug/mug || die
+ fi
+ dodoc AUTHORS HACKING NEWS TODO README ChangeLog INSTALL
+ if use doc; then
+ dodoc mu4e-manual-${PV}.pdf
+ fi
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+src_test () {
+ emake check
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "http://www.djcbsoftware.nl/code/mu/mu4e/Getting-started.html"
+ fi
+
+ elog "If you upgrade from an older major version,"
+ elog "then you need to rebuild your mail index."
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}