summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-11-02 22:06:36 +0000
committerThomas Kahle <tomka@gentoo.org>2012-11-02 22:06:36 +0000
commit191d8068f33085b3a8cb6259bbd8bf01d8a9a6d2 (patch)
tree2312e1f18a0547205ae4f02b122b3d21518da313 /net-mail/mu/mu-0.9.9.ebuild
parentCall distutils-r1_python_prepare_all from python_prepare_all. (diff)
downloadgentoo-2-191d8068f33085b3a8cb6259bbd8bf01d8a9a6d2.tar.gz
gentoo-2-191d8068f33085b3a8cb6259bbd8bf01d8a9a6d2.tar.bz2
gentoo-2-191d8068f33085b3a8cb6259bbd8bf01d8a9a6d2.zip
Bump to 0.9.9, install pdf manual, fix gmime dep (439842), remove old
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC)
Diffstat (limited to 'net-mail/mu/mu-0.9.9.ebuild')
-rw-r--r--net-mail/mu/mu-0.9.9.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/net-mail/mu/mu-0.9.9.ebuild b/net-mail/mu/mu-0.9.9.ebuild
new file mode 100644
index 000000000000..2f070c325812
--- /dev/null
+++ b/net-mail/mu/mu-0.9.9.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mu/mu-0.9.9.ebuild,v 1.1 2012/11/02 22:06:36 tomka Exp $
+
+EAPI=4
+
+inherit base elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
+SRC_URI="http://mu0.googlecode.com/files/${P}.tar.gz
+ doc? ( http://mu0.googlecode.com/files/mu4e-manual-${PV}.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs gui"
+
+# Without webkit-gtk there is no pdf-preview functionality, everthing
+# else works as of 0.9.8.5
+DEPEND="
+ dev-libs/gmime
+ dev-libs/xapian
+ dev-libs/glib:2
+ gui? (
+ x11-libs/gtk+:3
+ net-libs/webkit-gtk:3 )
+ emacs? ( >=virtual/emacs-23 )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="70mu-gentoo.el"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ use doc && cp "${DISTDIR}"/mu4e-manual-${PV}.pdf "${S}" || die
+}
+
+src_configure() {
+ local guiconf
+ if use gui; then
+ guiconf="--with-gui=gtk3"
+ else
+ guiconf="--with-gui=none"
+ fi
+
+ # Make a guile USE-flag as soon as >=guile-2 is avaiable
+ econf --disable-guile \
+ $(use_enable gui webkit) \
+ $(use_enable emacs mu4e) \
+ ${guiconf}
+}
+
+src_install () {
+ base_src_install
+ # Installing the guis is not supported by upstream
+ if use gui; then
+ dobin toys/mug/mug || die
+ fi
+ dodoc AUTHORS HACKING NEWS TODO README ChangeLog INSTALL
+ if use doc; then
+ dodoc mu4e-manual-${PV}.pdf
+ fi
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+src_test () {
+ emake check
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "http://www.djcbsoftware.nl/code/mu/mu4e/Getting-started.html"
+ fi
+
+ elog "If you upgrade from an older major version,"
+ elog "then you need to rebuild your mail index."
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}