summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-06-06 14:39:21 +0000
committerEray Aslan <eras@gentoo.org>2011-06-06 14:39:21 +0000
commitcb2d38a99ecf475ad9ca7a2d9fe7b15d62bc8809 (patch)
treed8a6a155e732f855d9cb37c4185c0598aa8a8034 /net-mail/mess822
parentWarn when using xfconf_use_debug without having debug in IUSE (diff)
downloadgentoo-2-cb2d38a99ecf475ad9ca7a2d9fe7b15d62bc8809.tar.gz
gentoo-2-cb2d38a99ecf475ad9ca7a2d9fe7b15d62bc8809.tar.bz2
gentoo-2-cb2d38a99ecf475ad9ca7a2d9fe7b15d62bc8809.zip
Respect CFLAGS - bug #241056. Respect LDFLAGS - bug #334603. Restrict test - bug #283172.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/mess822')
-rw-r--r--net-mail/mess822/ChangeLog11
-rw-r--r--net-mail/mess822/files/mess822-0.58-implicit.patch66
-rw-r--r--net-mail/mess822/mess822-0.58-r2.ebuild51
3 files changed, 126 insertions, 2 deletions
diff --git a/net-mail/mess822/ChangeLog b/net-mail/mess822/ChangeLog
index 33e6bcf1d214..0f907fa3999f 100644
--- a/net-mail/mess822/ChangeLog
+++ b/net-mail/mess822/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/mess822
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mess822/ChangeLog,v 1.11 2009/09/23 19:08:27 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mess822/ChangeLog,v 1.12 2011/06/06 14:39:21 eras Exp $
+
+*mess822-0.58-r2 (06 Jun 2011)
+
+ 06 Jun 2011; Eray Aslan <eras@gentoo.org> +mess822-0.58-r2.ebuild,
+ +files/mess822-0.58-implicit.patch:
+ Respect CFLAGS - bug #241056. Respect LDFLAGS - bug #334603. Restrict test -
+ bug #283172
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> mess822-0.58-r1.ebuild:
Remove virtual/libc
diff --git a/net-mail/mess822/files/mess822-0.58-implicit.patch b/net-mail/mess822/files/mess822-0.58-implicit.patch
new file mode 100644
index 000000000000..586a59bbb188
--- /dev/null
+++ b/net-mail/mess822/files/mess822-0.58-implicit.patch
@@ -0,0 +1,66 @@
+commit 43f63356fec31e46dfc5ab4574bb62cd75b35dfe
+Author: Eray Aslan <eras@gentoo.org>
+Date: Mon Jun 6 17:19:48 2011 +0300
+
+ Fix missing includes
+
+diff --git a/addrlist.c b/addrlist.c
+index fe196c8..a2ae631 100644
+--- a/addrlist.c
++++ b/addrlist.c
+@@ -3,6 +3,7 @@
+ #include "subfd.h"
+ #include "getln.h"
+ #include "mess822.h"
++#include "exit.h"
+
+ #define FATAL "addrlist: fatal: "
+
+diff --git a/leapsecs_read.c b/leapsecs_read.c
+index 62c8712..ff2ec23 100644
+--- a/leapsecs_read.c
++++ b/leapsecs_read.c
+@@ -1,6 +1,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <stdlib.h>
+ #include <errno.h>
+ extern int errno;
+ #include "tai.h"
+diff --git a/parsedate.c b/parsedate.c
+index 06f1d57..e90e198 100644
+--- a/parsedate.c
++++ b/parsedate.c
+@@ -6,6 +6,7 @@
+ #include "leapsecs.h"
+ #include "caltime.h"
+ #include "tai.h"
++#include "exit.h"
+
+ #define FATAL "parsedate: fatal: "
+
+diff --git a/quote.c b/quote.c
+index 7d21ac0..e8c7aa2 100644
+--- a/quote.c
++++ b/quote.c
+@@ -2,6 +2,7 @@
+ #include "subfd.h"
+ #include "substdio.h"
+ #include "strerr.h"
++#include "exit.h"
+
+ #define FATAL "quote: fatal: "
+
+diff --git a/tokenize.c b/tokenize.c
+index 667987d..840a220 100644
+--- a/tokenize.c
++++ b/tokenize.c
+@@ -3,6 +3,7 @@
+ #include "subfd.h"
+ #include "getln.h"
+ #include "mess822.h"
++#include "exit.h"
+
+ #define FATAL "tokenize: fatal: "
+
diff --git a/net-mail/mess822/mess822-0.58-r2.ebuild b/net-mail/mess822/mess822-0.58-r2.ebuild
new file mode 100644
index 000000000000..4004fa05cc8c
--- /dev/null
+++ b/net-mail/mess822/mess822-0.58-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mess822/mess822-0.58-r2.ebuild,v 1.1 2011/06/06 14:39:21 eras Exp $
+
+EAPI=4
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="Collection of utilities for parsing Internet mail messages."
+SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
+HOMEPAGE="http://cr.yp.to/mess822.html"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+LICENSE="as-is"
+
+RDEPEND=">=sys-apps/sed-4"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+src_prepare() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "/usr" > conf-home
+
+ # fix errno.h problem; bug #26165
+ sed -i 's/^extern int errno;/#include <errno.h>/' error.h
+
+ epatch "${FILESDIR}"/${P}-implicit.patch
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/share
+
+ # Now that the commands are compiled, update the conf-home file to point
+ # to the installation image directory.
+ echo "${D}/usr/" > conf-home
+ sed -i -e "s:\"/etc\":\"${D}/etc\":" hier.c || die "sed hier.c failed"
+
+ emake setup
+
+ # Move the man pages into /usr/share/man
+ mv "${D}/usr/man" "${D}/usr/share/"
+
+ dodir /usr/$(get_libdir)
+ mv "${D}/usr/lib/${PN}.a" "${D}/usr/$(get_libdir)/${PN}.a"
+ rmdir "${D}/usr/lib"
+ dodoc BLURB CHANGES INSTALL README THANKS TODO VERSION
+}