summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-02 22:09:34 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-02 22:09:34 +0000
commit35cb73cea670f4aed60e9f54d5d5f0bfa16158b8 (patch)
tree730335801da3dc321beae8e76021a0035b0f81cf /net-mail/mailman
parentVersion bump. (diff)
downloadgentoo-2-35cb73cea670f4aed60e9f54d5d5f0bfa16158b8.tar.gz
gentoo-2-35cb73cea670f4aed60e9f54d5d5f0bfa16158b8.tar.bz2
gentoo-2-35cb73cea670f4aed60e9f54d5d5f0bfa16158b8.zip
Fold extra -G argument to enewuser into existing <groups> argument to enewuser as enewuser takes care of splitting into -g/-G for us.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/mailman')
-rw-r--r--net-mail/mailman/ChangeLog8
-rw-r--r--net-mail/mailman/mailman-2.1.11.ebuild6
-rw-r--r--net-mail/mailman/mailman-2.1.12.ebuild6
-rw-r--r--net-mail/mailman/mailman-2.1.13.ebuild6
-rw-r--r--net-mail/mailman/mailman-2.1.14.ebuild6
-rw-r--r--net-mail/mailman/mailman-2.1.14_rc1.ebuild6
-rw-r--r--net-mail/mailman/mailman-2.1.9-r3.ebuild6
7 files changed, 25 insertions, 19 deletions
diff --git a/net-mail/mailman/ChangeLog b/net-mail/mailman/ChangeLog
index 321be2e71b45..2ec19fb6232d 100644
--- a/net-mail/mailman/ChangeLog
+++ b/net-mail/mailman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mailman
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/ChangeLog,v 1.128 2011/11/02 21:53:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/ChangeLog,v 1.129 2011/11/02 22:09:34 vapier Exp $
+
+ 02 Nov 2011; Mike Frysinger <vapier@gentoo.org> mailman-2.1.9-r3.ebuild,
+ mailman-2.1.11.ebuild, mailman-2.1.12.ebuild, mailman-2.1.13.ebuild,
+ mailman-2.1.14_rc1.ebuild, mailman-2.1.14.ebuild:
+ Fold extra -G argument to enewuser into existing <groups> argument to
+ enewuser as enewuser takes care of splitting into -g/-G for us.
02 Nov 2011; Mike Frysinger <vapier@gentoo.org> mailman-2.1.9-r3.ebuild,
mailman-2.1.11.ebuild, mailman-2.1.12.ebuild, mailman-2.1.13.ebuild,
diff --git a/net-mail/mailman/mailman-2.1.11.ebuild b/net-mail/mailman/mailman-2.1.11.ebuild
index 257f3a932db9..54acfa6b57de 100644
--- a/net-mail/mailman/mailman-2.1.11.ebuild
+++ b/net-mail/mailman/mailman-2.1.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.11.ebuild,v 1.5 2011/11/02 21:53:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.11.ebuild,v 1.6 2011/11/02 22:09:34 vapier Exp $
inherit eutils python multilib
@@ -32,7 +32,7 @@ pkg_setup() {
# need to add mailman here for compile process.
# Duplicated at pkg_postinst() for binary install.
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman,cron
}
src_unpack() {
@@ -111,7 +111,7 @@ pkg_postinst() {
python_mod_optimize ${INSTALLDIR}/bin/ ${INSTALLDIR}/Mailman
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman,cron
elog
elog "Please read /usr/share/doc/${PF}/README.gentoo.bz2 for additional"
elog "Setup information, mailman will NOT run unless you follow"
diff --git a/net-mail/mailman/mailman-2.1.12.ebuild b/net-mail/mailman/mailman-2.1.12.ebuild
index 597f760f07ab..b2293f9a998a 100644
--- a/net-mail/mailman/mailman-2.1.12.ebuild
+++ b/net-mail/mailman/mailman-2.1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.12.ebuild,v 1.6 2011/11/02 21:53:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.12.ebuild,v 1.7 2011/11/02 22:09:34 vapier Exp $
inherit eutils python multilib
@@ -33,7 +33,7 @@ pkg_setup() {
# need to add mailman here for compile process.
# Duplicated at pkg_postinst() for binary install.
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman,cron
}
src_unpack() {
@@ -114,7 +114,7 @@ pkg_postinst() {
${INSTALLDIR}/pythonlib/*/
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman,cron
elog
elog "Please read /usr/share/doc/${PF}/README.gentoo.bz2 for additional"
elog "Setup information, mailman will NOT run unless you follow"
diff --git a/net-mail/mailman/mailman-2.1.13.ebuild b/net-mail/mailman/mailman-2.1.13.ebuild
index f4e0bea116d3..b62acae87912 100644
--- a/net-mail/mailman/mailman-2.1.13.ebuild
+++ b/net-mail/mailman/mailman-2.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.13.ebuild,v 1.3 2011/11/02 21:53:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.13.ebuild,v 1.4 2011/11/02 22:09:34 vapier Exp $
inherit eutils python multilib
@@ -33,7 +33,7 @@ pkg_setup() {
# need to add mailman here for compile process.
# Duplicated at pkg_postinst() for binary install.
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman,cron
}
src_unpack() {
@@ -114,7 +114,7 @@ pkg_postinst() {
${INSTALLDIR}/pythonlib/*/
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman,cron
elog
elog "Please read /usr/share/doc/${PF}/README.gentoo.bz2 for additional"
elog "Setup information, mailman will NOT run unless you follow"
diff --git a/net-mail/mailman/mailman-2.1.14.ebuild b/net-mail/mailman/mailman-2.1.14.ebuild
index 8dac84a0fd1d..998aa6dd4e54 100644
--- a/net-mail/mailman/mailman-2.1.14.ebuild
+++ b/net-mail/mailman/mailman-2.1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.14.ebuild,v 1.6 2011/11/02 21:53:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.14.ebuild,v 1.7 2011/11/02 22:09:34 vapier Exp $
inherit eutils python multilib
@@ -33,7 +33,7 @@ pkg_setup() {
# need to add mailman here for compile process.
# Duplicated at pkg_postinst() for binary install.
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman,cron
}
src_unpack() {
@@ -114,7 +114,7 @@ pkg_postinst() {
${INSTALLDIR}/Mailman/*/
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman,cron
elog
elog "Please read /usr/share/doc/${PF}/README.gentoo.bz2 for additional"
elog "Setup information, mailman will NOT run unless you follow"
diff --git a/net-mail/mailman/mailman-2.1.14_rc1.ebuild b/net-mail/mailman/mailman-2.1.14_rc1.ebuild
index e92b456d7525..c7463e39e26a 100644
--- a/net-mail/mailman/mailman-2.1.14_rc1.ebuild
+++ b/net-mail/mailman/mailman-2.1.14_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.14_rc1.ebuild,v 1.2 2011/11/02 21:53:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.14_rc1.ebuild,v 1.3 2011/11/02 22:09:34 vapier Exp $
inherit eutils python multilib
@@ -34,7 +34,7 @@ pkg_setup() {
# need to add mailman here for compile process.
# Duplicated at pkg_postinst() for binary install.
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman,cron
}
src_unpack() {
@@ -115,7 +115,7 @@ pkg_postinst() {
${INSTALLDIR}/pythonlib/*/
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman,cron
elog
elog "Please read /usr/share/doc/${PF}/README.gentoo.bz2 for additional"
elog "Setup information, mailman will NOT run unless you follow"
diff --git a/net-mail/mailman/mailman-2.1.9-r3.ebuild b/net-mail/mailman/mailman-2.1.9-r3.ebuild
index 788711309367..ad554e6b4aa2 100644
--- a/net-mail/mailman/mailman-2.1.9-r3.ebuild
+++ b/net-mail/mailman/mailman-2.1.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.9-r3.ebuild,v 1.6 2011/11/02 21:53:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.9-r3.ebuild,v 1.7 2011/11/02 22:09:34 vapier Exp $
inherit eutils python multilib
@@ -31,7 +31,7 @@ pkg_setup() {
# need to add mailman here for compile process.
# Duplicated at pkg_postinst() for binary install.
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} /bin/bash ${INSTALLDIR} mailman,cron
}
src_unpack() {
@@ -108,7 +108,7 @@ pkg_postinst() {
python_mod_optimize ${INSTALLDIR}/bin/ ${INSTALLDIR}/Mailman
enewgroup ${MAILGRP} ${MAILGID}
- enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman -G cron
+ enewuser ${MAILUSR} ${MAILUID} -1 ${INSTALLDIR} mailman,cron
elog
elog "Please read /usr/share/doc/${PF}/README.gentoo.bz2 for additional"
elog "Setup information, mailman will NOT run unless you follow"