summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Bordelon <sunflare@gentoo.org>2002-06-27 22:44:54 +0000
committerPhil Bordelon <sunflare@gentoo.org>2002-06-27 22:44:54 +0000
commit5a18f466d29d8f90d480289b42ee6d6957d15697 (patch)
tree11af7d187c7257eff600ee78df014045cdb1cdc3 /net-mail/mailbase/mailbase-0.00-r4.ebuild
parentpatch for fix #3791 (diff)
downloadgentoo-2-5a18f466d29d8f90d480289b42ee6d6957d15697.tar.gz
gentoo-2-5a18f466d29d8f90d480289b42ee6d6957d15697.tar.bz2
gentoo-2-5a18f466d29d8f90d480289b42ee6d6957d15697.zip
New mailbase to fix a bug I discovered with /var/spool/mail disappearing. See the ChangeLog.
Diffstat (limited to 'net-mail/mailbase/mailbase-0.00-r4.ebuild')
-rw-r--r--net-mail/mailbase/mailbase-0.00-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-mail/mailbase/mailbase-0.00-r4.ebuild b/net-mail/mailbase/mailbase-0.00-r4.ebuild
new file mode 100644
index 000000000000..833025b70ff0
--- /dev/null
+++ b/net-mail/mailbase/mailbase-0.00-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+S=${WORKDIR}
+SLOT="0"
+DESCRIPTION="MTA layout package"
+SRC_URI=""
+HOMEPAGE="http://www.gentoo.org/"
+LICENSE="GPL-2"
+DEPEND=""
+RDEPEND=""
+
+
+src_install() {
+ dodir /etc/mail
+ insinto /etc/mail
+ doins ${FILESDIR}/aliases
+ insinto /etc/
+ doins ${FILESDIR}/mailcap
+
+ dodir /var/spool/mail
+ chown root.mail ${D}/var/spool/mail
+ touch ${D}/var/spool/mail/.keep
+ dosym /var/spool/mail /var/mail
+}
+
+pkg_postinst() {
+ if [ ! -d ${ROOT}/var/spool/mail ]
+ then
+ mkdir -p ${ROOT}/var/spool/mail
+ chown root.mail ${ROOT}/var/spool/mail
+ fi
+}