summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-14 06:33:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-14 06:33:58 +0000
commitc3bc1f77d5daa052947c31c25f8e618568853380 (patch)
treeaf8c34e51cb08849bee552835f1d1edfd9683cc1 /net-mail/libpst
parentBump (diff)
downloadgentoo-2-c3bc1f77d5daa052947c31c25f8e618568853380.tar.gz
gentoo-2-c3bc1f77d5daa052947c31c25f8e618568853380.tar.bz2
gentoo-2-c3bc1f77d5daa052947c31c25f8e618568853380.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-mail/libpst')
-rw-r--r--net-mail/libpst/ChangeLog7
-rw-r--r--net-mail/libpst/libpst-0.6.63.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/net-mail/libpst/ChangeLog b/net-mail/libpst/ChangeLog
index 03f86cda822c..44fe3fb90ecf 100644
--- a/net-mail/libpst/ChangeLog
+++ b/net-mail/libpst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/libpst
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.45 2014/01/12 19:52:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.46 2014/01/14 06:33:58 patrick Exp $
+
+*libpst-0.6.63 (14 Jan 2014)
+
+ 14 Jan 2014; Patrick Lauer <patrick@gentoo.org> +libpst-0.6.63.ebuild:
+ Bump
12 Jan 2014; Pacho Ramos <pacho@gentoo.org> libpst-0.6.61.ebuild:
amd64 stable, bug #495862
diff --git a/net-mail/libpst/libpst-0.6.63.ebuild b/net-mail/libpst/libpst-0.6.63.ebuild
new file mode 100644
index 000000000000..db5babce3bd5
--- /dev/null
+++ b/net-mail/libpst/libpst-0.6.63.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.6.63.ebuild,v 1.1 2014/01/14 06:33:58 patrick Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2"
+
+inherit autotools eutils python
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://www.five-ten-sg.com/libpst/"
+SRC_URI="http://www.five-ten-sg.com/${PN}/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug dii doc python static-libs"
+
+RDEPEND="dii? ( media-gfx/imagemagick[png] )
+ gnome-extra/libgsf"
+DEPEND="${RDEPEND}
+ virtual/libiconv
+ virtual/pkgconfig
+ dii? ( media-libs/gd[png] )
+ python? ( >=dev-libs/boost-1.48[python] )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # don't build the static python library
+ epatch "${FILESDIR}"/${PN}-0.6.52-no-static-python-lib.patch
+
+ # fix pkgconfig file for static linking
+ epatch "${FILESDIR}"/${PN}-0.6.53-pkgconfig-static.patch
+
+ # conditionally install the extra documentation
+ use doc || { sed -i -e "/SUBDIRS/s: html::" Makefile.am || die; }
+
+ # don't install duplicate docs
+ sed -i -e "/^html_DATA =/d" Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-libpst-shared \
+ $(use_enable debug pst-debug) \
+ $(use_enable dii) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use python && echo --with-boost-python=boost_python-${PYTHON_ABI})
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}