summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-22 09:06:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-22 09:06:06 +0000
commit4febe28fd625a63ed8c3c774963147ec6c459fcb (patch)
tree87587e0f56c26ea6782b413d26efe16d7c1991e7 /net-mail/libpst
parentadd pkgconfig dep (diff)
downloadgentoo-2-4febe28fd625a63ed8c3c774963147ec6c459fcb.tar.gz
gentoo-2-4febe28fd625a63ed8c3c774963147ec6c459fcb.tar.bz2
gentoo-2-4febe28fd625a63ed8c3c774963147ec6c459fcb.zip
Bump to 0.6.38, python bits disabled for now. Fixes #274187.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/libpst')
-rw-r--r--net-mail/libpst/ChangeLog7
-rw-r--r--net-mail/libpst/libpst-0.6.38.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-mail/libpst/ChangeLog b/net-mail/libpst/ChangeLog
index e35cfd84c1e5..e398a81a7509 100644
--- a/net-mail/libpst/ChangeLog
+++ b/net-mail/libpst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/libpst
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.15 2009/06/15 03:54:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.16 2009/06/22 09:06:06 patrick Exp $
+
+*libpst-0.6.38 (22 Jun 2009)
+
+ 22 Jun 2009; Patrick Lauer <patrick@gentoo.org> +libpst-0.6.38.ebuild:
+ Bump to 0.6.38, python bits disabled for now. Fixes #274187.
15 Jun 2009; Jeroen Roovers <jer@gentoo.org> libpst-0.6.37.ebuild:
Marked ~hppa (bug #271002).
diff --git a/net-mail/libpst/libpst-0.6.38.ebuild b/net-mail/libpst/libpst-0.6.38.ebuild
new file mode 100644
index 000000000000..6ae07ef9b087
--- /dev/null
+++ b/net-mail/libpst/libpst-0.6.38.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.6.38.ebuild,v 1.1 2009/06/22 09:06:06 patrick Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://www.five-ten-sg.com/libpst/"
+SRC_URI="http://www.five-ten-sg.com/${PN}/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~x86"
+IUSE="debug"
+
+# newest version optionally pulls in boost for py bindings
+RDEPEND="media-libs/gd[png]
+ media-gfx/imagemagick[png]"
+ #>=dev-libs/boost-1.35.0-r5[python]"
+DEPEND="${RDEPEND}"
+
+# we disable the python bindings for now. Feel free to fix the configure script to know about py 2.6 and
+# such advanced concepts ...
+src_configure() {
+ econf \
+ $(use_enable debug pst-debug) \
+ --enable-libpst-shared \
+ --disable-python
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS TODO || die "dodoc failed"
+}