summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-28 23:43:27 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-28 23:43:27 +0000
commit4ac46783082aea17bd8cb9d8a1e2a81d9cccc717 (patch)
treefe509e6abaddd763ec0e96da5089c5652c40c4fe /net-mail/libpst
parentVersion bump (diff)
downloadgentoo-2-4ac46783082aea17bd8cb9d8a1e2a81d9cccc717.tar.gz
gentoo-2-4ac46783082aea17bd8cb9d8a1e2a81d9cccc717.tar.bz2
gentoo-2-4ac46783082aea17bd8cb9d8a1e2a81d9cccc717.zip
Version bump. Update to EAPI 4, add doc and static-libs USE flags, and don't install the static python library and libtool archive file (bug #298881 by Diego Elio Pettenò and Kacper Kowalik).
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/libpst')
-rw-r--r--net-mail/libpst/ChangeLog12
-rw-r--r--net-mail/libpst/files/libpst-0.6.52-no-static-python-lib.patch11
-rw-r--r--net-mail/libpst/libpst-0.6.52.ebuild50
3 files changed, 71 insertions, 2 deletions
diff --git a/net-mail/libpst/ChangeLog b/net-mail/libpst/ChangeLog
index ba157a4ee3bb..2ffa568f382b 100644
--- a/net-mail/libpst/ChangeLog
+++ b/net-mail/libpst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/libpst
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.22 2009/12/21 15:38:37 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.23 2011/05/28 23:43:26 radhermit Exp $
+
+*libpst-0.6.52 (28 May 2011)
+
+ 28 May 2011; Tim Harder <radhermit@gentoo.org> +libpst-0.6.52.ebuild,
+ +files/libpst-0.6.52-no-static-python-lib.patch:
+ Version bump. Update to EAPI 4, add doc and static-libs USE flags, and don't
+ install the static python library and libtool archive file (bug #298881 by
+ Diego Elio Pettenò and Kacper Kowalik).
21 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> libpst-0.6.41.ebuild,
+files/libpst-0.6.41-asneeded.patch:
diff --git a/net-mail/libpst/files/libpst-0.6.52-no-static-python-lib.patch b/net-mail/libpst/files/libpst-0.6.52-no-static-python-lib.patch
new file mode 100644
index 000000000000..5bf53c6dd81c
--- /dev/null
+++ b/net-mail/libpst/files/libpst-0.6.52-no-static-python-lib.patch
@@ -0,0 +1,11 @@
+--- libpst-0.6.52/python/Makefile.am.orig
++++ libpst-0.6.52/python/Makefile.am
+@@ -8,7 +8,7 @@
+
+ pythonlibdir = $(libdir)/@PYTHON_VERSION@/site-packages
+ pythonlib_LTLIBRARIES = _libpst.la
+-_libpst_la_LDFLAGS = -module $(NO_UNDEFINED) -avoid-version
++_libpst_la_LDFLAGS = -module $(NO_UNDEFINED) -avoid-version -shared
+ _libpst_la_SOURCES = python-libpst.cpp
+ _libpst_la_LIBADD = -lboost_python ../src/libpst.la
+
diff --git a/net-mail/libpst/libpst-0.6.52.ebuild b/net-mail/libpst/libpst-0.6.52.ebuild
new file mode 100644
index 000000000000..9a97ba4e41a0
--- /dev/null
+++ b/net-mail/libpst/libpst-0.6.52.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.6.52.ebuild,v 1.1 2011/05/28 23:43:26 radhermit Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://www.five-ten-sg.com/libpst/"
+SRC_URI="http://www.five-ten-sg.com/${PN}/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug dii doc python static-libs"
+
+RDEPEND="dii? ( media-gfx/imagemagick[png] )"
+DEPEND="${RDEPEND}
+ virtual/libiconv
+ dii? ( media-libs/gd[png] )
+ python? ( >=dev-libs/boost-1.35.0-r5[python] )"
+
+src_prepare() {
+ # Don't build the static python library
+ epatch "${FILESDIR}"/${P}-no-static-python-lib.patch
+
+ # Conditionally install the extra documentation
+ use doc || sed -i -e "/SUBDIRS/s: html::" Makefile.am
+
+ eautomake
+}
+
+src_configure() {
+ econf \
+ --enable-libpst-shared \
+ $(use_enable debug pst-debug) \
+ $(use_enable dii) \
+ $(use_enable python) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove useless python .la files (bug #298881)
+ find "${ED}" -name '_libpst.la' -exec rm {} +
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm {} +
+}