summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-09-23 16:45:18 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-09-23 16:45:18 +0000
commit2ade78aec03c1b91ed4280825e5899ce357e13cf (patch)
treeb712519abf221344a1fa916d9b63d7a1b3f96b2e /net-mail/libpst
parentremoving the gtkmm-2.12 mask (diff)
downloadgentoo-2-2ade78aec03c1b91ed4280825e5899ce357e13cf.tar.gz
gentoo-2-2ade78aec03c1b91ed4280825e5899ce357e13cf.tar.bz2
gentoo-2-2ade78aec03c1b91ed4280825e5899ce357e13cf.zip
Version bump to 0.5.2. Fixes bug 180001.
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-mail/libpst')
-rw-r--r--net-mail/libpst/ChangeLog8
-rw-r--r--net-mail/libpst/files/digest-libpst-0.5.23
-rw-r--r--net-mail/libpst/files/libpst-0.5.2-gentoo.diff110
-rw-r--r--net-mail/libpst/libpst-0.5.2.ebuild35
4 files changed, 155 insertions, 1 deletions
diff --git a/net-mail/libpst/ChangeLog b/net-mail/libpst/ChangeLog
index 09567712eb1c..15c57f3c59b8 100644
--- a/net-mail/libpst/ChangeLog
+++ b/net-mail/libpst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/libpst
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.8 2007/02/09 04:38:09 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.9 2007/09/23 16:45:18 philantrop Exp $
+
+*libpst-0.5.2 (23 Sep 2007)
+
+ 23 Sep 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/libpst-0.5.2-gentoo.diff, +libpst-0.5.2.ebuild:
+ Version bump to 0.5.2.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-mail/libpst/files/digest-libpst-0.5.2 b/net-mail/libpst/files/digest-libpst-0.5.2
new file mode 100644
index 000000000000..5512006d2546
--- /dev/null
+++ b/net-mail/libpst/files/digest-libpst-0.5.2
@@ -0,0 +1,3 @@
+MD5 0a80562bf7c503f9d3fdd96e0de10408 libpst-0.5.2.tar.gz 89256
+RMD160 fc4e0976841f7a4da21f0c2d77e126d27e00a641 libpst-0.5.2.tar.gz 89256
+SHA256 1e4a0e7a8d1572e8fe77c62a0e747b832bb93814fd1df624077ad0f879477857 libpst-0.5.2.tar.gz 89256
diff --git a/net-mail/libpst/files/libpst-0.5.2-gentoo.diff b/net-mail/libpst/files/libpst-0.5.2-gentoo.diff
new file mode 100644
index 000000000000..7c0daff7eb62
--- /dev/null
+++ b/net-mail/libpst/files/libpst-0.5.2-gentoo.diff
@@ -0,0 +1,110 @@
+diff -urN libpst-0.5.1.orig/libpst.c libpst-0.5.1/libpst.c
+--- libpst-0.5.1.orig/libpst.c 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/libpst.c 2004-12-16 00:06:24.630215120 -0500
+@@ -261,7 +261,7 @@
+ int32_t pst_attach_to_file(pst_file *pf, pst_item_attach *attach, FILE* fp) {
+ pst_index_ll *ptr;
+ struct holder h = {NULL, fp, 0, "", 0};
+- int32_t size;
++ int32_t size = 0;
+ DEBUG_ENT("pst_attach_to_file");
+ if (attach->id_val != -1) {
+ ptr = _pst_getID(pf, attach->id_val);
+@@ -283,7 +283,7 @@
+ int32_t pst_attach_to_file_base64(pst_file *pf, pst_item_attach *attach, FILE* fp) {
+ pst_index_ll *ptr;
+ struct holder h = {NULL, fp, 1, "", 0};
+- int32_t size;
++ int32_t size = 0;
+ char *c;
+ DEBUG_ENT("pst_attach_to_file_base64");
+ if (attach->id_val != -1) {
+@@ -373,10 +373,10 @@
+ pst_desc_ll *p;
+ pst_num_array *na;
+ // pst_index_ll *list;
+- pst_index2_ll *list2;//, *t;
++ pst_index2_ll *list2 = NULL;//, *t;
+ unsigned char * buffer=NULL, *headerbuffer=NULL;//, *tc;
+ pst_x_attrib xattrib;
+- int32_t bptr = 0, bsize, hsize, tint, err=0, x;
++ int32_t bptr = 0, bsize=0, hsize=0, tint, err=0, x;
+ pst_x_attrib_ll *ptr, *p_head=NULL, *p_sh=NULL, *p_sh2=NULL;
+ char *wt;
+
+diff -urN libpst-0.5.1.orig/lspst.c libpst-0.5.1/lspst.c
+--- libpst-0.5.1.orig/lspst.c 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/lspst.c 2004-12-16 00:08:07.554568240 -0500
+@@ -37,7 +37,10 @@
+ char *rfc2426_escape(char *str);
+ char *rfc2445_datetime_format(FILETIME *ft);
+ // }}}1
+-#define DEBUG_MAIN(x) debug_print x;
++#ifdef DEBUG_MAIN
++# undef DEBUG_MAIN
++# define DEBUG_MAIN(x) debug_print x;
++#endif /* DEBUG_MAIN */
+ // int main(int argc, char** argv) {{{1
+ int main(int argc, char** argv) {
+
+@@ -47,7 +50,7 @@
+ pst_desc_ll *d_ptr;
+ char *temp = NULL; //temporary char pointer
+ int skip_child = 0;
+- struct file_ll *f, *head;
++ struct file_ll *f = NULL, *head = NULL;
+ // }}}2
+
+ if (argc <= 1)
+diff -urN libpst-0.5.1.orig/Makefile libpst-0.5.1/Makefile
+--- libpst-0.5.1.orig/Makefile 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/Makefile 2004-12-16 00:12:08.190985944 -0500
+@@ -1,7 +1,8 @@
+ #!/usr/bin/make -f
+
+-CFLAGS ?= -g -Wall
+-PREFIX ?= /usr/local
++CC ?= gcc
++CFLAGS += -Wall
++PREFIX ?= /usr
+ INSTALL ?= install
+
+ #---------------- Do not modify below this point ------------------
+@@ -58,8 +59,6 @@
+ $(INSTALL_PROGRAM) readpst{,log} $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/share/man/man1
+ $(INSTALL_FILE) readpst{,log}.1 $(DESTDIR)$(PREFIX)/share/man/man1/
+- $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/share/doc/libpst
+- $(INSTALL_FILE) $(DOCS) $(DESTDIR)$(PREFIX)/share/doc/libpst/
+
+ uninstall:
+ -rm -f $(DESTDIR)$(PREFIX)/bin/readpst{,log}
+diff -urN libpst-0.5.1.orig/readpst.c libpst-0.5.1/readpst.c
+--- libpst-0.5.1.orig/readpst.c 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/readpst.c 2004-12-15 23:59:05.334998144 -0500
+@@ -144,7 +144,7 @@
+ int base64_body = 0;
+ // int encrypt = 0;
+ FILE *fp;
+- char *enc; // base64 encoded attachment
++ char *enc = NULL; // base64 encoded attachment
+ char *boundary = NULL, *b1, *b2; // the boundary marker between multipart sections
+ char *temp = NULL; //temporary char pointer
+ int attach_num = 0;
+diff -urN libpst-0.5.1.orig/readpstlog.c libpst-0.5.1/readpstlog.c
+--- libpst-0.5.1.orig/readpstlog.c 2004-12-15 23:23:52.000000000 -0500
++++ libpst-0.5.1/readpstlog.c 2004-12-16 00:04:38.368369376 -0500
+@@ -21,11 +21,11 @@
+
+ int main(int argc, char** argv) {
+ int *i=NULL, x, ptr, stop=0, flag;
+- char *fname, *buf, format, rec_type;
++ char *fname, *buf, format=0, rec_type;
+ unsigned char version;
+ int *show_type=NULL, show_size=0;
+ int *ex_type=NULL, ex_size=0;
+- unsigned int funcname, filename, text, end, dtype, line, c;
++ unsigned int funcname=0, filename=0, text=0, end=0, dtype=0, line=0, c=0;
+ FILE *fp;
+ struct _debug_file_rec_m mfile_rec;
+ struct _debug_file_rec_l lfile_rec;
diff --git a/net-mail/libpst/libpst-0.5.2.ebuild b/net-mail/libpst/libpst-0.5.2.ebuild
new file mode 100644
index 000000000000..1e31902117a0
--- /dev/null
+++ b/net-mail/libpst/libpst-0.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.5.2.ebuild,v 1.1 2007/09/23 16:45:18 philantrop Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://alioth.debian.org/projects/libpst/"
+SRC_URI="http://alioth.debian.org/download.php/844/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-0.5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS CREDITS TODO FILE-FORMAT || die "dodoc failed"
+ dohtml FILE-FORMAT.html || die "dohtml failed"
+}