summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-05-21 06:07:56 +0000
committerTorsten Veller <tove@gentoo.org>2007-05-21 06:07:56 +0000
commit8f23e1e3db9ba50395b5d5be75ac6334acb8399c (patch)
tree23d64f44b88ce3c1a6dcabb49f7a7805f9fc075e /net-mail/lbdb
parentrevert previous change and make a revbump instead (diff)
downloadgentoo-2-8f23e1e3db9ba50395b5d5be75ac6334acb8399c.tar.gz
gentoo-2-8f23e1e3db9ba50395b5d5be75ac6334acb8399c.tar.bz2
gentoo-2-8f23e1e3db9ba50395b5d5be75ac6334acb8399c.zip
Version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-mail/lbdb')
-rw-r--r--net-mail/lbdb/ChangeLog7
-rw-r--r--net-mail/lbdb/files/digest-lbdb-0.353
-rw-r--r--net-mail/lbdb/lbdb-0.35.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/net-mail/lbdb/ChangeLog b/net-mail/lbdb/ChangeLog
index 40839fc93155..b8a7878747ad 100644
--- a/net-mail/lbdb/ChangeLog
+++ b/net-mail/lbdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/lbdb
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.33 2007/02/20 21:57:50 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.34 2007/05/21 06:07:56 tove Exp $
+
+*lbdb-0.35 (21 May 2007)
+
+ 21 May 2007; Torsten Veller <tove@gentoo.org> +lbdb-0.35.ebuild:
+ Version bump
20 Feb 2007; Matti Bickel <mabi@gentoo.org> lbdb-0.34.ebuild:
ppc stable (bug #161400)
diff --git a/net-mail/lbdb/files/digest-lbdb-0.35 b/net-mail/lbdb/files/digest-lbdb-0.35
new file mode 100644
index 000000000000..663d862cff89
--- /dev/null
+++ b/net-mail/lbdb/files/digest-lbdb-0.35
@@ -0,0 +1,3 @@
+MD5 334ed4b24b49000d6495ca0883b86275 lbdb_0.35.tar.gz 108378
+RMD160 e669c270c6ddab971ed17712e9519d4a20886900 lbdb_0.35.tar.gz 108378
+SHA256 dee9faa1bccac53db128615e8a06bb1003797b3fb2403df429121a21128f38a6 lbdb_0.35.tar.gz 108378
diff --git a/net-mail/lbdb/lbdb-0.35.ebuild b/net-mail/lbdb/lbdb-0.35.ebuild
new file mode 100644
index 000000000000..08b84654d446
--- /dev/null
+++ b/net-mail/lbdb/lbdb-0.35.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/lbdb-0.35.ebuild,v 1.1 2007/05/21 06:07:56 tove Exp $
+
+inherit eutils
+
+IUSE="pda ldap finger nis abook crypt evo"
+
+MY_P=${P/-/_}
+DESCRIPTION="Little Brother database"
+SRC_URI="http://www.spinnaker.de/debian/${MY_P}.tar.gz"
+HOMEPAGE="http://www.spinnaker.de/lbdb/"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+DEPEND="mail-client/mutt
+ evo? ( mail-client/evolution )
+ finger? ( net-misc/netkit-fingerd )
+ abook? ( app-misc/abook )
+ crypt? ( app-crypt/gnupg )
+ nis? ( net-nds/yp-tools )"
+RDEPEND="${DEPEND}
+ pda? ( dev-perl/p5-Palm )
+ ldap? ( dev-perl/perl-ldap )"
+
+src_compile() {
+ local evoversion
+ local evolution_addressbook_export
+
+ if useq evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ evolution_addressbook_export="/usr/libexec/evolution/${evoversion:0:3}/evolution-addressbook-export"
+ fi
+
+ econf $(use_with finger) \
+ $(use_with abook) \
+ $(use_with nis ypcat) \
+ $(use_with crypt gpg) \
+ $(use_with evo evolution-addressbook-export "${evolution_addressbook_export}" ) \
+ --without-pgp5 --without-pgp \
+ --without-niscat --without-addr-email --with-getent \
+ --libdir=/usr/$(get_libdir)/lbdb || die
+ emake || die
+}
+
+src_install () {
+ emake install_prefix="${D}" install || die
+ dodoc README TODO debian/changelog
+}