summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-10-02 21:23:01 +0000
committerAron Griffis <agriffis@gentoo.org>2006-10-02 21:23:01 +0000
commit79517369a90a494d98a16ef9fcf0bb70ed5ea308 (patch)
tree6e36e521db8f03c695cca186db974fb3047bd737 /net-mail/gnubiff
parentenable sysroot support for mingw (diff)
downloadgentoo-2-79517369a90a494d98a16ef9fcf0bb70ed5ea308.tar.gz
gentoo-2-79517369a90a494d98a16ef9fcf0bb70ed5ea308.tar.bz2
gentoo-2-79517369a90a494d98a16ef9fcf0bb70ed5ea308.zip
Update 2.1.9 ebuild to include fixes from 2.2.1 ebuild, and fix
password-saving support #133853 (Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-mail/gnubiff')
-rw-r--r--net-mail/gnubiff/ChangeLog6
-rw-r--r--net-mail/gnubiff/gnubiff-2.1.9.ebuild33
2 files changed, 23 insertions, 16 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index c9280cd2a75a..ccb024d19365 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/gnubiff
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.11 2006/10/02 21:19:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.12 2006/10/02 21:23:01 agriffis Exp $
+
+ 02 Oct 2006; Aron Griffis <agriffis@gentoo.org> gnubiff-2.1.9.ebuild:
+ Update 2.1.9 ebuild to include fixes from 2.2.1 ebuild, and fix
+ password-saving support #133853
*gnubiff-2.2.1 (02 Oct 2006)
diff --git a/net-mail/gnubiff/gnubiff-2.1.9.ebuild b/net-mail/gnubiff/gnubiff-2.1.9.ebuild
index bb381889e79a..40da7d50762b 100644
--- a/net-mail/gnubiff/gnubiff-2.1.9.ebuild
+++ b/net-mail/gnubiff/gnubiff-2.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.1.9.ebuild,v 1.3 2006/10/02 21:19:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.1.9.ebuild,v 1.4 2006/10/02 21:23:01 agriffis Exp $
inherit eutils
@@ -10,30 +10,33 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
-IUSE="gnome nls password"
+IUSE="fam gnome nls password"
RDEPEND=">=x11-libs/gtk+-2.4
>=gnome-base/libglade-2.3
- gnome? ( >=gnome-base/libgnome-2.2
+ dev-libs/popt
+ gnome? (
+ >=gnome-base/libgnome-2.2
>=gnome-base/libgnomeui-2.2 )
- virtual/fam"
-
+ password? ( dev-libs/openssl )
+ fam? ( virtual/fam )
+ || (
+ x11-proto/xproto
+ virtual/x11 )"
DEPEND="${RDEPEND}
gnome? ( dev-util/pkgconfig )"
src_compile() {
- local myconf
-
- if use password; then
- einfo "generating random password"
- myconf="${myconf} --with-password --with-password-string=${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
- fi
-
- econf $(use_enable gnome) $(use_enable nls) || die
- emake || die
+ econf $(use_enable gnome) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM}) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO
}