summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-05-22 20:18:30 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-05-22 20:18:30 +0000
commit3a0bfc892247da7c5ed748a3de61a0c7f15144a3 (patch)
treeed611354d5415055a03ef4310f1484c102e9b68f /net-mail/gnubiff
parentClean up and change dep on dev-db/mysql to virtual/mysql (i.e. mysql-communit... (diff)
downloadgentoo-2-3a0bfc892247da7c5ed748a3de61a0c7f15144a3.tar.gz
gentoo-2-3a0bfc892247da7c5ed748a3de61a0c7f15144a3.tar.bz2
gentoo-2-3a0bfc892247da7c5ed748a3de61a0c7f15144a3.zip
Version bump, #268503
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/gnubiff')
-rw-r--r--net-mail/gnubiff/ChangeLog8
-rw-r--r--net-mail/gnubiff/gnubiff-2.1.3.ebuild46
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.11.ebuild41
3 files changed, 48 insertions, 47 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index 4f5ee985c43e..716613a7e413 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/gnubiff
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.23 2009/02/14 23:33:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.24 2009/05/22 20:18:30 dertobi123 Exp $
+
+*gnubiff-2.2.11 (22 May 2009)
+
+ 22 May 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ -gnubiff-2.1.3.ebuild, +gnubiff-2.2.11.ebuild:
+ Version bump, #268503
14 Feb 2009; Markus Meier <maekke@gentoo.org> gnubiff-2.2.10.ebuild:
amd64/x86 stable, bug #245679
diff --git a/net-mail/gnubiff/gnubiff-2.1.3.ebuild b/net-mail/gnubiff/gnubiff-2.1.3.ebuild
deleted file mode 100644
index e0a17989ce93..000000000000
--- a/net-mail/gnubiff/gnubiff-2.1.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.1.3.ebuild,v 1.8 2008/03/14 10:07:57 phreak Exp $
-
-inherit eutils
-
-DESCRIPTION="A mail notification program"
-HOMEPAGE="http://gnubiff.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 x86"
-IUSE="gnome password"
-
-RDEPEND="virtual/libc
- >=x11-libs/gtk+-2.4
- >=gnome-base/libglade-2.3
- gnome? ( >=gnome-base/libgnome-2.2
- >=gnome-base/libgnomeui-2.2 )
- virtual/fam"
-
-DEPEND="${RDEPEND}
- gnome? ( dev-util/pkgconfig )"
-
-src_compile() {
- local myconf
-
- if use gnome; then
- myconf="${myconf} --prefix=`pkg-config libpanelapplet-2.0 --variable=prefix`"
- else
- myconf="${myconf} --disable-gnome"
- fi
-
- if use password; then
- einfo "generating random password"
- myconf="${myconf} --with-password --with-password-string=${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
- fi
-
- econf ${myconf} || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
-}
diff --git a/net-mail/gnubiff/gnubiff-2.2.11.ebuild b/net-mail/gnubiff/gnubiff-2.2.11.ebuild
new file mode 100644
index 000000000000..0ecff4fc4ee2
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.11.ebuild,v 1.1 2009/05/22 20:18:30 dertobi123 Exp $
+
+inherit base eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="debug fam gnome nls password"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ gnome? (
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2 )
+ password? ( dev-libs/openssl )
+ fam? ( virtual/fam )
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable gnome) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM}) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}